-   Linux - Laptop and Netbook (
-   -   EEEPC 1005HAB resolution (

n_spect_r 04-19-2012 08:51 PM

EEEPC 1005HAB resolution
I have an EEEPC and decided to ditch windows for Zorin. Everything I do on this can be done with Zorin so in that aspect things are good. I do not like the screen resolution though. I ran xrandr from terminal and it shows res from 320 x 200 to 4096 x 4096. In the settings I only have choices of 640 x 480, 800 x 600, 1024 x 600.
I would like to try some different settings, some windows get cut off either on top or bottom. I looked for an xorg.conf, did not find one.
Been playing with this for about 10 days, the learning curve is pretty steep. I do not plan to go back to windows though.

RockDoctor 04-20-2012 12:27 PM

You may need a custom xorg.conf file (or the appropriate fragments in /etc/X11/xorg.conf.d). As root, in a terminal window, the command

Xorg :1 -configure
will create the rile /root/ Edit this file as needed, and save it as /etc/X11/xorg.conf. Restart X, and your new xorg.conf file should be used. I used commands of the form

gtf x y refresh
(run in a terminal window as a normal user) to generate the appropriate modelines. I did a fair amount of editing of /root/ to generate my current xorg.conf file, which I show here for illustration purposes only:

Section "ServerLayout"
        Identifier    " Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
        ModulePath  "/usr/lib64/xorg/modules"
        FontPath    "catalogue:/etc/X11/fontpath.d"
        FontPath    "built-ins"

Section "Module"
        Load  "dri2"
        Load  "dbe"
        Load  "glx"
        Load  "extmod"
        Load  "record"
        Load  "dri"

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"

Section "Monitor"

        #UseModes    "Modes0" #monitor0usemodes
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "Monitor Model"
        DisplaySize  432        270
        HorizSync    30.0 - 86.0
        VertRefresh  56.0 - 76.0
        ModeLine    "1440x900" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
        ModeLine    "1680x1050" 147.1 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
        Modeline    "1920x1080"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
        Option            "PreferredMode" "1680x1050"

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "SWcursor"                  # [<bool>]
        #Option    "HWcursor"                  # [<bool>]
        #Option    "NoAccel"                    # [<bool>]
        #Option    "ShadowFB"                  # [<bool>]
        #Option    "VideoKey"                  # <i>
        #Option    "EXAPixmaps"                # [<bool>]
        Option            "IgnoreEDID"  "TRUE"
        Identifier  "Card0"
        Driver      "nouveau"
        VendorName  "nVidia Corporation"
        BoardName  "Unknown Board"
        BusID      "PCI:2:0:0"

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport  0 0
                Depth    24
        Option "IgnoreEDID" "TRUE"
                Modes    "1920x1080" "1680x1050" "1440x900" "1280x1024"

Section "Extensions"
        Option            "Composite" "Enable"
        Option            "Compositing" "Enable"

n_spect_r 04-20-2012 05:37 PM

Thanks for the help. I am learning but still quite confused.
Created the Xorg.conf and ran gtf x y refresh

I have no idea what to do with this now.
# 0x0 @ 0.00 Hz (GTF) hsync: -nan kHz; pclk: -nan MHz
Modeline "0x0_0.00" -nan 0 -2147483648 -2147483648 -2147483648 0 1 4 1 -HSync +Vsync

Looking over the example file you posted, I will try to figure out what to do next.

RockDoctor 04-20-2012 07:11 PM

Here's how I got the 1680x1050 info:

~$ gtf 1680 1050 60

  # 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
  Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync

The line beginning with the hash mark (#) is a comment. The Modeline went into the Monitor section of my xorg.conf with the mode's name slightly edited - I changed the "1680x1050_60.00" in the gtf output to "1680x1050". I then added a "1680x1050" mode in the screen section, so that my monitor would actually use this mode.

n_spect_r 04-26-2012 03:19 AM

I want to say thanks for your help although I never could get the xorg.conf to work. I did however stumble upon a tray application called Jupiter that tweaks several hardware/software items including screen resolution to 1024x768. So with the exception of file sharing still causing fits things are pretty good.

All times are GMT -5. The time now is 11:05 PM.