-   Linux - Laptop and Netbook (
-   -   Each time my laptop is put to sleep, the keyboard doesn't work upon awake. (

Nicolas.Perrault 12-31-2009 09:24 PM

Each time my laptop is put to sleep, the keyboard doesn't work upon awake.
Each time my laptop is put to sleep, the keyboard doesn't work upon awake.
I run Ubuntu 9.10 on a Sony Vaio VGN-CSJ390.

Thanks for your help!


Carsto 01-02-2010 07:41 AM

Known problem with the Aspire as well.
Do some searching and on Linuxforums as well. Look under my posts of about a month ago. I have now re-installed Fedora Core 11 and still have to do three taps on the Kb to get it to wake up properly. It's like your cell phone. There are other posts as well - with other solutions. For the moment I am living with it.

Keep looking. Good Luck!!

vansch76 01-03-2010 06:46 PM


Are you using hibernate or suspend?
Hibernate doesnt always work correctly in Ubuntu.
I had to switch mine to suspend.
You should try that as let us know what happens.
Its under system/perferences/powermanagement


Nicolas.Perrault 01-06-2010 07:40 PM

Well, the funny thing is, the keyboard is completly dead after hibernating or suspending. It's not a few keys to press or something, it's simply dead. I use the DVORAK simplified keyboard (instead of QWERTY) if that is any help. Please note that this is a laptop.

Thanks in advance, Nick.

vansch76 01-08-2010 07:15 PM


Have you tried to re-map your keyboard to qwerty and re-test it.
It may be a Dvorak issue.


Nicolas.Perrault 06-14-2010 05:56 PM

Yeah, it's not only a Dvorak issue, I've tested it. I'm running Ubuntu 10.04 now, and the problem persists. The problem also exists under Debian 5.04.

Thanks again, and sorry for the 6-month delay...


Nicolas.Perrault 12-03-2010 09:59 PM

Another 6 months has gone by and the problem persists. The same computer is running on Ubuntu 10.10. Ubuntu was never fresh installed, and I still have some inactive Karmic repositories, but as mentioned above, Debian had the same problem.

Any suggestions?

Nicolas.Perrault 07-31-2011 08:10 AM

I know this is the third time I bump, but it's been like a year and a half...
I'm running debian again now, the problem still persists.

Nicolas.Perrault 09-12-2012 07:22 PM

If a solution exists...
As of now, I'm running Ubuntu 12.04 with the MATE (GNOME 2) Graphical User Environment.
The problem is so persistent, it has to be some deeply hardware related problem.

Nicolas.Perrault 06-30-2013 09:49 AM

Come on guys :) Any solution?
Also, each time I have a USB mouse plugged in, the right button stops working after about 20 minutes.

Nicolas.Perrault 08-18-2013 02:44 PM

I'm the loneliest person on the boards!
Bumping is becoming my game.
Also, may I receive a reply?

Resistor1 09-13-2013 12:19 AM


Originally Posted by Nicolas.Perrault (Post 5011506)
I'm the loneliest person on the boards!
Bumping is becoming my game.
Also, may I receive a reply?

You are not alone. I'm running Linux Mint 15 on a new Dell 15z. First, I wiped Win8 while trying to install LM15, which never saw Win8, due to uEFI. Then, I proceeded to wipe the GPT/MBR a couple of times.

Now, I'm running LM15 from one of 3 USB devices, configuring the browser and a few other settings, on each boot.

I generally suspend at the end of the session, but can do this only one time, due to the ramdrive, I suspect.

The dead keyboard is an intermittent thing and it is a battle to get things configured and running, before it dies. I don't know if restarting Cinnimon makes a difference, after I flip the panel from bottom to top.

It seems to makes a difference, but I'm a trucker and not sure about anythng I'm doing with a computer, these days.

911InsideJob 09-13-2013 07:05 AM

I have an HP that does this occassionally. Pretty sure it's a driver issue with the quick access buttons but once the hardware locks it'll keep locking up unless I unplug, remove the battery and press power button (to discharge capacitors.) Then it starts sleeping and waking up normally again.

Resistor1 09-29-2013 05:48 PM

Reaching back to, I think, Linux Mint 9... There was a setting - maybe in Compiz or Meta City - to prevent other windows from stealing focus.

When I lose control of the cursor, I still have access to the arrow keys and can navigate to some extent, with the tab and shift-tab keys. The Enter key works, the Super L (Windows) key works and will bring up the menu. Escape works, as does some of the Function keys.

Sometimes, Control-Alt-Backspace will log out and present the log in screen. Control-Alt-Delete does not work, though.

I'm waiting for the next version of Mint, with great hope...

I'm hoping that the next version will overcome the jumpy cursor, as well. I now wear Jersey gloves with the fingers cut off, to provide some cursor stability, when typing. Nothing else seems to make a difference.

All times are GMT -5. The time now is 12:15 AM.