-   Linux - Laptop and Netbook (
-   -   Dual Boot Problem Windows 7 (64bit) and RHEL (

ashmab 01-04-2011 05:22 AM

Dual Boot Problem Windows 7 (64bit) and RHEL
Hi Guys,

Would appreciate if someone out there can help me to fix the problem.

I have got a hp laptop (dual core, i7) which came with Windows 7 preinstalled and use a data card to surf net.

1) i want to dual boot Win 7 with Linux (RHEL for 64bit. The necessary partitions are created and when my lappy boots with the RHEL CD, after i make a choice of installation, the machine hangs up with no progress.

My Query: how do i dual boot Win 7 (64bit) with RHEL.

2) As an alternative, i installed virtual machine and then went for RHEL on it, thank god! i am able to work with linux. But,i am not able to browse net via my data card as there are two network setup.

My Query: How to fix this network issue?

i have tried many alternatives to fix the above but hard luck. Is it that Hp laptops have problem dual booting Windows 7 and RHEL? Guess, there should be a way out.

Thanks in advance.

business_kid 01-04-2011 11:54 AM

Whats a 'lappy'? What's the error you get on boot? When you have no install cd/dvd in, what happens? What's the boot loader?

ashmab 01-07-2011 01:42 AM

Hi Business Kid,

Thanks for your response and sorry for being bit personal to call my laptop as "lappy".

Well, the error i receive when i try to boot up with RHEL cd (5.3, 64bit) and higher is something like below:

RIP [<ffffffff8014c621>]_list_add t0x2e/0x68
RSP <ffff810104737820>
<0>kernel panic - not syncing : Fatel exception

i tried with other RHEL versions but encountered the same error.

thanks again.

business_kid 01-08-2011 04:16 AM

I'm a grouch sometimes, that's all. Forget the laptop/lappy thing, an apology was not necessary.
That situation is crashed. The lines before 'cr2' and all the hex stuff would be interesting.

The kernel boots read only, finds the root drive, and starts init, which loads all the startup stuff. To get to init, you need the modules to drive your box in an initrd if they're not compiled into the kernel, and you need to have the correct root device specified on the boot line. You also need working hardware.

Check all of the above. If there's a module, it's not compiled in. I don't see the error "Unable to mount root device" (although you might) so you can probably eliminate that one.

All times are GMT -5. The time now is 10:57 AM.