-   Linux - Laptop and Netbook (
-   -   Display not comming back when Laptop Lid is opened (

shoekstr 10-10-2005 09:06 PM

Display not comming back when Laptop Lid is opened
I've had this problem on both of my laptops at some point in time.


When I close the lid on my laptop the display turns off I can see this throught the crack between my base and display which takes only a few seconds. But when I open the lid back up the display will not come back up I have to forceablly reboot the laptop.

Can any body help me I've narrowed this down to a Linux issue, since it works fine in windows xp and I've never had this problem with my old Dell Inspiron 8000 which I don't have anymore I also read this might be an apm or acpi problem but could not find a sure fix on this problem

Laptop 1

Dell Inspiron 8100
Nvidia Geforce2Go

Laptop 2

Toshiba Satelitte A20
Trident Based Display

Current Distro is FC3 upgrading to FC4

biophysics 10-11-2005 04:35 PM

Make sure your laptop does not suspend while closing the lid?

1. Run the ssh daemon in your laptop. Connect to your network. Now close the lid. Try connecting to your laptop from some other computer. If you are unable to connect then your laptop suspends/hibernates...

2. Check the directory /etc/acpi
and disable any scripts that put your laptop into suspend

(Note: This does not mean that your laptop does not support suspend - it is just that you have configure it to work correctly)

superchar42 10-12-2005 02:12 PM

I think it might be the suspend thing too. Mine does that if I close the lid, and I have to quickly hit the power button to get it back on.

Have you tried just hitting the power button?

shoekstr 10-12-2005 09:51 PM

I've done what you suggested biophysics I ssh'd it to the system when the lid and the display was closed and it was just like I was running my regular system remotely. I looked into the /etc/acpi directory and the only config file is the sample.conf file events subdirectory. The only command in the sample.conf file is to turn off the computer when the power button is pressed. And to awnser superchar42 comment the system goes throught the shut down process.

I found these entries in /var/log/messages right after I closed and opened the lid of the laptop

Oct 12 21:33:40 dell8100 kernel: video bus notify
Oct 12 21:33:52 dell8100 kernel: PCI: device 0000:07:00.0 has unknown header type 07, ignoring.
Oct 12 21:33:55 dell8100 kernel: video bus notify

Upon further testing the first "kernel: video bus notify" comes up after I close the lid

and the "kernel: PCI: device 0000:07:00.0 has unknown header type 07, ingoring." comes up after I open the lid

Does this have anything to do with my problem??

cyberjun 10-13-2005 08:29 AM

Have you tried switching consoles. CTRL+ALT+F1 and then CTRL+ALT+F7.

I have a toshiba satellite M30 laptop with Nvidia Go5200 card. Am using the latest 7676 driver from nvidia. When I close the lid
the monitor turns off and comes back on when I open it. However when I use dpms to switch it off, it doesn't come back on. No matter how many keys I press or move the mouse/tocuhpad. Then I have to do the console switch. Then everything is normal.

God knows when these nvidia guys will fix these display problems for ever.

I keep on upgrading to one driver after another in the hope that the new one will solve all the problems but..............

well try the console switch.


shoekstr 10-13-2005 09:11 AM

I tried it but nothing happened but the hdd light flashes a little and that's it

shoekstr 10-13-2005 10:48 AM

I went back to basics and installed slackware 10.2 on my troublesom laptop now the display comes back up but the screen gets split up on resume and I have to change screens to console to get my display back right

I'd keep this setup but I like the autodetection fedora core 2 has to offer.....

I forgot to mentions slackware is using 2.4.31 kernel

superchar42 10-13-2005 12:33 PM

A quick google turned up this forum, with the same problem and solution and I'll reprint what it says that he just hits Fn +F7 to get him out of it.

He was using a 2.6.7 kernel, though on Slack 10.

Here is also another forum with the display issue as well, and some conf files.

So maybe these will help. Either way, hopefully the google could point you in the right direction. edit: silly smilies taking over urls... gah.

shoekstr 10-13-2005 01:11 PM

I appriceate your suggestions but my problem is different I get the display just fine it's just when I open the lid it's like the vhold shifts to a different position. My questions is it the video driver of the acpi configs that are causing the problems?

VinnySem 10-14-2005 08:44 AM

I am having the EXACT same problem on my Dell Inspiron 6000 with SUSE 10.0. Graphics system is Intel 915GM.

I do not believe this has anything to do with power management. I have my laptop set up to not do anything when the lid is closed if the laptop is plugged in. The display turns off, then does not come back on when the lid is re-opened. If I were to close the lid at the login screen, I can still login (albeit I can't see what I'm typing), and the Gnome startup sound plays. KDE does the same thing. Also, hitting the key combo to switch displays has no effect.

Jimlas53 10-15-2005 07:23 PM

Display not coming back on
I also have a Dell Inspiron 6000 running FC4.
There were several other threads talking about the display off/on functions related to the lid, and a couple of scripts as well.
This seems to do the trick - in /etc/acpi/actions:

A script file named


# $Id: 3369 2005-07-08 20:19:40Z thias $

export XAUTHORITY=/var/gdm/\:0.Xauth

# When the display is "being closed", the state is already closed
if grep "closed" /proc/acpi/button/lid/LID/state; then
    xset -display :0 dpms force off

# When the display is "being opened", the state is already open
if grep "open" /proc/acpi/button/lid/LID/state; then
    xset -display :0 dpms force on

So far, the display correctly comes on when opening the lid - something it definitely didn't do before installation of the script.
I have not tried this on any other machine, this one runs Fedora Core 4, which may not be the same with other distros or even FC2.

Hope this helps


shoekstr 10-18-2005 09:40 AM

I Install the script but locations in proc don't exist in my kernel I'm trying to update to 2.6.13 and fix the missing entries in the kernel I'll let you know as soon as I get my kernel updated

shoekstr 10-23-2005 10:00 PM

Your script runs fine but it still darn display still doesn't come back.

Can any body tell me how to adjust the backlight in the console for the display?

Brian1 11-05-2005 05:45 PM

Look over this post.
Look at the scripts I have written in post#23.

Hope this helps.

mi2913jj 12-02-2005 03:14 PM

I'm having the same problem with my Dell Inspiron 8200. When I close my lid, the screen turns off. However, the screen will never turn on again when I open up the lid. I tried the power button and all of the keys. I have to force it reboot by holding down the power button for a few seconds.

I'm using Ubuntu 5.10.

All times are GMT -5. The time now is 06:59 PM.