-   Linux - Laptop and Netbook (
-   -   Disk Utility sees CD. Rhythmbox doesn't (

j2l11 03-01-2011 12:58 PM

Disk Utility sees CD. Rhythmbox doesn't
Ubuntu 10.10 on Toshiba Netbook. External CD Drive worked fine as boot drive when installing Ubuntu. Now I want to extract a music CD into Rythmbox, but "devices" never shows up in that ap. Nor is the drive visible in Places, though it is seen with Disk Utility. What am I missing here? Thanks in advance

Snark1994 03-01-2011 02:30 PM

As far as I recall, Rhythmbox doesn't rip CDs on its own. If you can do it through Rhythmbox, then it will be running another programme to do the ripping for it.

You can use sound-juicer - in Ubuntu it's named "Audio CD Extractor" in the menu, I believe :)

dwpbike 03-01-2011 08:25 PM

when you load the cd, does the system "see" it and ask how you want to open it?

purevw 03-01-2011 11:41 PM

Is the external CD set to mount automatically in "etc/fstab", or do you need to mount it manually? Perhaps your system is set up so that removable media is not auto-mounted, and possibly not even mountable by a normal user. You could try "sudo mount /dev/sr0" assuming your system sees the external disk as sr0.
Your laptop BIOS saw the drive as a boot device. That does not mean that Linux will automatically mount it. If it is not mounted, it won't be seen by most programs.

halon1301 03-02-2011 04:10 AM

Just a stab in the dark - I recall there being a user group called cdrom or cd. Does your unix user belong to one of these groups?

To check what groups your user is associated with execute this in console:

$ groups <your username>

j2l11 03-02-2011 10:28 AM

mounting CD problems
Thanks for the good suggestions. I think I am making progress. This is what I have done so far,

I tried "sudo mount /dev/sr0" with no success. I next tried:

sudo mkdir /media/CD
sudo mount /dev/cdrom /media/CD
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: you must specify the filesystem type

The drive still does not appear in Computer, but is seen by Disk Utility

Assuming this is progress, how do I find the "filesystem type" and what command do I use to enter that?


dwpbike 03-02-2011 01:44 PM

could you post/attach a screenshot of the cd/dvd drive portion of disk utility?

Gnuru-the-1 03-03-2011 01:56 AM

You might try
You might try
sudo mount -t iso9660 /dev/sr0 /media/CD

and make sure you "user" got reading rights in the area :-)

you might try to edit ore look on you´re
/etc/fstab if you're device is present there if it isn't then add it there and reboot....

All times are GMT -5. The time now is 01:42 AM.