Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 06-20-2013, 09:10 AM   #1
LQ Newbie
Registered: Jun 2013
Posts: 3

Rep: Reputation: Disabled
desktop icons disappeared mint maya

i have toshiba satellite m70 laptop. i installed double boot win xp and maya. everything ok, one day when i was shitting down a windows appared about such a process is running and cannot shut down, i forced. when i reboot my desktop icons and the title bar of the windows are disappeared and the wallpaper is black, i can see only start menu and if i open a terminal or other programs the windows with NO title bar with resize minimize buttons... what i could do? my resolution is ok, driver is ok. if i start a terminal and type xfdesktop the icons riappear but the title bar of the windows with the button to close resize the windows no. and when i reboot it is black again. please help
Old 06-20-2013, 07:49 PM   #2
LQ Guru
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 13,196
Blog Entries: 18

Rep: Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476Reputation: 3476
Here's an idea for testing.

Create a new user. If you can't start the GUI tools, you may have to do it from the command line with the adduser and passwd commands. Depending on how adduser works in Mint, you may have to manually create the /home/ for the new user.

Log out and log in as new user. If the desktop works for new user, it's something in the hidden (dot) config files for your desktop environment in your user's home directory. Since you didn't mention which DE you are using, I can't suggest which files to look at, but a little Googling should tell you.

If that's the case, the easiest fix would be to delete the config files for the DE, log out, and then log back in. The config files should get recreated and your desktop should be functional.

Another test would be, before logging in, to use the "Session" icon on the login screen to choose a different desktop, and see if the problem occurs under it. I have Mint Maya on a machine and it seems to have included Cinnamon, MATE, Gnome Fallback, though I'm using Enlightenment right now.

Good luck.

Last edited by frankbell; 06-20-2013 at 07:52 PM.
Old 06-21-2013, 03:05 AM   #3
LQ Newbie
Registered: Jun 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
solved but interested into your explanation

i solved thinking so...when i open terminal and type xfdesktop icons and wallpaper riapperas if i type xfwm4 title bar and resize button and close button reappear on the windows. but changes doesn't remain stable after reboot. i saw firefx also autostart. so i think a session saved...i went to menu to sessions and cleared cache and stardet the process and make autosave session. now every time is all ok. now i want to ask you about login... i have no login screen my sistem startup and display wallpaper and icons. no choose from cinnamon kde excetera...why? what are you talking about? thank you.
Old 06-21-2013, 08:11 PM   #4
LQ Guru
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,540

Rep: Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447Reputation: 1447
If you require password at login, you will see three icons at the bottom of the window where you enter your user name and password: Language, Session and Actions. Session will give you several Desktop environment options.

Apparently, you have autologin set so you don't get the option. If that's the case you need to click the Mint menu, up to System Settings and click it and then go to User Accounts and set Automatic Login to Off. Maybe there's another way, I don't know.
Old 06-23-2013, 03:31 AM   #5
LQ Newbie
Registered: Jun 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
thank you!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Linux Mint Maya Desktop JohnnyF Linux - Software 4 02-05-2013 01:39 AM
Boot parameters for Xserver (desktop) on Mint 13 (Maya) Please help. naps Linux Mint 8 11-27-2012 02:32 PM
LXer: The Perfect Desktop - Linux Mint 13 (Maya) LXer Syndicated Linux News 0 05-31-2012 04:20 PM
LXer: Linux Mint 13 LTS Maya Released: Come With Mate Desktop And Cinnamon Desktop LXer Syndicated Linux News 0 05-26-2012 02:00 PM
Desktop icons disappeared underlay Linux - Desktop 2 03-25-2008 03:17 PM > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 06:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration