-   Linux - Laptop and Netbook (
-   -   Desktop goes white after change to Radeon drivers on a ATI Radeon Mobility x600 (

Plasmarobo 03-27-2008 07:53 PM

Desktop goes white after change to Radeon drivers on a ATI Radeon Mobility x600
I'm Running Fedora 8 and I have just changed the drivers for my 'Unknown' Radeon Mobility x600 graphics card. I was ATTEMPTING to install the linva (or whatever) drivers but didn't see them in the Fedora display list (though they do exist on my system). The previous drivers were fglrx drivers, but graphics lagged and crashed when I tried to play 3D games (though compiz seemed to be reasonable) so I figured I'd try and upgrade. So I did the lvina rpm then yum installation with no visible effects (maybe a slightly better graphical performance, or slightly worse for compiz) so I went into the Display preferences (not too sure about the specific menu) and found a dialog that listed my monitor and my 'Unknown' graphics card. Ubuntu had picked it up fine, so I figured Fedora was just being unintelligent so I hit configure.

I noticed that fglrx drivers were selected, and decided to try and find my card. I found an ATI driver that didn't list my card, then I scrolled down and found a driver that conveniently enough claimed to work for All ATI cards including mobility's. I selected it and rebooted. I get the mouse, loadsplash and login screen. I login and I see my background (mouse is still here) for a second (no bars) then BAM background goes white. Mouse is still drawn. I can use compiz, but every face of the cube is white (except for the top, which has a nice Fedora logo).
I'm GUESSING that I just selected the wrong drivers, but I did an interactive start up and selected no for loading fglrx, but got the same story. I did a network install of fedora (my DVD burner died so I unloaded it on my server and did it from there, wheee) so I have no recovery media.

Is there a way to boot into bash and change the graphics drivers back?

petespin27 03-27-2008 11:09 PM

Here's what is happening:

White screen- compiz is enabled, but there is no 3d acceleration (I've had that experience before).

When you took out fglrx at interactive startup, all that happened was you did not load the kernel module. The kernel module enables things like 3d acceleration.

To get a fix (one method)- press ctrl-alt-f5 to get to a console. Log in as root and then edit /etc/X11/xorg.conf. Look for Section "Device" and change the driver to "fglrx". As an example from my own xorg.conf:


Section "Device"
BoardName "Framebuffer Graphics"
BusID "1:0:0"
Driver "fglrx"
Identifier "Device[0]"
Don't worry about the Board Name. This can be anything. Save the file and then reboot.
If you need help editing from a console, write back.

If everything comes back after a reboot, take a look at this thread for further information:

emilevdm 10-30-2008 09:59 AM

White screen and disabling desktop effects to recover
I had the same issue with another ATI card. The screen went white after enabling desktop effects.
According to ATI, it was a known problem with a driver version prior to 8.5, yet I'd installed version 8.10.

What solved the problem for me was to CTRL+ALT+F1, log in as root and run xgl-switch --enable-xgl.

Once I did that and restarted the display manager, it resolved the problem.

On this subject also - to recover from the white screen, you can disable compiz desktop effects by going to your home directory and deleting ~/.config/compiz/enable-compiz. Once the file is deleted and your display manager restarted, compiz will be disabled.

All times are GMT -5. The time now is 06:56 AM.