LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Dell Studio 1555 (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/dell-studio-1555-a-745983/)

ms-rathore 08-08-2009 03:09 AM

Dell Studio 1555
 
Hi !! friends

I bought Dell Studio 15 with 512 MB ATI mobolity Radeon HD 4570 & integrated sound. I have few problems with it.

1. I;m not able to play or hear any sound / music even though th sound icon on taskbar shows it is enabled.

2. I'm not able to use desktop effects, error message comes "desktop effects could not be enabled".

3. The bluetooth icon is show but it is disabled and even if u want to enable it, it doesn;t gets enabled.

4. The most important is, how to use Reliance netconnect USB modem on fedora 11.

Thanks

harry2006 08-08-2009 12:49 PM

sound issue is a know one with dell studio 1555, the one solution that works for most of the people is to add a single line to the end of this file,
/etc/modprobe.d/alsa-base
you append this to the end,
options snd-hda-intel model=dell-m6

the reason is that the systems is not able to detect the model and hence not able to load the corresponding drivers, i guess this should fix the problem.

HTH.

ms-rathore 08-09-2009 04:45 AM

Quote:

Originally Posted by harry2006 (Post 3635953)
sound issue is a know one with dell studio 1555, the one solution that works for most of the people is to add a single line to the end of this file,
/etc/modprobe.d/alsa-base
you append this to the end,
options snd-hda-intel model=dell-m6

the reason is that the systems is not able to detect the model and hence not able to load the corresponding drivers, i guess this should fix the problem.

HTH.

Thnaks buddy,..... it worked and not I can hear sound while playing movies and sonds... thanks a ton.

Can anyone help me with enabling "Desktop Effects"... it gives an error "Desktop effects could not be enabled"

greatquizzard 08-17-2009 05:26 PM

Quote:

Originally Posted by ms-rathore (Post 3636455)
Can anyone help me with enabling "Desktop Effects"... it gives an error "Desktop effects could not be enabled"

There are two drivers available for the graphics card which you have - one is the open source radeon which you are currently using, the other is the proprietary fglrx. To activate the latter, go to System > Administration > Hardware Drivers. In that list you'll find 'ATI Radeon' listed. Activate that and you'll be able to enable desktop effects.

Having said that I would advise you AGAINST doing this, since the proprietary driver can often mess up your system badly if something goes wrong. Desktop effects look nice when you install initially but it isn't something 'essential' that you'll need in daily usage.

greatquizzard 08-17-2009 05:28 PM

Instructions I have posted are for Ubuntu. You haven't mentioned which distro you're using but you seem to indicate Fedora. Details for Fedora are available here - http://www.fedorafaq.org/#radeon Again, this will install the propriatery fglrx driver. Not advisable.

Hangdog42 08-18-2009 07:14 AM

Quote:

Originally Posted by greatquizzard
Not advisable.

Why not? Other that not being an open source driver, are you aware of there being any problems with it? In my experience, fglrx is a perfectly good driver.

greatquizzard 08-19-2009 12:31 AM

Personal experience. Mostly, something breaks when you're doing a distro upgrade. Things stay fine if you do a clean install every time a new version comes out.

Hangdog42 08-19-2009 07:12 AM

Needing to do a reinstall is extremely common for drivers. Usually a distro upgrade comes with a kernel upgrade, which means that pretty much every driver needs to be recompiled. The drivers the distro supports get done as part of the upgrade, but non supported drivers have to be done by the end user.

greatquizzard 08-20-2009 01:22 AM

Aware of that. :) Also, fglrx gives me choppy video playback, while radeonhd doesn't.


All times are GMT -5. The time now is 09:42 AM.