-   Linux - Laptop and Netbook (
-   -   Dell Latitude D630 - Nvidia Quadro NVS 135M (

Popsicle-Pete 09-02-2008 04:41 PM

Dell Latitude D630 - Nvidia Quadro NVS 135M
The basic information first:

Distro: Fedora Core 9


I have been jumping around the web for the past 2 days trying to get this video card (nVidia Quadro NVS 135M) to work properly. The solution that seemed most popular was using kmod-nvidia from I added the repo and downloaded the appropriate packages. If I open up nvidia-settings it shows that my resolution is 1440x900, which is correct. However, if I go System > Administration > Display it says my resolution is 1024x768 with an unknown monitor / graphics card.

Looking at my screen it doesn't feel like it is showing 1440x900. Everything seems a bit large but this could possibly be a mental thing. Attached is my xorg.conf. Please take a look and let me know any suggestions.

I have tried manually manipulating the configuration but it still looks the same...


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Thu Jul 17 18:39:19 PDT 2008

# Xorg configuration created by system-config-display

Section "ServerLayout"
    Identifier    "single head configuration"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
    ModulePath      "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath      "/usr/lib/xorg/modules"

Section "ServerFlags"
    Option        "AIGLX" "on"

Section "InputDevice"

    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"

Section "InputDevice"

# keyboard added by rhpxl
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us"

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Unknown"
    HorizSync      30.0 - 110.0
    VertRefresh    50.0 - 150.0
    Option        "DPMS"

Section "Device"
    Identifier    "Videocard0"
    Driver        "nvidia"

Section "Screen"
    Identifier    "Screen0"
    Device        "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "1"
    Option        "RenderAccel" "True"
    Option        "AddARGBGLXVisuals" "True"
    SubSection    "Display"
        Viewport    0 0
        Depth      24

Section "Extensions"
    Option        "Composite" "Enable"

nebben11 09-02-2008 05:07 PM

I see one problem you need to config your monitor

nebben11 09-02-2008 05:12 PM

On Cent OS its in the Kmenu under System - Display
it might be the same under your OS
now if it is Tab over to Hardware and click on Configure next to Monitor type select the correct monitor
do the same for your Video card type and it should fix it

Popsicle-Pete 09-02-2008 07:32 PM

Thanks for the reply.

Yes - This xorg.conf was generated by Nvidia. If I manually adjust the monitor / video card within the Gnome display settings I can only select from what is given. For monitor I have tried setting it to Generic LCD 1440x900 but after restarting X it still doesn't allow me to change the Display Resolution past 1280x1024.

I'm guessing I need to force the display settings to allow 1440x900 but I'm not sure how.

nebben11 09-02-2008 08:38 PM

I wouldn't use the Generic LCD display driver if you can select your lcd brand its much better than the generic ones

nebben11 09-02-2008 08:44 PM

oh also try restarting the computer sometimes x doesnt respond to an x restart on the res like


Popsicle-Pete 09-03-2008 03:21 PM

I wouldn't mind choosing a more specific monitor from the list provided but I'm not sure what manufacturer Dell uses for their laptops.

nebben11 09-04-2008 02:46 PM

I see a Dell... Well I Would try this to find out what model it is
got to and type in "Dell *Model # here* Screen" if nothing replace "screen" with "display" or "LCD"
Ebay is a good resource for finding out what displays are in laptops Dell wount tell you snap

modaudell 09-15-2008 10:51 AM

exact same issue
Hey, I have the exact same issue on the same hardware/os. I searched high and low and did not find a viable solution but I did see a supposed fix, which was to add the kernel boot parameter "maxcpus=1". This is obviously not desirable since it means you cant use both cores, but it is supposed to stop the crashing. Apparently this is a bug dealing with the kernels scheduler.

If you do find any more info about this I would be VERY interested, so be sure to post!!

Good luck :)

Popsicle-Pete 09-15-2008 11:09 PM

Nothing Yet...
I put the system to the side for now... I actually loaded Ubuntu 8.04 on the system shortly after and with the build in Hardware Drivers utility it grabs everything right off the bat! Including those blasted Dell wireless drivers.

If I ever do find a good fix I'll be sure to post an update. Hopefully Fedora implements some of the hardware support that Ubuntu is allowing. Unfortunately I don't that that is going to happen.

All times are GMT -5. The time now is 01:35 PM.