LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 03-07-2011, 11:56 AM   #1
compuidiot
Member
 
Registered: Jul 2010
Distribution: ubuntu 10.04
Posts: 45

Rep: Reputation: 0
dell duo/ubuntu 10.04 netbook no sound


i have searched the forum and googled this problem found others having problems with headsets not working but there speakers work fine mine is just the opposite my headset jack is fine but i can't get the speakers to work. any advice!

ubuntu 10.04 netbook on a dell duo i like it!!
 
Old 03-08-2011, 03:27 AM   #2
ravikiran189
Member
 
Registered: Mar 2011
Posts: 45

Rep: Reputation: 4
Hi,

Try removing .pulse folder (if exists)in your home directory & reboot..

cd /home
ls -a
rm -r .pulse


In b/w try lspci command to see if your sound hardware is listed or not

Hope this helps

Last edited by ravikiran189; 03-08-2011 at 03:29 AM.
 
Old 03-08-2011, 10:07 AM   #3
compuidiot
Member
 
Registered: Jul 2010
Distribution: ubuntu 10.04
Posts: 45

Original Poster
Rep: Reputation: 0
00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge (rev 02)
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Multimedia controller: Broadcom Corporation Device 1615
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)



this is what lspci gives me
no pulse folder found
 
Old 03-10-2011, 12:38 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
I came across this:

http://ubuntuforums.org/showthread.php?t=1658635

Hope that helps.

Josh
 
Old 03-10-2011, 01:08 PM   #5
compuidiot
Member
 
Registered: Jul 2010
Distribution: ubuntu 10.04
Posts: 45

Original Poster
Rep: Reputation: 0
that's the link i posted in one of my earler threads when i was working on the touch screen
i do thank you for your effort
i'm still working on this and having no luck at all
the comp. can see the sound card and is listing the correct model
 
Old 03-10-2011, 01:10 PM   #6
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
Can you post your /etc/modprobe.d/alsa-base.conf?
 
Old 03-10-2011, 01:36 PM   #7
compuidiot
Member
 
Registered: Jul 2010
Distribution: ubuntu 10.04
Posts: 45

Original Poster
Rep: Reputation: 0
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
options snd-hda-intel model=ideapad
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
 
Old 03-10-2011, 01:46 PM   #8
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
Try removing options snd-hda-intel model=ideapad and replace with the following:
Code:
options snd-hda-intel model=auto
 
Old 03-10-2011, 01:53 PM   #9
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
Alsa, give me the output of the following:
Code:
cat /proc/asound/cards
 
Old 03-10-2011, 02:10 PM   #10
compuidiot
Member
 
Registered: Jul 2010
Distribution: ubuntu 10.04
Posts: 45

Original Poster
Rep: Reputation: 0
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0x98200000 irq 16
 
Old 03-10-2011, 02:27 PM   #11
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
Did you have any luck setting it to auto?
 
Old 03-10-2011, 02:31 PM   #12
compuidiot
Member
 
Registered: Jul 2010
Distribution: ubuntu 10.04
Posts: 45

Original Poster
Rep: Reputation: 0
switch to root edited the file rebooted no change
 
Old 03-12-2011, 08:35 AM   #13
compuidiot
Member
 
Registered: Jul 2010
Distribution: ubuntu 10.04
Posts: 45

Original Poster
Rep: Reputation: 0
Interesting note:
I booted into windows to do some work after I finished I booted back into Ubuntu and sound worked but I had no touch also when you tried to scroll down in any screen it would just jump back to top and if you grabed the slider with the mouse and draged down as soon as you let off the botton the screen snaps back to top I rebooted in to Ubuntu and it went back to no sound and every thing else working.
 
Old 03-12-2011, 06:54 PM   #14
amilauduwerella
Member
 
Registered: Feb 2009
Distribution: Debian
Posts: 57

Rep: Reputation: 17
Hi,

I have the same issue, my headsets are working, but not speakers(altec lancing), im using debian squeeze on hp g42.
please help me.
thanks.
 
Old 03-13-2011, 12:08 PM   #15
amilauduwerella
Member
 
Registered: Feb 2009
Distribution: Debian
Posts: 57

Rep: Reputation: 17
hi all,

i got it solved,
install "module-assistant"
and then terminal;
#module-assistant

go to "SELECT"
then "alsa" then ok.
"search" "build"

and it fixed my proble.

Thanks.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu netbook on dell inspiron mini 1018 , sound issue meabi Linux - Hardware 1 12-01-2010 09:52 AM
Dell Ubuntu Netbook - $249. farslayer Linux - Laptop and Netbook 2 06-11-2009 03:27 PM
LXer: Dell Freshens Up Its Mini 10 Netbook with Ubuntu LXer Syndicated Linux News 0 05-11-2009 09:40 AM
LXer: Dell Inspiron 910 netbook running Ubuntu spotted LXer Syndicated Linux News 0 08-24-2008 08:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 12:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration