LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 01-08-2006, 05:14 PM   #1
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Rep: Reputation: 15
Unhappy Dell B120


hello,

I bought a Linux book the other day that included SuSE 9.1 (I loaned out my copy of 9.0 a year ago and never got it back...) and figured I would try my hand at loading it onto my new Dell Inspiron B120. Unfortunately, I can't get the W I D E S C R E E N display (1280x800) and the Sigmatel C-Major audio card to work under Linux. Oh yeah, and the display card is an integrated Intel Media Accelerator 900. I also have no idea how to config. the screen under the Monitors tab of Sax2.

Any ideas?

Thanks,
pck
 
Old 01-08-2006, 05:24 PM   #2
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Original Poster
Rep: Reputation: 15
Oh, yeah...I neglected to mention that I tried the Intel GMA 900 driver from their site. After installing the package, it does not appear under Sax2, and when I tried to reinstall the driver, it said the package was already installed. Then, when I tried removing it, it said it wasn't installed...eek!
 
Old 01-08-2006, 05:26 PM   #3
kwacka
Member
 
Registered: Dec 2003
Posts: 77

Rep: Reputation: 15
CDs with books are out of date when they hit the stores.

Try to get hold of OpenSuSE 10.0 if you can. I don't know where you live, but the current issue (UK) of Linux Magazine has the full (not OpenSuSE) version as a cover disk.

Alternatively, there's a couple of positive reports of Mandriva 2006 working well on this machine.

Last edited by kwacka; 01-08-2006 at 05:27 PM.
 
Old 01-08-2006, 05:28 PM   #4
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Original Poster
Rep: Reputation: 15
If only I had money :-)...
 
Old 01-08-2006, 05:36 PM   #5
kwacka
Member
 
Registered: Dec 2003
Posts: 77

Rep: Reputation: 15
OpenSuSE & Mandriva are both free downloads.

Alternatively, there are sellers of the download versions of disks, e.g. Linux Emporium (UK) or cheapbytes (USA) for less than 10 pounds/dollars.
 
Old 01-08-2006, 07:35 PM   #6
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Original Poster
Rep: Reputation: 15
...but if I knew how to fix this little problem, I could be up and running right now. Plus, with Dialup, it would take days to download new disk images, not to mention the fact that I already paid for the book and CD.

:-P

pck
 
Old 01-09-2006, 08:01 AM   #7
kwacka
Member
 
Registered: Dec 2003
Posts: 77

Rep: Reputation: 15
OK, email your address to me and I'll put a copy in the post - on condition that you agree to make 2 copies and pass them on (possibly you'll put the same condition on them?).

SuSE 9.1 shipped with the XFree86 server, later versions use X-org. Which driver did you downlad from Intel?

You might also try forceing a re-installation of the driver.
 
Old 01-13-2006, 12:42 AM   #8
bassguin
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Rep: Reputation: 0
it would be awesome if someone could give an answer for this. i have an inspiron b120 myself and have been desperately trying to get 1280x800 working, because, as far as i am concerned it's unusable with any other resolution
 
Old 01-13-2006, 03:37 PM   #9
bassguin
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by pkozub
hello,

I bought a Linux book the other day that included SuSE 9.1 (I loaned out my copy of 9.0 a year ago and never got it back...) and figured I would try my hand at loading it onto my new Dell Inspiron B120. Unfortunately, I can't get the W I D E S C R E E N display (1280x800) and the Sigmatel C-Major audio card to work under Linux. Oh yeah, and the display card is an integrated Intel Media Accelerator 900. I also have no idea how to config. the screen under the Monitors tab of Sax2.

Any ideas?

Thanks,
pck
I have a B120 and I found the answer to your problem (I think. it fixed my b120 anyway)

You need to download 855resolution, and change one of the modes in it to 1280x800 (i.e. '$ 855resolution 49 1280 800'). Next, add this modeline to your /etc/X11/xorg.conf (the section should look at least somewhat similar to this. all you need to really do is match up the modeline, i'm just putting the rest for reference):

Quote:
Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
Modeline "1280x800" 80.58 1280 1344 1480 1680 800 801 804 827
EndSection
If all goes according to plan, when you restart X after doing these two things, you should start right back up into 1280x800. I might be missing something, but I found that every time I restart I have to re-run 855resolution to include the widescreen res.

good luck
 
Old 01-14-2006, 07:06 PM   #10
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Original Poster
Rep: Reputation: 15
I shall try it right now!
 
Old 01-14-2006, 10:12 PM   #11
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Original Poster
Rep: Reputation: 15
Didn't work...I don't have an xorg.config file. Tried creating one...

Yes, I know, there are updates, but I have dial-up (56k) and so I would like to avoid huge downloads if at all possible.

I am using SuSE 9.1...getting kind of frustrated...this is supposed to be better than Windows... :-P

pck
 
Old 01-14-2006, 10:56 PM   #12
bassguin
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by pkozub
Didn't work...I don't have an xorg.config file. Tried creating one...

Yes, I know, there are updates, but I have dial-up (56k) and so I would like to avoid huge downloads if at all possible.

I am using SuSE 9.1...getting kind of frustrated...this is supposed to be better than Windows... :-P

pck
Trust me, you have the file. If you have Xorg, you have that file. It's /etc/X11/xorg.conf (not xorg.config)
 
Old 01-15-2006, 08:40 PM   #13
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Original Poster
Rep: Reputation: 15
perhaps that's my problem. I have xFree86 from a year or so ago. It's not xorg...

pck
 
Old 01-15-2006, 09:07 PM   #14
bassguin
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by pkozub
perhaps that's my problem. I have xFree86 from a year or so ago. It's not xorg...

pck

ouch. it should be XF86.config or something along those lines, just ls /etc/X11 and see which it is. there's a good chance it won't work the same way, you may as well update to xorg, but try editing xf86's config with that anyway
 
Old 01-15-2006, 10:31 PM   #15
pkozub
Member
 
Registered: Nov 2005
Location: Bloomington, IN
Distribution: SuSE
Posts: 39

Original Poster
Rep: Reputation: 15
Have you gotten sound to work on your system?

pck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Good deal? $750 OFF coupon for DELL and other coupns for DELL penguin12 General 7 07-14-2005 06:12 PM
"multiboot utility" and "dell utility partition" on dell i5150 xround Linux - Laptop and Netbook 5 04-21-2005 10:19 AM
Dell 1150 PCMCIA in Dell 600m with Slackware 9.1 giddyupman Linux - Wireless Networking 0 05-07-2004 11:01 AM
Dell dell GX270, Redhat 9, geforce 5200 problem eiffel Linux - Software 3 10-10-2003 01:07 AM
Help with Dell TrueMobile 1100 wlan adapter on Dell inspiron 8200 with suse8.1 simpson75us Linux - Laptop and Netbook 0 08-11-2003 11:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 01:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration