Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 09-13-2005, 12:28 AM   #1
Registered: Sep 2005
Location: Suburbia
Distribution: Slackware 14.0
Posts: 68

Rep: Reputation: 15
Debian boot hangs at ACPI

I upgraded my Debian kernel to package kernel-image-2.6.11-1-386 and excitedly restarted the computer only to see the boot hang Debian boot hangs at

ACPI: setting ELCR to 0200 (from 0800)

I'm running an IBM T23... the old kernel (2.4.27) still works just fine though. Anyway, how would I go about fixing this?
Old 09-14-2005, 06:44 PM   #2
Registered: Sep 2003
Distribution: Mandrake, Slack, Debian and PicoBSD
Posts: 181

Rep: Reputation: 31
T23s can't use ACPI, in fact they'll refuse to install unless you explicitly disable ACPI on the command line.
I'm guessing your old kernel used apm and the new one has ACPI (statically compiled?) and hangs when it doesn't work.
You'll have to interrupt your boot manager (grub or lilo), select the new kernel and then add

acpi=off noacpi
to the end of it. It should then boot fine.

Then edit grub or lilo to tack that onto the end by default and ensure apm is enabled. The relevant info is here, so I won't repeat it (applies to Debian as well):

And yes, I do have a T23, and it is pretty damn annoying when you first see this happen.
Old 11-16-2005, 04:31 PM   #3
LQ Newbie
Registered: Oct 2004
Distribution: Slackware, Mandrake
Posts: 27

Rep: Reputation: 15
i don't know what's the problem about installing or running an ACPI enabled kernel on a t23 - neved hear of it. i recompiled the kernel from sources, the ACPI is on, everything works fine except the hibernate or suspend. in order to enable suspend i have to give the "acpi=off apm=on" option at boot. but if you don't care about suspend or hibernate - it works fine for me with ACPI. if anybody is interested i can post the .config file for the kernel - it's a 2.6.14.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get ACPI working for debian sarge linuxmandrake Linux - General 14 01-26-2008 01:29 PM
Hangs at boot - Debian 3.0r4 OZn Linux - Newbie 4 04-12-2005 12:46 AM
ACPI hangs with kernel 2.6.8-mm on HP Pavilion ze4400 laptop jsmarie Linux - Hardware 1 09-24-2004 01:40 AM
Kernel bootup hangs on ACPI on Toshiba TE2300 Alf829 Linux - Laptop and Netbook 0 03-28-2004 03:07 AM
Kernel compile error/system hangs, APIC/ACPI taids Linux - Hardware 14 08-23-2003 07:11 AM > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 11:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration