LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   cpufan alway running on sony vaio pcg-grt995mp (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/cpufan-alway-running-on-sony-vaio-pcg-grt995mp-842935/)

Lis 11-07-2010 09:48 PM

cpufan alway running on sony vaio pcg-grt995mp
 
Hello everyone.
So I installed slwackware (more or less) and the cpu fan is always running at full speed.
How do I fix this?

I use it on a sony vaio pcg-grt995mp.
It has a pentium 4 cpu with a sis chipset.

I searched google but nothing of the tips really helped.
I tried to modprobe cpufreq_ondemand etc.

How do I find out if the motherboard's sensors are recognized?

Thank you, Louis

H_TeXMeX_H 11-08-2010 03:04 PM

For a laptop, make sure you have the modules 'processor', 'thermal', and 'fan' inserted. First check 'lsmod' and if they are not there, run 'modprobe' and the module name.

Lis 11-08-2010 10:10 PM

processor and thermal are insterted, fan was not.

Doing a modprobe fan did not solve the problem.

Thank you, Louis

H_TeXMeX_H 11-09-2010 04:26 AM

Ok, let's assume you have installed slackware 13.1. Are you running a custom kernel ? What version ?

Also, are you sure it is the CPU fan that is running all the time ? Could it be the GPU fan ?

If ACPI detects an ACPI sensor it should be listed at '/proc/acpi/thermal_zone'. Other sensors can be detected using lm_sensors 'sensors-detect'.

I would also check the BIOS options for fan speed, just in case, if there are any.

Lis 11-09-2010 11:33 AM

Oh I'm totally sorry for holding the additional important information back.

It's Slackware 13.1 with an unmodified kernel with a fresh install
and nvidia drivers 96.43.18 installed.

There is one node in /proc/acpi/thermal_zone which is called ATF0.

Using sensors-detect shows me
Code:

bash-4.1# sensors-detect
# sensors-detect revision 5818 (2010-01-18 17:22:07 +0100)
# System: Sony Corporation PCG-GRT995MP(DE) (laptop)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): YES
Silicon Integrated Systems SIS5595...                      No
VIA VT82C686 Integrated Sensors...                          No
VIA VT8231 Integrated Sensors...                            No
AMD K8 thermal sensors...                                  No
AMD Family 10h thermal sensors...                          No
AMD Family 11h thermal sensors...                          No
Intel Core family thermal sensor...                        No
Intel Atom thermal sensor...                                No
Intel AMB FB-DIMM thermal sensor...                        No
VIA C7 thermal sensor...                                    No
VIA Nano thermal sensor...                                  No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): YES
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor'...                  No
Trying family `SMSC'...                                    Yes
Found `SMSC LPC47N227 Super IO'                           
    (no hardware monitoring capabilities)
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor'...                  No
Trying family `SMSC'...                                    No
Trying family `VIA/Winbond/Nuvoton/Fintek'...              No
Trying family `ITE'...                                      No

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (YES/no): YES
Probing for `National Semiconductor LM78' at 0x290...      No
Probing for `National Semiconductor LM79' at 0x290...      No
Probing for `Winbond W83781D' at 0x290...                  No
Probing for `Winbond W83782D' at 0x290...                  No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): YES
Using driver `i2c-sis96x' for device 0000:00:02.1: Silicon Integrated Systems SMBus Controller

Next adapter: SiS96x SMBus adapter at 0x8100 (i2c-0)
Do you want to scan it? (YES/no/selectively): YES

Next adapter: NVIDIA i2c adapter  (i2c-1)
Do you want to scan it? (YES/no/selectively): YES

Next adapter: NVIDIA i2c adapter  (i2c-2)
Do you want to scan it? (YES/no/selectively): YES

Next adapter: NVIDIA i2c adapter  (i2c-3)
Do you want to scan it? (YES/no/selectively): YES

Sorry, no sensors were detected.
This is relatively common on laptops, where thermal management is
handled by ACPI rather than the OS.

There are no options for fan controls nor any options for powercontrol within the bios.

H_TeXMeX_H 11-09-2010 02:37 PM

Ok, well for laptops it is normal not to have any sensors detected by sensors-detect, because there's usually just one sensor via ACPI. If you cat that file '/proc/acpi/thermal_zone' it should say the temperature, or a decent monitoring program can pick it up.

Looking at this issue online a bit, I notice that it happens with many sony laptops, and they mention that there is a Window$ utility that controls the fan speed. Then I take a look at the kernel documentation:
http://www.kernel.org/doc/Documentat...ony-laptop.txt

Quote:

Platform specific:
------------------
Loading the sony-laptop module will create a
/sys/devices/platform/sony-laptop/
directory populated with some files.

You then read/write integer values from/to those files by using
standard UNIX tools.

The files are:
brightness_default screen brightness which will be set
when the laptop will be rebooted
cdpower power on/off the internal CD drive
audiopower power on/off the internal sound card
lanpower power on/off the internal ethernet card
(only in debug mode)
bluetoothpower power on/off the internal bluetooth device
fanspeed get/set the fan speed

Note that some files may be missing if they are not supported
by your particular laptop model.
Try loading this module and see if you can set the fan speed using this.

Lis 11-10-2010 11:21 AM

After installing the Linux Kernel Slackware-Current 2.6.35.7 the fan slows down after about 10 minutes logged in.

Code:

watch cat /proc/acpi/thermal_zone/ATF0/temperature
is a good monitoring programm.

It prints values bigger than 50 C, so it looks like the sensor is working.

Problem solved, thank you.

H_TeXMeX_H 11-10-2010 01:01 PM

Interesting, but why ? Why does it work in current and not in 13.1 ? Well, if you have some ideas post them, if not, just mark the thread solved.


All times are GMT -5. The time now is 03:38 AM.