-   Linux - Laptop and Netbook (
-   -   Convert RHEL 5.1 Desktop DIsk Image to Laptop Image (

Wolfsbane2k 08-24-2010 06:26 PM

Convert RHEL 5.1 Desktop DIsk Image to Laptop Image

I've aquired a desktop that has a specific set of applications and apparent services that no matter what i've tried i can't get running on the laptop i need to get it running on.

It's a RHEL 5.1 Server image that I have spent the last 3 days trying to get working on the laptop with very little progress. HW specs on both are intel Core 2 Duo, 4 GB Ram, 120 GB hd, but Desktop is HDA, Laptop is SDA.

I've tried:
1) Ghosting entire disk from Desktop to Hardrive, with GRUB pointed in the right direction. Kernel panics on "can't find /dev/root"
2) Tried Fixing the init in initrd to point to the new /dev/sda, but no luck. It contains ide and sata modules.
3) Booted without an initrd - kernel panic, no /dev/root/
4) Using the same harddrive parition as desktop, installed RHEL5.1 again. Copied contents of /boot/ to a flash disk and then applied old ghost. Loaded rescue disk and copied new contents of flash disk back to /boot. Modified grub.conf to point to new laptop builds. Booted it, kernel booted, "just" got into X when crashed. ran in Telinit 1, ran kudzu. Never booted again.

I think i need to go back steps 1 to 4, and then do something different on the first boot.

I've tried virtualising this, but the virutalisation i've tried slowed the machine down a lot so it was no longer useable - it's a signal processing tool that needs to run in real-time.

Any ideas on the "right" way to do this?

Thanks in advance.


kinetic 08-24-2010 07:13 PM

Can't you install RHEL to your laptop the same way you installed it to your desktop? Can you use unetbootin to install RHEL to a pendrive? I'm assuming you're dealing with some kind of ISO here. How about booting to a live CD you know works, mounting the RHEL partition, and then chrooting into it? Just some suggestions.

Wolfsbane2k 08-25-2010 02:59 AM

Hi Kinetic,

I'd tried that, but the installation instructions were "install RHEL, copy CD contents to /usr/, run "make go".

And with commands that simple, it's failing, but i can't work out why. I get no verbose output from the make files, tracing through them ( 104 make files in total ) i can't work out what is failing, ie no idea on dependanice issues etc.

SO i thought it would be easier to ghost it over so all the dependancies etc are installed, confs are aligned, and it "should" work once the new H/W is configured....

How wrong i was!

kinetic 08-27-2010 11:18 AM

It really sounds like it isn't worth the trouble. What did you need it for anyway?

All times are GMT -5. The time now is 12:45 PM.