-   Linux - Laptop and Netbook (
-   -   Configuring wireless on Dell D600 SuSE 9.2 (

JWHolloway 02-16-2005 09:11 PM

Configuring wireless on Dell D600 SuSE 9.2
Hi folks --

Noob alert --

Spent a few hours, with the help of the great Rajesh Menon NYLug, trying to configure my Dell Latitude D600 for wireless. Using an Orinoco Gold Classic card, SuSE 9.2 (disabled the one-board Dell True Mobile card). Typed the following into shell, to no avail:

linux:/home/jwholloway # ifconfig eth0 down
linux:/home/jwholloway # ifconfig eth1 down
linux:/home/jwholloway # ifconfig eth1 up
linux:/home/jwholloway # iwconfig eth1 essid "lienjuks"
linux:/home/jwholloway # ifconfig eth1 netmask broadcast

What am I doing wrong? Any quidance deeply appreciated.

FWIW, I was not able to configure dhclient, if that is important (I am a real noob).

Thanks much, I hope to learn a little and maybe help someone else out some day.

If someone in NY or Brooklyn has the time to show me, at a coffee shop or something, how to do it I will give him This is Spinal Tap on DVD or some good Django Reinhardt.

Regards, James

linbox 04-20-2005 09:45 PM

try to use ndiswrapper
I do have a dell d600 as well an I ended up using ndiswrapper.
It's software that lets you use windows driver under linux.
It's not perfect, but at least it works.


MarkR 06-28-2005 04:21 PM

I'm using ubuntu on my d600. Plug and play. :p

joe704 06-28-2005 05:37 PM

What wireless card are you using? I've spent weeks trying to connect a Dell/Truemobile 1150, using SuSE 9.0,and now 9.3. The former gave local, but not internet connection. Can't get anything with 9.3. I like SuSE, but will change to anyghing that will give me a wireless connection.

kernalzero 06-28-2005 08:36 PM

I finally got my D600 with a Truemobile 1400 working using Ndiswrapper the other day but the next morning without changing stopped...and plugging it in doesn't even work now! Does anyone know how to set it up so that you don't have to mess with the resolv.conf file or better yet just solve this problem in general??? I'd like to have wireless as my primary network device but when I plug-in have wireless shut off. I also don't have a static IP from my DSL carrier, is there a way to have resolv.conf autodetect these settings so I don't have to type in 'Search <my IP> Nameserver'?? By the way I only made my way over to Linux from Windows a month or so ago so don't get pissed if I don't understand everything that is mentioned in your replys ;-) Thanks in advance for any input you may have.

kernalzero 06-28-2005 08:47 PM

i have a pdf file from ndiswrapper that doesn't seem to be available anymore detailing ndiswrapper installation on SuSE 9.2...PM my if anyone wants it and I'll email it to you. It's really good minus the problems I've had ;-) I didn't write it by the way, the author's name isn't listed but i still have to thank him/her.

MarkR 06-29-2005 12:47 AM

My card's an Intel (R) ProWireless 2100 LAN miniPCI Adapter, runs out of the box with the current hoary distro of ubuntu. Ubuntu has a live cd you could try...

joe704 06-29-2005 04:49 PM

Thanks for the info. I have Ubuntu, but not the Live CD.
However, I do have MandrakeMove (which I just tried).
The wizard got me connected in just a few minutes. My laptop hard drive is full, so after one more try with SuSE, I am going to switch distros. Thanks again for the suggestion.

darragh-o-h 07-08-2005 11:07 AM

Dell D600 and Suse 9.3

I'm about to start installing Suse 9.3 Professional on a dell D600 laptop however as I'm a newby I could do with some help. Specifically what drivers are the hardest to get installed? I remember on an old del the modem was a pain to get working as it was a win modem. From what I've read here and on other sites it seems like the wireless network card is going to be the problem this time.

I'd appreciate any help any of you can provie. I know bits about Linux but have only used redhat and Fedora core in the past.


whitehawk 07-08-2005 11:47 AM

I have been using Suse 9.2 for over a year. It's plug and play for most of the pcmcia wireless cards but has issues with the USB adapters.
Have you guys tried Linuxant? Check out the trial version for 30 days and if it is flawless you can purchase it for $20.
If you have the luxury of time, you can mess around with ndiswrapper else $20 should be a very good option.
Rather than saying "it doesn't seem to work" try to post the error messages / logs. after you do 'modprobe ndiswrapper' check the messages by keying in 'dmesg' on the terminal. This should give you an idea of errors.
Look into this and we'll go from there.

joe704 07-08-2005 12:21 PM

Linuxant sounds interesting; I'll look into it. For now, I have Ubuntu running on the laptop...use it only when I travel, and almost exclusively for Mozilla.
SuSE 9.0 would connect locally, but not to the outside world, and there were no error messages; it just timed out. SuSE 9.2 Professional seemed to configure correctly in YaST, but I couldn't even ping my router with it (using parameters taken from my wired conx and the wireless data from Mandrake Move).
I will try with SuSE again when I get a bigger HDD.

ultimatenoob 07-08-2005 01:24 PM

check out these threads, they may be helpful in some way. I got my wireless working by looking at almost every thread i could find on the subject on two seperate forums, using the ndiswrapper forums, and Obviously, this took a while, and in the long run, I really don't know what I did to get it working, and even as is, sometimes i use "iwconfig wlan0 essid "networkname" and "ifup wlan0" to connect, and other times i use the GUI program called Network Device Control, and normally between the two i'm successful. So, best of luck to you!

and I believe there were several more that I no longer have bookmarked, but hopefully those will suffice.

whitehawk 07-08-2005 02:00 PM

check your routing tables, DHCP configuration and see the output of /var/log/messages This should give you a clue as to why your SUSE box is not connecting to www. Also check SUSE Firewall settings. These are the preliminery checks. As I mentioned earlier, the logs are very important for troubleshooting.

All times are GMT -5. The time now is 06:45 AM.