-   Linux - Laptop and Netbook (
-   -   Compaq Presario CPU Frequency Problem (

Tide 09-30-2005 07:59 PM

Compaq Presario CPU Frequency Problem
Hello everyone. I'm new to linux, and since I installed Kubuntu I've been having a problem with my CPU clock speed on my Compaq Presario 2590US. Upon running cat /proc/cpuinfo I am told the following:

owner@box:~$ cat /proc/cpuinfo
processor      : 0
vendor_id      : GenuineIntel
cpu family      : 15
model          : 2
model name      : Genuine Intel(R) CPU 2.30GHz
stepping        : 9
cpu MHz        : 1596.512
cache size      : 512 KB
fdiv_bug        : no
hlt_bug        : no
f00f_bug        : no
coma_bug        : no
fpu            : yes
fpu_exception  : yes
cpuid level    : 2
wp              : yes
flags          : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 3137.53

Yet lshw tells me the following:

          description: CPU
          product: Genuine Intel(R) CPU 2.30GHz
          vendor: Intel Corp.
          physical id: 4
          version: 15.2.9
          slot: WMT478/NWD
          size: 1600MHz
          capacity: 2300MHz
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr

So I ought to be running my CPU at 2.3 ghz, not at 1.6. Does anyone know how I can correct this problem? Thus far, cpuspeedy has not worked for me, and I'm pretty sure that this problem is not being caused by CPU throttling since I did not have that feature enabled and also due to the fact that that frequency never changes, even when programs are loading.

zaug 10-02-2005 05:28 AM

In my case, the CPU frequency is set in the bios. Have you checked there ?

Tide 10-02-2005 05:41 PM

In my bios there is no place for me to change or even view the attributes of my processor, but in windows it is able to run full blast at 2.3ghz without any problems.

springshades 10-03-2005 02:56 AM

Have you tried checking the speed of the processor while running an intensive application? By default, newer mobile processors don't run at full speed unless they NEED to. This is to save power and lower the heat build up. I believe that the pertinant information is in:


cd into that directory and do:

cat scaling_governor

if this gives back "ondemand" or something like that, then that's what it is. If that's the case, then this is a good thing because you don't want your CPU running full speed all the time in a laptop (even 1.6 GHz is kinda high). Windows probably does this too, even though they may not tell you. If you don't get back "ondemand", then it may be an actual problem. Do you happen to know for certain that your laptop really DOES have a Pentium 4 2.3 GHz processor? Is it possible that it detected it wrong?

Tide 10-03-2005 07:24 AM

Here's the response I get:

owner@box:~$ cd /sys/devices/system/cpu/cpu0/cpufreq
bash: cd: /sys/devices/system/cpu/cpu0/cpufreq: No such file or directory
As for the processor type, I'm sure that it has detected it correctly; or, at least it is labelled the same way in windows where it runs at 2.3ghz.

springshades 10-03-2005 07:34 AM

Those were the only things that I could think of that would effect your CPU frequency outside of the BIOS. It's possible that there is a completely different mechanism that lowers the CPU frequency for Intel processors, but if that's the case, I don't know what it is because the CPU in my laptop is AMD. I'm pretty sure that cpufreq handles frequency scaling for Intel processors as well though. In other words, I'm out of ideas. Sorry. :(

Tide 10-05-2005 01:53 PM


Could really use some help with this.

springshades 10-05-2005 07:59 PM

One other thing. Are you completely against trying another Linux distribution? Perhaps a Live CD so that you can try it without messing up any of your current settings. It's possible that it's some sort of issue with your current distro or maybe even the specific kernel you're using.

All times are GMT -5. The time now is 12:11 AM.