LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 10-04-2005, 01:14 PM   #1
jhwhite
LQ Newbie
 
Registered: Aug 2005
Location: central North Carolina
Posts: 17

Rep: Reputation: 0
Compaq doesn't turn off after shutdown


I recently installed Suse 9.3 on a Compaq Presario 2312 Laptop (Turion) and thanks to the kind folks posting on this site, I've gotten past the odd display resolution (1280x768) and the fast clock.

The next problem on the list is that the laptop doesn't power down after a shutdown. The shutdown appears otherwise be complete -- the screen goes blank and the verbose listing of messages put out during the shutdown ends with a line saying the shutdown is complete or something like that. Problem is that the lights are still on and the fan is running. Holding the power button down for 5 seconds forces a successful power down. The shutdown works when I'm running XP.

The ACPI stuff does seem to be working since it tells me the processor clock rate is changing and the battery capacity indicator looks good.

Upon the advice of the Suse manual, I looked in the /var/log/messages and I don't see any associated with ACPI that would indicate a problem to me, but then I'm a definite novice at this. The ACPI messages are:


Oct 3 21:46:26 linux kernel: ACPI: AC Adapter [ACAD] (off-line)
Oct 3 21:46:26 linux kernel: ACPI: Battery Slot [BAT1] (battery present)
Oct 3 21:46:26 linux kernel: ACPI: Power Button (FF) [PWRF]
Oct 3 21:46:26 linux kernel: ACPI: Sleep Button (CM) [SLPB]
Oct 3 21:46:26 linux kernel: ACPI: Lid Switch [LID]
Oct 3 21:46:26 linux kernel: ACPI: CPU0 (power states: C1[C1] C2[C2])
Oct 3 21:46:26 linux kernel: ACPI: Processor [CPU0] (supports 8 throttling states)
Oct 3 21:46:26 linux kernel: drivers/usb/serial/usb-serial.c: USB Serial support registered for Generic
Oct 3 21:46:26 linux kernel: usbcore: registered new driver usbserial_generic
Oct 3 21:46:26 linux kernel: usbcore: registered new driver usbserial
Oct 3 21:46:26 linux kernel: drivers/usb/serial/usb-serial.c: USB Serial Driver core v2.0
Oct 3 21:46:27 linux kernel: ACPI: Thermal Zone [THRM] (52 C)
Oct 3 21:46:28 linux kernel: powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09e)
Oct 3 21:46:28 linux kernel: powernow-k8: 0 : fid 0x8 (1600 MHz), vid 0x4 (1450 mV)
Oct 3 21:46:28 linux kernel: powernow-k8: 1 : fid 0x0 (800 MHz), vid 0x16 (1000 mV)
Oct 3 21:46:28 linux kernel: cpu_init done, current fid 0x8, vid 0x4
Oct 3 21:46:28 linux rcpowersaved: enter 'powernow_k8' into POWERSAVE_CPUFREQD_MODULE in /etc/sysconfig/powersave/cpufreq.
Oct 3 21:46:28 linux rcpowersaved: this will speed up starting powersaved and avoid unnecessary warnings in syslog.

Any suggestions for a cause or cure?
Thanks,
jhw
 
Old 10-05-2005, 07:48 AM   #2
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,832

Rep: Reputation: 47
try that
#chmod +s /sbin/halt
 
Old 10-06-2005, 06:54 AM   #3
jhwhite
LQ Newbie
 
Registered: Aug 2005
Location: central North Carolina
Posts: 17

Original Poster
Rep: Reputation: 0
I tried:
#chmod +s /sbin/halt
and it didn't help. File ownership was already root (if that was what that command was supposed to fix. I'm still learning this linux stuff)

Thanks for taking the time to help.
 
Old 10-06-2005, 07:01 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,582

Rep: Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504
Kernel level ???.
Try poweroff command instead, and see what happens.
 
Old 10-06-2005, 08:14 AM   #5
jhwhite
LQ Newbie
 
Registered: Aug 2005
Location: central North Carolina
Posts: 17

Original Poster
Rep: Reputation: 0
I get "command not found" when I type "poweroff"

Where do I find the Kernal level? Looks like it might be 2.6.11.4-20a-default. I see files by that name in /boot and KDE reports that as a release.

Obviously you're dealing with a newbie here.
 
Old 10-06-2005, 08:22 AM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,582

Rep: Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504
For kernel level, from a console/terminal type
Code:
uname -r
root should have access to poweroff - maybe try
Code:
/sbin/poweroff
- will need to be root still.
BTW, how are you getting to root ???. If logged on as root, should be no problem, but if you use "su", try "su -" instead before issuing the commands (man su will explain the difference).
 
Old 10-06-2005, 08:38 AM   #7
jhwhite
LQ Newbie
 
Registered: Aug 2005
Location: central North Carolina
Posts: 17

Original Poster
Rep: Reputation: 0
I was using "su" to gain root privileges.

poweroff gives the same result -- screen goes blank after all the shutdown messages scroll by. Lights on on/off switch and some buttons remain on. Fan may come on after a few seconds. Pressing and holding power switch for 5 seconds kills lights and fan.

Kernal level is indeed what I said.

Thanks for your help.
 
Old 10-06-2005, 03:32 PM   #8
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,832

Rep: Reputation: 47
#modprobe apm
Then the halt command will totally shut down your system.
 
Old 10-06-2005, 07:02 PM   #9
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,582

Rep: Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504
Maybe ....
maybe not.

I thought I saw this (non powering off) issue at 2.6.10, and I think it went away either very late in the 2.6.11 cycle, or maybe early 2.6.12
Poweroff was the only thing that worked for me - others reported the same as jhwhite; nothing worked.

To save a lot of probably needless stress, the best solution might be to update the kernel as soon as you have the opportunity.
 
Old 10-07-2005, 05:43 PM   #10
jhwhite
LQ Newbie
 
Registered: Aug 2005
Location: central North Carolina
Posts: 17

Original Poster
Rep: Reputation: 0
# modprobe apm returns
FATAL: Module apm not found.
...but then if the apm stuff were not already there, would the battery monitoring work? The battery monitoring looks good and the clock speed is being changed so I thought the power management was present and working. I guess I shouldn't worry too much about the shutdown problem since I can always use the switch, but I put Linux on this laptop to learn about Linux and I do learn stuff by investigating these problems. I do need to test out the other power features like suspend, etc. I have not yet done that.

Regarding updating the Kernel, I'll probably upgrade stuff before too long. I understand you need to do that with Linux. In the meantime, I'll try to learn how to fix things that are broken so it won't be a big task when I run into it.

Related question: What other features are in the same system with the power down? I want to check out the related stuff and see if the lack of a power-off is just one symptom of a more widespread problem.
 
Old 10-07-2005, 06:51 PM   #11
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 19,582

Rep: Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504Reputation: 3504
acpi - they have a project page on sourceforge. Looks like the fix may have shipped in 2.6.12.3.
 
Old 10-11-2005, 06:29 AM   #12
rhandwor
Member
 
Registered: Oct 2005
Posts: 125

Rep: Reputation: 16
shutdown problem

While I use fedora they had 3 kernels in a row which wouldn't shutdown my machine. I have 3 hard drives and the windows drives would shutdown the computer. As the shutdown is in the kernel, I would download and install an updated kernel this should correct the problem. Especially if it started after this kernel was installed.
 
Old 10-11-2005, 08:09 AM   #13
jhwhite
LQ Newbie
 
Registered: Aug 2005
Location: central North Carolina
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks to all of you for the info. I'll look into what I need to do to upgrade the Kernel that I got from Suse.

The machine is practically new. It came as a Windows XP home machine which I made dual-boot and added Linux. The power features all work under Windows. As I reported at the beginning of the thread, the power down doesn't work under Linux. More recently, I did a quick test, and I don't believe the sleep modes work either. When I get back to it, I'll check the ACPI log files to see if there are any clues, but maybe before I worry too much about it, I'll figure out how to upgrade the Kernel.

Thanks again.
 
Old 10-13-2005, 03:44 PM   #14
rhandwor
Member
 
Registered: Oct 2005
Posts: 125

Rep: Reputation: 16
shutdown problems

http://mirrows.kernal.org/suse/
 
Old 10-13-2005, 03:45 PM   #15
rhandwor
Member
 
Registered: Oct 2005
Posts: 125

Rep: Reputation: 16
shutdown problem

http://mirrors.kernal.org/suse/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
turn off linux /shutdown computer xprometeus Linux - General 9 09-25-2010 02:18 PM
How to turn off verbose on shutdown Khepri Linux - Newbie 4 08-11-2005 06:08 AM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 08:05 AM
Mandrake 9.2 does not turn off power at shutdown dancro Mandriva 12 03-19-2004 06:41 AM
Shutdown script wont physically turn off my system... cav Slackware 2 09-13-2003 02:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 07:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration