LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).


  Search this Thread
Old 02-13-2009, 10:12 AM   #1
LQ Newbie
Registered: Feb 2006
Location: Finland
Distribution: Slackware
Posts: 24

Rep: Reputation: 15
Chicony UVC webcam not working in Slackware 12.2

bash-3.1# lsusb | grep Webcam
Bus 001 Device 003: ID 04f2:b012 Chicony Electronics Co., Ltd 1.3 MPixel UVC Webcam
Linux video capture interface: v2.00
uvcvideo: Found UVC 1.00 device USB2.0 1.3M UVC WebCam  (04f2:b012)
input: USB2.0 1.3M UVC WebCam  as /devices/pci0000:00/0000:00:03.3/usb1/1-5/1-5:1.0/input/input8
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
bash-3.1# lsmod | grep v4l
v4l2_common            13824  0 
v4l1_compat            17924  2 uvcvideo,videodev
bash-3.1# ls /dev/video*
/dev/video  /dev/video0
bash-3.1# cat /dev/video0 > ./test.mpq
cat: /dev/video0: No such device
bash-3.1# uname -r
I'm using Slackware 12.2 on Asus PRO50SR, and the webcam isn't working... I found out that v4l2 is supposed to support that cam but it looks to me like uvcvideo is using v4l1 instead which doesn't support my cam.

Any help greatly appreciated.

EDIT: And when I tried using the cam in Kopete it doesn't even find the webcam.

Last edited by Ryuu; 02-13-2009 at 10:25 AM.
Old 02-14-2009, 06:33 AM   #2
LQ Newbie
Registered: Feb 2006
Location: Finland
Distribution: Slackware
Posts: 24

Original Poster
Rep: Reputation: 15
I downloaded MPlayer to test it out 'cause that seems to be what everyone else is using... and image capture seems to work just fine with mplayer... so how do I get other programs to discover the webcam? since it's obviously working just fine, I just need to get it activated.

EDIT: or actually if this is just a Kopete problem then I'd like suggestions for what IM program to use that would support the webcam and Yahoo!/MSN protocols.

EDIT2: problem solved by using aMSN... the webcam works fine

Last edited by Ryuu; 02-14-2009 at 07:13 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
UVC Webcam Ubuntu j0eh4x Linux - Hardware 5 01-05-2009 09:33 PM
Webcam for Skype - UVC video failure in Fedora 7 Peacepunk Linux - Hardware 2 05-01-2008 06:50 AM
Installing Linux-UVC drivers in Slackware 12 Poetics Slackware 2 02-04-2008 11:18 AM
Fixed: chicony wireless usb mouse not working pbhj Linux - Hardware 1 08-01-2006 06:24 PM
driver for chicony DC100 webcam for fedora3 03mcmt02 Linux - Software 0 04-06-2005 11:47 AM

All times are GMT -5. The time now is 09:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration