-   Linux - Laptop and Netbook (
-   -   Can't turn off RF Kill switch on Asus Z33A with Intel 2200BG wireless (

kmierle 07-30-2005 12:01 PM

Can't turn off RF Kill switch on Asus Z33A with Intel 2200BG wireless
I can't for the life of me turn off the stupid RF Kill switch on my brand new Asus Z33A. I'm running Debian, but I don't think this is a Linux problem. After modprobe ipw2200, I get:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.4
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ip2200: Radio Frequency Kill Switch is On:
Kill switch must be turned off for wireless networking to work.

# cat /sys/bus/pci/devices/*/rf_kill

which means the ip2200 driver detected a HW RF switch. I've tried Fn+F2 (which has the little wireless icon in blue), but that doesn't seem to do anything. The wireless LED on the laptop is off. I also tried opening the back and pressing on the RF connectors to make sure they were connected, but they seemed pretty secure to me.

# iwlist eth1 scan
eth1 No scan results

which is clearly wrong, as my laptop is literally 2 feet away from my wireless router.

I also tried:
# modprobe asus_acpi
# echo 1 > /proc/acpi/asus/wled

then reloading the ipw module. This has no effect, the kill switch is still on :(

Has anyone else had this problem?

Thanks in advance,

MattD82 07-30-2005 06:20 PM

Had the same problem (Asus Z33A also)

Heres how I fixed it:

1) Install ipw2200 (

2) Install ipw2200 firmware (from the above site)

3) Upgraded to the latest BIOS


filex 09-22-2005 10:11 PM

I use to type "setkeycodes" command follow by pressing "Wireless Button" to make it change to rf_kill = "0"

All times are GMT -5. The time now is 07:27 AM.