-   Linux - Laptop and Netbook (
-   -   Can't sync IPOD with GTKPOD (

Abomb 06-25-2006 09:45 PM

Can't sync IPOD with GTKPOD
Hey guys,

Just purchased a brand new Ipod Nano and I'm trying to use it with Linux. I don't want to reformat the Ipod and put Linux on it, I just want it to work with Linux. I reformated it on a Windows and now gtkpod can recognize the songs on the ipod. But I can't write anything to it. Everytime I hit sync, it gives me an error that says:

Path not found: '/media/ipod/iPod_Control/Music/F11'.
Anyone have an idea?

Caeda 06-26-2006 07:34 PM

Is there a /iPod_Control/Music/F11 folder on your ipod?

Abomb 06-27-2006 06:40 PM

I resolved it. There was another post on this site that I had to do some researching to find. But it simply says just to create those F* directories in the folder. So F01 all the way up till the error goes away. Had to handle it directly though.

Thanks for the reply. =P

maroonbaboon 06-29-2006 09:18 PM

Just to add a bit more to this thread: I had some problems getting my (Apple format) Ipod mini to sync with gtkpod.

Like the guides say I had built the kernel with the HFS filesystem and turned off disk journalling with the mini attached to a Mac, but still no sync.

I eventually fixed it by changing the permissions of all the top level IPod directories to world access (instead of just root access). Maybe something similar would have worked in your case.

Incidentally, I don't find the gtkpod interface very intuitive, or the error messages and warnings very useful. The documentation is also very sparse. Can anyone recommend a good in-depth gtkpod guide? I don't really understand the interaction of all the various features.

Abomb 07-07-2006 07:43 AM

You know, I never thought about changing the permissions of the files themselves. I did try running gtkpod as root but that didn't work. Next time I get a problem like that, I'll try that.

As for documentation goes, I didn't really find alot about GTKPod either. However, I was able to get GTKPod working far before I could get gnupod, the cli program to work for me. But after getting the program to work, I haven't really needed any more documentation to be honest. I haven't come across any features of the program that wasn't self explanatory, but then I'm probably not using the program the same way you are.

Good luck, and keep us posted on how far you get!

All times are GMT -5. The time now is 09:54 PM.