LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Can't mount DVD-R (with disk/data) on HP Laptop (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/cant-mount-dvd-r-with-disk-data-on-hp-laptop-538006/)

HunterLoftis 03-16-2007 08:56 AM

Can't mount DVD-R (with disk/data) on HP Laptop
 
Hi! This is my first post. A couple of hours ago I backed up all my files onto 6 DVD-Rs and then erased Windows Vista Premium (which came with my HP dv6265us) and installed Ubuntu 6.10.

I have never used Linux before and have already run into a few problems because I am the sort of person who will not be satisfied if I can't make Linux do a single thing that Windows can do. I figured out how to get the display resolution right by installing 915resolution (but I would *really* appreciate somebody explaining to me why that fixed the problem / what 915 resolution is, what it did, etc - is it a driver? did it just change a config file somewhere?). I then edited the xorg.conf file to get my wacom tablet to work and in the process stuffed up X11 and had to figure out how to use the command-line to restore it from a backup. The Wacom tablet works (except the scroll wheel is inverted, still working on that) and now I'm trying to figure out how to load all of my files from the DVD-Rs onto which they are saved.

When I insert the DVD into the drive and then try to access it (Places -> Computer -> CD-RW/DVD+-R Drive) the drive initializes, I hear it spin, and then I get:

"Unable to mount the selected volume. The volume is probably in a format that cannot be mounted."
"mount: block device /dev/hda is write-protected, mounting read-only

mount: wrong fs type, bad option, bad superblock on /dev/hda,

missing codepage or other error

in some cases useful info is found in syslog - try

dmesg | tail or so

"

I know the DVDs work because I tested them all with Windows before formatting.

Thanks in advance for your help with this, I really think this would be an impossible task if it weren't for all the experienced Linux users out there willing to help.

Hunter

GrapefruiTgirl 03-16-2007 10:48 AM

Code:

/dev/hdb        /media/cdrom                udf,iso9660        defaults,noauto,user        0 0
/dev/hdd        /media/dvdrom                udf,iso9660        defaults,noauto,user,ro        0 0
/dev/fd0        /media/floppy                auto                defaults,noauto,user        0 0

Hello Hunter :) Welcome to Linux. Nice move on the MS removal ;)
OK, the stuff I pasted above is from the file located at /etc/fstab.
That file is what tells the Linux system how to mount various media in the drives.
You see that I have a DVD drvice called /dev/hdd, which mounts on the folder /media/dvdrom.
DVD's and CD's typically have one of 2 filetypes, either UDF or iso9660, so that's what I have specified there. The system first tries to mount a disk as udf, and if that fails, it will try to mount it as iso9660.
In most of my experience, disks made with Windows will be in UDF format.
The entried following the filetype are specific instructions for how to mount the disk, once the filetype has been determined.
In a console window, use the 'man' command to read the manual on the mount command, as well as the fstab file by typing:
man mount
or
man fstab
And you will see all the possibilities for how to mount stuff.
By default, discs mounted under Linux are mounted RO (read-only) because unlike Windows, for example, a CD or DVD cannot be mounted in a writeable fashion unless you are using a disc-burning application like k3b or similar.
If you cannot mount discs as a user, su to root first before mounting, or use the format 'sudo mount /dev/hdd ...etc.....", but the reason I have the 'user' flag on my CD-drives in fstab, is so regular users can mount discs.
NOTE: these instructions are typically carried out in a console, on my system (Slackware) however, the etc/fstab file takes effect system-wide, and any saved changes you make to it should take effect immediately.
Good luck, I hope this helps you out :)
Sasha

HunterLoftis 03-16-2007 11:15 AM

Hi Sasha! Thanks a lot for your help. I followed your instructions (I've tried something similar earlier) and I got this again:

"Unable to mount the selected volume"
"mount: special device /dev/hdd does not exist"

(I get that when I go to Places -> Computer -> DVD-ROM)

Any ideas?

GrapefruiTgirl 03-16-2007 11:49 AM

Hmmm.. Ok, MY dvd device is named /dev/hdd, but is yours?
As per your first post, you are trying to mount /dev/hda, not /dev/hdd.
Check for typos ;)

HunterLoftis 03-16-2007 11:56 AM

How do you find out what your DVD device is named?

GrapefruiTgirl 03-16-2007 12:00 PM

And..
P.S - While I'm not certain, the 915resolution *might* be a kernel module required for your onboard chipset video hardware, depending on what processor and chipset your 'puter has in it..
type lsmod in a console, and if you see the 915 device listed there, then that means it is a kernel module.
If I am on the right track here, the 915 is a newer version of an older module called 800-something, which will be made obsolete by the 915 module eventually.
How did you 'install' the 915 device? By what means?

HunterLoftis 03-16-2007 12:02 PM

I just used Ubuntu's package system to "Apply" it

GrapefruiTgirl 03-16-2007 12:03 PM

Well, you could look around in the /dev folder, and see what hd? devices are there; there shouldn't be very many of them.
I have 4 devices in mine, 2 hard disks and 2 CD-drives, and all are named hda, hdb, hdc, and hdd, depending on what position on the IDE bus they are plugged into.You could also (this is easier) read the file /var/log/dmesg because this file is generated during each boot, and will identify all devices the system detected during boot.
it will have a line identifying the device name, IDE bus number, and device type (CD-ROM, DVD-R, Hard disk, etc)

GrapefruiTgirl 03-16-2007 12:04 PM

OK, LOL, I'm not sure what Ubuntu's 'apply' button does, but.. lsmod will tell you if it is a loaded kernel module.

HunterLoftis 03-16-2007 12:08 PM

Yes it does seem to be a loaded kernel module (called i915) and I checked - my disk is called "hda" - which is weird, because I figured that would be the main hard disk. Anyway, so it's hda but when I try to mount it now it says "Opening CD-RW/DVD-RW Drive..." (and then the drive spins) and then "Unable to mount the selected volume. The volume is probably in a format that cannot be mounted."

Is there a way for me to download other formats? Maybe Windows Vista burns data DVDs in newer formats or something, although that would be really damn annoying

GrapefruiTgirl 03-16-2007 12:16 PM

Well, there really (as far as I know) is no way of 'downloading other formats' however, the linux kernel is equipped to deal with MANY filesystem types (literally dozens).
Now, whether the support for all a persons needed filesystems is compiled and ready to go by default is another question.
It is possible that the disk is in a MSDOS, VFAT (fat-16 or fat-32) or NTFS format. You could also specify the filetype as 'AUTO' in the fstab file, and see what happens there; that will make the kernel try various filesystems for which it has the ability to read, until it finds one that is suitable.
It would be ideal to know what the filesystem is for sure, and LOL It sure would be annoying if they used some screwed up weirdo filesystem. I doubt it though; chances are you just havent stumbled onto the correct filesystem yet.
If it comes down to it (which I dont suspect yet) we can look into your kernel's modules and see what filesystem support it has.
Also, again check the 'man mount' page for other options which may help.
Also, in a terminal, AFTER attempting to mount the disc, type 'dmesg | tail' and this will give you the last output from the kernel, which can give hints as to what exactly the problem is with the disc.

GrapefruiTgirl 03-16-2007 12:34 PM

Here's another possibility, which I had to use in order to use some movie DVD's in my DVD player.
I had to download a DVD-decryption library called 'libdvdcss' in order to decode some types of movies.
You *may* have to look into that, but I doubt it, as this is a computer disc we're talking about here, rather than a copy-protected movie.
Typically, ubuntu has all the necessary stuff built in to make transitioning from Windows relatively easy. However, I'd be happy to continue helping you get this working one way or another if it is still failing.
Mircosoft also uses several 'filesystem extensions' with its CD/DVD formats, such as the Joliet extension, and also one called 'Rock-Ridge' which again are usually enabled by default, but if necessary, we can check into the built-in support for filesystems if need be.

HunterLoftis 03-16-2007 12:44 PM

I'm trying your suggestions now. Just wanted to say thanks so much for helping me!

HunterLoftis 03-16-2007 12:50 PM

I tried "auto" setting and then I also downloaded that dvd decoder and neither of them seem to do the trick...

[17183242.188000] ide: failed opcode was: unknown
[17183242.188000] end_request: I/O error, dev hda, sector 6971008
[17183242.188000] Buffer I/O error on device hda, logical block 871376
[17183247.640000] UDF-fs: No fileset found
[17183432.772000] hda: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
[17183432.772000] hda: media error (bad sector): error=0x30 { LastFailedSense=0x03 }
[17183432.772000] ide: failed opcode was: unknown
[17183432.772000] end_request: I/O error, dev hda, sector 6971008
[17183432.772000] Buffer I/O error on device hda, logical block 871376
[17183438.168000] UDF-fs: No fileset found

HunterLoftis 03-16-2007 12:57 PM

I think this might be the root of my problems:

http://windowshelp.microsoft.com/Win...88f5c1033.mspx


All times are GMT -5. The time now is 12:44 AM.