LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   Can't get Mozilla to connect to internet (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/cant-get-mozilla-to-connect-to-internet-175696/)

dalerobertson 04-28-2004 06:04 PM

Can't get Mozilla to connect to internet
 
Ok, I am very new to Linux and have installed Redhat Linux WS v3(I'm not even sure how to tell the version) on a Dell Latitude CSXH.

I installed a NetGear MA401 wireless ethernet card and had everything working until I screwed around with the display setting. Not knowing how to recover, I reinstalled Linux.

Now I can't get it to connect to the internet. It see's my XP machines through my router, but the RedHat Network connection nor Mozilla will connect to the internet. Each attempt at any website comes back with it could not be found. The connection ICON states that it's online. It's set to use a direct network connection.

Thanks for any help.

Dale

marghorp 04-28-2004 06:19 PM

try netstat

dalerobertson 04-28-2004 06:36 PM

Ok, now what?
 
I tried that command and it came back with quite a bit of info that I'm not sure how to interpret.

Does the IRQ of the Adapter card need to be the same as the PCMCIA services driver?

Also, during boot, the Orinoco services returns an error stating that the ETH0 device does not seem to be present, but the card shows a wireless connection to the AP.

Thanks,

Dale

marghorp 04-28-2004 06:39 PM

are you using KDE?

Try setting the network card under System settings --> Network

dalerobertson 04-28-2004 06:51 PM

More
 
Not sure what KDE is... LOL. I have gone and configured the adapter through system settings --> network and everything looks ok.

One thing I have set is to bind to the MAC address of the NIC.

It's set for DHCP, nickname eth0

I just can't figure out why it connects to other systems on the network, but won't go past the router to the outside world. All security is disabled.

Dale

marghorp 04-28-2004 06:57 PM

The puzzle is over my knowledge. I had the same problem with one machine once. No matter what I did it wouldn't connect to the internet, but it connected to other machines. I ended doing a reinstall and to see at installation of RH9, it actually says configure your network card now or you might experience problems with it later. I did that and it worked fine and still works fine. I am not saying that you should reinstall, but if all else fails and no guru helps you....

Come on gurus, HELP :) (I am not shouting)

Paul Weaver 05-01-2004 03:32 PM

Alright, I assume you aren't too scared of the command line. There is a generic fault-finding process for troubleshooting internet connections.

You have your network running fine if you can see your other computers, so thats not a problem. You'll need to know the IP of your router (mine, for example, is 10.0.0.2, yours may be 192.168.0.1)

Try these

1) Ping your router
Method: In an open terminal (xterm, rxvt, konsole), type "ping 192.168.0.1" (replace with your router's IP address

IF FAILED: Strange, if you can see your windows machines and not your router it's probably a problem with your router's configuration.

2) Ping the external IP of your router (on a windows machine type "tracert www.google.com", a list of IP addresses will come up, the first should be the IP of your router. Should look similar to this:

Quote:

traceroute to www.google.com (216.239.59.104), 30 hops max, 40 byte packets
1 10.0.0.2 15.497 ms 16.952 ms 18.552 ms
2 host-212-158-192-228.bulldogdsl.com (212.158.192.228) 20.223 ms 20.357 ms 21.080 ms
3 host-83-146-17-33.bulldogdsl.com (83.146.17.33) 25.371 ms 27.314 ms 16.236 ms
...
My external address in this case is 212.158.192.228

IF FAILED:
routing problem. Run "route" adnd put the output on this forum. You may neet to be logged is an root to do this. It should say something like this
Quote:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 wlan0
default 10.0.0.2 0.0.0.0 UG 0 0 0 wlan0
If you don't have the "default" line, then you've got a routing problem. The simple way is "route add default gw 10.0.0.2" (replace 10.0.0.2 with your router IP address, but that's not permament.

3) On your linux macine, ping 144.173.6.8 (a machine at Exeter University, UK), which checks your external connectivity

IF FAILED: run "traceroute 144.173.6.8", and see which the last IP address if gets too. This might also be a routing problem

If those work

4) Try "ping www.google.com", this should resolve an IP address, basically look up the name in the internet phonebook. It should come up with
Quote:

PING www.google.akadns.net (66.102.9.104) 56(84) bytes of data.
If that fails, but the previous steps dont, you've got a problem with name resolution - your DNS server. Put the output of "cat /etc/resolv.conf" here.

Not sure how Redhat sets up network cards though

dalerobertson 05-01-2004 08:07 PM

More.....
 
Try these

1) Ping your router
Method: In an open terminal (xterm, rxvt, konsole), type "ping 192.168.0.1" (replace with your router's IP address

IF FAILED: Strange, if you can see your windows machines and not your router it's probably a problem with your router's configuration.

>>Worked fine

2) Ping the external IP of your router (on a windows machine type "tracert www.google.com", a list of IP addresses will come up, the first should be the IP of your router. Should look similar to this:

>>command not recoginized on Linux. XP maching provide the full trace.



quote:
--------------------------------------------------------------------------------

traceroute to www.google.com (216.239.59.104), 30 hops max, 40 byte packets
1 10.0.0.2 15.497 ms 16.952 ms 18.552 ms
2 host-212-158-192-228.bulldogdsl.com (212.158.192.228) 20.223 ms 20.357 ms 21.080 ms
3 host-83-146-17-33.bulldogdsl.com (83.146.17.33) 25.371 ms 27.314 ms 16.236 ms
...

--------------------------------------------------------------------------------



My external address in this case is 212.158.192.228

IF FAILED:
routing problem. Run "route" adnd put the output on this forum. You may neet to be logged is an root to do this. It should say something like this

quote:
--------------------------------------------------------------------------------

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 wlan0
default 10.0.0.2 0.0.0.0 UG 0 0 0 wlan0

--------------------------------------------------------------------------------



If you don't have the "default" line, then you've got a routing problem. The simple way is "route add default gw 10.0.0.2" (replace 10.0.0.2 with your router IP address, but that's not permament.

3) On your linux macine, ping 144.173.6.8 (a machine at Exeter University, UK), which checks your external connectivity

>> This worked just fine.

IF FAILED: run "traceroute 144.173.6.8", and see which the last IP address if gets too. This might also be a routing problem

If those work

4) Try "ping www.google.com", this should resolve an IP address, basically look up the name in the internet phonebook. It should come up with

quote:
--------------------------------------------------------------------------------

PING www.google.akadns.net (66.102.9.104) 56(84) bytes of data.

--------------------------------------------------------------------------------



If that fails, but the previous steps dont, you've got a problem with name resolution - your DNS server. Put the output of "cat /etc/resolv.conf" here.

>> I couldn't find any such file. However I think you have helped narrow done were the issue is. Thanks.

Not sure how Redhat sets up network cards though

dalerobertson 05-01-2004 10:45 PM

I have determined that I can get to any website by typing the IP address.

So now the question is:

Where's the name resolver?

--Dale

Paul Weaver 05-02-2004 07:42 AM

/etc/resolv.conf

Mine looks like
Quote:

nameserver 10.0.0.3
search isorox.co.uk
When I was at Exeter uni it was

Quote:

nameserver 144.173.6.6
search ex.ac.uk
Again, I don't know the redhat GUI way of doing it. Your DHCP server should set it, but obviously it's not.

dalerobertson 05-02-2004 07:45 AM

it's fixed!!!
 
I poked around on the RH website and found out that in my ifcfg script that if dhcp is used, then PEERDNS must be enabled to allow modification to the file that resolves names. Of course, mine was set to NO.

Thanks,

Dale


All times are GMT -5. The time now is 02:17 PM.