-   Linux - Laptop and Netbook (
-   -   Can't get dvd/cdrom drive mounted on toshiba laptop (

jzero 09-29-2003 12:26 PM

Can't get dvd/cdrom drive mounted on toshiba laptop
hey all,

been working w/ this for a few days now and just can't get the cd/dvd rom drive mounted. specs below:

Toshiba Satellite 5205-s505
Redhat 9
Kernel version 2.4.19

when I try to mount the device via:
mount /mnt/cdrom/
mount -t iso9660 /dev/cdrom /mnt/cdrom
i get the error
mount: /dev/cdrom is not a valid block device

the cdrom drive appears to be at /dev/hdb with a symbolic link from /dev/cdrom. fstab has an entry for /dev/cdrom. I've tried recompiling the kernel with IDE/ATAPI CDROM support built in and as a module, also tried compiling with SCSI CDROM support as well, both built in and as a module to no avail.
Anyone else having this problem, or am I doing something wrong?

Thanks for your help in advance!

:study: :study: :study:

frankieboy 09-29-2003 02:27 PM

How about kernel-parameters

If you're using LILO you should add
append hdc=ide-scsi

With GRUB set
directly behind the kernel-call.

Pls give feedback, if this hint helps you

Best regards


jzero 09-29-2003 02:34 PM

Hi Frank,

Thanks for responding so quickly :)

Here's what's in my grub.conf right now, not exactly sure what the insmod is for, got it from a document on getting linux working on this model:

kernel /k2419 ro root=/dev/hda2 insmod hdb=ide-scsi vga=0x31b idebus=66

Thanks again!

frankieboy 09-29-2003 03:40 PM

Hello j0,

pls type lsmod and look for these entries:

sr_mod 18136 0 (autoclean)
ide-scsi 12208 0
scsi_mod 107544 3 [sg sr_mod ide-scsi]
ide-cd 35712 0
cdrom 33728 0 [sr_mod ide-cd]

Then check if /dev/cdrom is a link to /dev/scd0


jzero 09-29-2003 04:11 PM

Hi Frank,

Here's the what lsmod spits out:

Module Size Used by Tainted: PF
nvidia 1676448 10 (autoclean)
vmnet 23496 6
vmmon 27828 0 (unused)
keybdev 2944 0 (unused)
mousedev 5492 1
hid 22148 0 (unused)
input 5728 0 [keybdev mousedev hid]

no entry for anything scsi as far as I can tell.
It looks like /dev/cdrom is a link to /dev/hdb but it doesn't look like anything's pointing to /dev/scd0

Thanks again!

megaspaz 09-29-2003 08:41 PM

just went through this with my dad after we enabled scsi emulation. my guess coincides with yours in that /dev/cdrom isn't a valid block device any longer because it points to hdX (usually hdb or hdc). basically check your /dev folder and look for any cdrom links (cdrom, cdrom1, cdrom2, etc...). look at their properties and see where they point to. to test out open up your shell terminal and instead of using /dev/cdrom try using /dev/scd0 or /dev/scd1. if you get an error message about bad fs or no medium found, then you're half way there to figuring out the scsi mapping. if your drive used to be hdb, my guess is that the device block you want would be /dev/scd0. i'm also guessing, from what i experienced, that kudzu automatically created more /dev/cdromX links in /dev. all you have to do is delete /dev/cdrom and rename the right /dev/cdromX to /dev/cdrom.

All times are GMT -5. The time now is 11:50 AM.