-   Linux - Laptop and Netbook (
-   -   Cannot get wireless to work on Toshiba Satellite L350-170 (Wireless card: RTL8187B) (

TiggerTiggerTigger 01-06-2009 03:24 PM

Cannot get wireless to work on Toshiba Satellite L350-170 (Wireless card: RTL8187B)
I've recently bought a Toshiba Satellite L350-170 on which I have installed Slackware. The installation was fine, but I have not yet been able to connect to the internet with wireless. Realtek's website seems to have drivers for Linux for most of its wireless cards, but for some reason, one is not provided for the RTL8187B ( I considered using ndiswrapper for one of the Windows drivers, but upon compilation, I received a series of errors:

-- snip --
/home/luke/ndiswrapper-1.53/driver/iw_ndis.c:1159: error: too few arguments to function 'iwe_stream_add_point'
make[3]: *** [/home/luke/ndiswrapper-1.53/driver/iw_ndis.o] Error 1
make[2]: *** [_module_/home/luke/ndiswrapper-1.53/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/luke/ndiswrapper-1.53/driver'
make: *** [all] Error 2

I am fairly new to Linux, so any advice would be greatly appreciated. Thanks in advance.

Drakeo 01-06-2009 03:59 PM

the drivers for that card are built into the kernel. 2.6.27 and up.
rtl drivers work on the 2.6.27 and up up grade or use the ndiswrapper. I just installed two of the rtl 8185 8187 chips this week . first I down loaded pupp4.12 that has the new kernel and tried works great so I up graded my systems. other wise use the ndiswrapper I used on one of my old laptops. I use the kernel for both slackware 12.1 and 12.2 and the rtl works fine. and I do not use the ndiswrapper. if you do you will have a conflict with the kernel it will load it before it loads the ndiswrapper. then go get the to slackware extra and install the cool program wicd in extras you will find it. it works great. make sure you reboot after installing the wicd program.

alvlin 01-06-2009 04:23 PM

Also, if you are not doing it already, use the ndiswrapper SlackBuild to compile ndiswrapper, it should compile without errors.

TiggerTiggerTigger 01-07-2009 02:18 PM

Thanks for the replies. I tried the ndiswrapper SlackBuild and the ndiswrapper compilation went smoothly so thank you for that! Eventually, I loaded the Windows driver onto it, which seemed to go well, and then used "ndiswrapper -m" to write the configuration to modprobe. Then, after appending "ndiswrapper" to the (then empty) /etc/modules.conf file as advised, I rebooted to find that I still couldn't connect to the internet.

I'm not at all sure if I've done everything I was supposed to or if I correctly used ndiswrapper. The driver should be right as I downloaded it from the Toshiba website which said that it was for this computer. So, in short, I am completely bewildered. Once again, thank you for the replies. I hope I'm getting somewhere now.

alvlin 01-07-2009 04:51 PM

Let's go step by step.
First: is ndiswrapper module loaded? you can check that with lsmod
Modification of /etc/modules.conf is not encouraged anymore. You should create a "ndiswrapper" file under /etc/modprobe.d with this content:

alias wlan0 ndiswrapper
Second: is it detecting your device properly? give ndiswrapper -l to find out. It should return "driver found" and "device present"
Third: which program are you using to control the network? Slackware comes with wicd in the /extra folder, you should install it and let it control the network. If you install it, remember to comment out ALL the lines on /etc/rc.d/rc.inet1.conf (no line should be left uncommented) otherwise it won't work properly (this is not always the case, but at least for me it was)

Good luck and regards.

TiggerTiggerTigger 01-07-2009 06:33 PM

Wow. I was actually really panicking about possibly never being able to use the internet on this computer, which would've been quite a shame. It turns out the only reason it wasn't working is because I wasn't actually using a network controller. And Wcid works nicely. I much appreciate your help, and now at last I feel like I have a whole system up.

All times are GMT -5. The time now is 11:35 PM.