LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 01-21-2012, 09:59 PM   #16
Ahaaa
Member
 
Registered: Jan 2012
Location: Melbourne
Distribution: Ubuntu
Posts: 45

Original Poster
Rep: Reputation: 1

I've had some excellent success! Despite my problems differing from here, a similar approach fixed it! For the record, I booted from USB (Linux Mint 12, 64-bit, Live DVD), using "Universal USB Installer". On the Linux splash screen, I edited boot options (by pressing tab). I found this line
Code:
/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.lz quiet splash --
and added text to make it
Code:
/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.lz quiet splash -- acpi=off
I then installed Linux Mint (using gparted to make partitions, as the installer partitioner failed).

I restarted, again needing to specify acpi=off. I edited boot options again (this time by pressing "e" as per the on-screen instruction. Then, I changed the line ending with
Code:
...quiet splash vt.handoff=7
to
Code:
...quiet splash vt.handoff=7 acpi=off
I opened up terminal, typed in
Code:
sudo nano
/etc/default/grub
then changed
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=enable pci=noacpi pci=assign-busse acpi=ht"
quit nano (control-x, "y", enter), then edited the GRUB file from within terminal by typing
Code:
sudo update-grub
Do you know what the "acpi=enable pci=noacpi pci=assign-busse acpi=ht" options actually do? Is this a suboptimal workaround? I have noticed a problem now, where I cannot wake the screen after it begins to sleep. Is there a way to solve this?

Cheers, and thanks for all the advice!
 
Old 01-21-2012, 11:27 PM   #17
Ahaaa
Member
 
Registered: Jan 2012
Location: Melbourne
Distribution: Ubuntu
Posts: 45

Original Poster
Rep: Reputation: 1
To clarify, the screen works fine on waking from suspend. The issue that I have is when the *screen* sleeps (and the computer remains awake). In this situation, I cannot make the screen wake up.
 
Old 01-23-2012, 04:01 AM   #18
mdlinuxwolf
Member
 
Registered: Dec 2006
Distribution: Mepis and Fedora, also Mandrake and SuSE PC-BSD Mint Solaris 11 express
Posts: 378

Rep: Reputation: 41
booting

First, obviously, make sure your bios is set to boot from the DVD-rom or USB.

Its best to use the Live version to see if everything works, but the full size DVD for the actual install if the 2 are different. The distro and its version should be identical.

I use k3b to burn O/S discs. DVDs ad CDs are usually the best way to install, even if you need an external drive for a netbook. Live USBs sometimes work well, but can be troublesome at times. Obviously, burn at a slower speed then max. Usually I burn at 50% to 75% of the max speed. I haven't had any problems doing it that way.
 
Old 01-23-2012, 04:16 AM   #19
Ahaaa
Member
 
Registered: Jan 2012
Location: Melbourne
Distribution: Ubuntu
Posts: 45

Original Poster
Rep: Reputation: 1
Sorry, I think you replying to my previous post? I've since installed Linux, by tweaking some settings, but I'm not sure what they did exactly.

Thanks for the help anyway.
 
Old 01-25-2012, 09:05 AM   #20
Ahaaa
Member
 
Registered: Jan 2012
Location: Melbourne
Distribution: Ubuntu
Posts: 45

Original Poster
Rep: Reputation: 1
So I have been reading more, and came across this page that describes some of the boot options, and ways to troubleshoot acpi issues. The page suggests that if "acpi=off" solves the problem, then to try other options, as quoted here:
Code:
acpi=ht
    the most like "acpi=off", disables all of ACPI except what is needed to enumerate processors.
    If acpi=off works and acpi=ht fails, then the issue is in the ACPI table parsing code itself, or perhaps the SMP code. 
pci=noacpi
    Disables ACPI for PCI root bus enumeration.
    Disables ACPI for IRQ routing. 
acpi=noirq
    Disables ACPI for IRQ routing. 
pnpacpi=off
    Disables the ACPI component of the Linux Plug and Play code. 
noapic
    Disables the IO-APIC for IRQ routing. 
nolapic
    Disables the Local-APIC and the IO-APIC.
I tried all six options independently, and the only option that worked was pci=noacpi. Unfortunately, I don't know how to interpret this, nor does the article elaborate beyond troubleshooting.

I suspect that my previous workaround of "acpi=enable pci=noacpi pci=assign-busse acpi=ht" was overkill. I couldn't find much information on acpi=enable, but this would seem counter-intuitive, since I'm turning parts of acpi off later. pci=assign-busse was also un-Googleable, and is possibly a typo for pci=assign-busses? Finally, acpi=ht seems unnecessary since pci=noacpi works alone.

I was wondering if anyone could elaborate on the effects of pci=noacpi on my computer, whether it was a valid workaround, and whether there was a better alternative.
 
Old 01-27-2012, 05:51 PM   #21
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,563

Rep: Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780
Not a big deal. Acpi is usually OK in newer systems but I am stumped as to why it fails on a new system.

acpi is generally power but could be much more. The specification covers a lot of hardware controls.

It is a valid workaround for many types of hardware. Generally acpi fails more in laptops.


Sorry about my initial assumptions.
 
Old 01-27-2012, 06:26 PM   #22
Ahaaa
Member
 
Registered: Jan 2012
Location: Melbourne
Distribution: Ubuntu
Posts: 45

Original Poster
Rep: Reputation: 1
Thanks. And no worries. I appreciate the time and effort you have put into helping me.

Just to give this thread some closure, and hopefully help others with similar problems, I've since managed to boot without any custom options. I'm not 100% sure what it was, but I installed Bumblebee, which is a package that controls the Optimus Nvidia graphics card (since the native drivers do not function correctly). This package will not work with pci=noacpi (or acpi=off), so I attempted to disable it. This worked fine (both in booting and with Bumblebee). I'm guessing that either general system updates or this package is to blame for fixing my computer!

Thanks again.
 
1 members found this post helpful.
Old 03-31-2012, 10:02 AM   #23
bcatarino
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
After doing the steps posted in the forum, I installed the NVIDIA drivers. I can now boot without editing any options on boot, so it seems it's a problem with the graphic card (as noted before in the forum and many other foruns I looked).

Anyway, thanks for this amazing thread that just saved my life (and 800 )
 
Old 04-01-2012, 12:22 AM   #24
Ahaaa
Member
 
Registered: Jan 2012
Location: Melbourne
Distribution: Ubuntu
Posts: 45

Original Poster
Rep: Reputation: 1
I'm glad it could help you! It's so frustrating when it doesn't work out-of-the-box! I was despairing that I'd never see Linux on my computer. Enjoy Linux!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] dell XPS L502X will not boot Marty Kraimer Fedora - Installation 14 01-29-2012 11:58 AM
[SOLVED] Can't boot into Slackware 13.37 on my Dell XPS 15 sudeepkulkarni Slackware 13 06-01-2011 05:49 AM
[SOLVED] Dell Vostro 3500 unable to boot from live cd (Fedora core 13) mkhan919 Linux - Laptop and Netbook 2 10-22-2010 12:55 PM
Is Dell XPS 16 is compatible for using linux (ubuntu) iamarunbabu Ubuntu 4 11-18-2009 01:03 AM
Dell XPS M1530 - Dell ubuntu ISOs? danraider Linux - Laptop and Netbook 4 04-02-2008 05:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 06:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration