-   Linux - Laptop and Netbook (
-   -   Cannot boot. Errors on disk. (

dsl_ 11-29-2012 01:19 PM

Cannot boot. Errors on disk.
Out of nowhere I suddenly cannot boot my laptop. It appears I have errors on /dev/sda5. I dualboot with Windows 7 and everything has been working so far.

I tried booting from SystemRescueCD in order to run a fsck on the partition but fsck says it doesn't exist even though "fdisk -l" happily shows it.

What is going on?! How can I run fsck on the partition if it cannot find it?

It says:

root@sysresccd /root % fsck -f /dev/sda5
fsck from util-linux 2.21.2
e2fsck 1.42.6 (21-Sep-2012)
fsck.ext2: No such file or directory while trying to open /dev/sda5
Possibly non-existent device?

Although "fdisk -l" shows all partitions /dev/sda1 thru /dev/sda7 1 and 5 being the boot partitions for Windows and Debian respectively.

Anyone? This is driving me mad!

dsl_ 11-29-2012 01:26 PM

OKL. Now I tried to run:

file -s /dev/[hs]d[a-f][1-9].

to see what file thinks of my partitions and lo and behold it doesn't find /dev/sda5!
In fact both sda4 and sda5 are missing.

What do I do?

dsl_ 11-29-2012 01:36 PM

Well, gparted found it and is running a check on the little bugger now... weird.

dsl_ 11-29-2012 01:38 PM

Nope. I end up with the same error from fsck. I really have to reinstall everything?! :(

All times are GMT -5. The time now is 09:37 PM.