LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 01-05-2010, 02:43 PM   #1
fischerville
LQ Newbie
 
Registered: Jan 2010
Location: Toronto
Distribution: Ubuntu, Slackware
Posts: 5

Rep: Reputation: 0
Can't mount cdrom (thinkpad t23; slackware 13; xfce)


I have been working on this for three days and i've found a few posts that are similar but haven't solved my problem. I first installed Slack 13 on my Thinkpad T23 a week ago and was unable to mount from the cdrom. It was giving me an error

#> mount -t iso9660 /dev/cdrom /mnt/cdrom
/dev/hdc: unknown device

Or something similar. I followed this post, which seems to describe a similar problem, and I subsequently installed cdfs, but it didn't solve my problem.

Now i am able to mount a music cd, but not a cdrom. I'm getting this response.

#> mount -t cdfs /dev/cdrom /mnt/cdrom
mount: no medium found on /dev/hdc

For the record, here is my fstab:
Code:
/dev/hda2        /                ext4        defaults         1   1
/dev/hda1        /home            ext4        defaults         1   1
/dev/hda3        none             swap        sw
/dev/hda4        /opt             ext4        defaults         1   1
/dev/cdrom       /mnt/cdrom       cdfs        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
and from dmesg | grep hdc
Code:
hdc: TOSHIBA DVD-ROM SD-C2512, ATAPI CD/DVD-ROM drive
hdc: host max PIO4 wanted PIO255(auto-tune) selected PIO4
hdc: UDMA/33 mode selected
ide-cd: hdc: ATAPI 24X DVD-ROM drive, 512kB Cache
Any ideas? It has occurred to me that this might be an XFCE problem.
 
Old 01-05-2010, 04:07 PM   #2
GooseYArd
Member
 
Registered: Jul 2009
Location: Reston, VA
Distribution: Slackware, Ubuntu, RHEL
Posts: 183

Rep: Reputation: 46
Is dmesg showing you any device errors around the time you try to mount? It sounds like an issue with the device.
 
Old 01-05-2010, 04:35 PM   #3
fischerville
LQ Newbie
 
Registered: Jan 2010
Location: Toronto
Distribution: Ubuntu, Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
i haven't seen anything like that... here is the result from

#>tail -n 15 /var/log/dmesg

Code:
powernow: This module only works with AMD K7 CPUs
cpufreq: No nForce2 chipset.
EXT4-fs: barriers enabled
kjournald2 starting: pid 2814, dev hda1:8, commit interval 5 seconds
EXT4 FS on hda1, internal journal on hda1:8
EXT4-fs: delayed allocation enabled
EXT4-fs: file extents enabled
EXT4-fs: mballoc enabled
EXT4-fs: mounted filesystem hda1 with ordered data mode
EXT4-fs: barriers enabled
kjournald2 starting: pid 2815, dev hda4:8, commit interval 5 seconds
EXT4 FS on hda4, internal journal on hda4:8
EXT4-fs: delayed allocation enabled
EXT4-fs: mballoc enabled
EXT4-fs: mounted filesystem hda4 with ordered data mode
 
Old 01-05-2010, 04:40 PM   #4
fischerville
LQ Newbie
 
Registered: Jan 2010
Location: Toronto
Distribution: Ubuntu, Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Also, to be clear, i've had WinXP, Ubuntu 8.10, Ubuntu 9.04 installed on this laptop, all installed from CD or DVD. So as for the physical drive, i'm reasonably sure it's sound. As for the /dev/hdc, i haven't a clue. I'm not really clear on how much the distro and/or the desktop manager affects how the devices work.
 
Old 01-05-2010, 05:51 PM   #5
fischerville
LQ Newbie
 
Registered: Jan 2010
Location: Toronto
Distribution: Ubuntu, Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Another similar posting has suggests looking here, and the mappings look to be doing exactly what they say they are...

#>cat /etc/udev/rules.d/70-persistent-cd.rules

Code:
# This file was automatically generated by the //lib/udev/write_cd_rules
# program, run by the cd-aliases-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and set the $GENERATED variable.

# TOSHIBA_DVD-ROM_SD-C2512 (pci-0000:00:1f.1-ide-1:0)
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:1f.1-ide-1:0", SYMLINK+="cdrom0", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:1f.1-ide-1:0", SYMLINK+="cdrom", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:1f.1-ide-1:0", SYMLINK+="dvd0", ENV{GENERATED}="1"
ENV{ID_CDROM}=="?*", ENV{ID_PATH}=="pci-0000:00:1f.1-ide-1:0", SYMLINK+="dvd", ENV{GENERATED}="1"
 
Old 01-10-2010, 08:36 PM   #6
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Quote:
For the record, here is my fstab:
Code:

/dev/hda2 / ext4 defaults 1 1
/dev/hda1 /home ext4 defaults 1 1
/dev/hda3 none swap sw
/dev/hda4 /opt ext4 defaults 1 1
/dev/cdrom /mnt/cdrom cdfs noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
Try changing your fstab file to make the cdrom use iso9660 and user, not owner(usually root). Also rw if you want to burn from it.
/dev/cdrom /mnt/cdrom iso9660 noauto,user,rw 0 0

Tom (retired penguin)
linxt@comcast.net
 
Old 01-16-2010, 09:39 AM   #7
the_penguinator
Member
 
Registered: Jan 2009
Location: Canada
Distribution: slackware, OpenBSD, OSX
Posts: 211

Rep: Reputation: 22
Have a look in /etc/group and see if you as a user are a member of audio,video,cdrom,plugdev,power and you should also be listed as a member of netdev and scanner as well. If not, as root use your favourite text editor to add yourself to those groups. Upon restarting, all should be well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WLAN on Thinkpad T23 unstable didi156 Linux - Hardware 1 03-23-2006 12:15 PM
Slackware 10.2, 2.6.13 kernel recompile, and a Thinkpad T23 SocialEngineer Slackware 8 10-23-2005 06:46 PM
Need to Install Slackware 10.1 on an ibm thinkpad T23 ttumelty Slackware - Installation 5 08-22-2005 08:52 AM
Suse on t23 thinkpad sachinnshah Linux - Networking 0 09-27-2004 12:47 AM
Porblems installing Slackware 8.0 on a Thinkpad T23 Sfin Slackware 2 08-04-2002 11:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 03:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration