-   Linux - Laptop and Netbook (
-   -   bootable usb on laptop and netbook (

prudra 04-30-2013 08:49 AM

bootable usb on laptop and netbook
I made a bootable usb flashdrive by the root command:
#dd if=debian-live-6.0.7-i386-gnome-desktop.iso of=/dev/sdb bs=1M;sync

My dell-vostro-xxxx laptop recognized the usb and I could run the live OS. But when I tried it on my Zenith-AlwaysOn (Indian OEM) netbook
the machine simply hung and refused to recognize the usb.
With debian-wheezy-live-rc1-i386-gnome-desktop.iso both the machine
booted without any hiccup.
Can anybody please explain why this strange behaviour?

DaneM 04-30-2013 01:33 PM

I've seen this before--where a computer won't boot off a specific flash device--but it's more likely a configuration problem.

Please explain exactly what you mean by it not being recognized? Error message? Blank screen? Not listed in the POST screen? The more info the better!

What's your boot device priority list look like in the BIOS/CMOS setup screen? Please post here all information that even mentions drives and booting in your BIOS, and I'll see if anything got missed.

One I have that info, I'll be able to assist you better. If it really is a hardware conflict/problem, we can troubleshoot that after I have the above information and we've tried a few simpler steps.

Have a good one!


jefro 04-30-2013 03:29 PM

Be sure to do cold boot with usb in. Then go directly to bios and move the hard drive order to usb first.

You may have to try some other things. I didn't know the debian live was a hybrid iso.

prudra 05-01-2013 07:59 AM

About the live-debian first: this is available in ---> stable ---> i386 ---> iso-hybrid.

My boot option order is first usb then others.

In fact, when I have used the non-live iso image of debian everything goes fine; as also with ubuntu, xubuntu, opensuse, live wheezy. It is only in live squeeze that the machine is obdurate.

When I switch on the machine, first a logo [Zenith Always On] appears then
the machine starts booting. That's the normal thing.

With this live usb plugged in the machine continues with the [Zenith Always On] logo, ad infinitum.

jefro 05-01-2013 03:28 PM

Did you try what I suggested?

Good that you cleared that up for me on the iso. Thanks.

DaneM 05-01-2013 11:38 PM


Thanks for the clarification.

I ran into this a couple of times when I was doing computer repair. Some motherboards just hate certain USB hardware--anything from hubs, to flash drives, to gamepads, etc. I have yet to determine WHY this happens, but when it does, the main symptom (or only symptom) is that if you try to boot with it in, it won't get past the initial POST screen, or the screen will simply remain black (depending on the computer).

For a flash drive, you might try the following from a Linux computer. Make sure that there's nothing on it you care about before starting.

1. Plug the flash drive in.

2. Type the following (as root):


# Identify the device name of your flash drive--probably /dev/sdXY.  Note what "X" and "Y" are.
umount /dev/sdXY
badblocks -svw /dev/sdX
# Note that "Y" isn't included.  This will check your drive with a read/write test.  It will erase all data!  (Non-destructive tests can only test for certain kinds of defects.)

Wait for the test to finish. If numbers start appearing, then those are bad sectors: your drive is effectively "dead," and the solution is to simply use a different flash drive. (Depending on how it's being read on each piece of hardware, the bad sectors may or may not be noticed--hence, some computers will "like" it and not others.) If not, then the drive is almost certainly OK, and the problem is with the laptop's motherboard not "liking" it. Hopefully, someone knows how to get past the latter problem; I've never been able to reconcile it, short of not using that device with that motherboard.

Hope that helps.


prudra 05-02-2013 03:22 AM

I'll answer DaneM first. The funny thing is that this occurs only when live version of the Stable Debian is tried. (This also is the case with live linuxmint maya.) There is no problem with live versions of Wheezy, ubuntu,xubuntu, opensuse; nor with non-live version of squeeze; all tried with the same usb.
When tried all these on the other dell laptop eerything is ok. So the usb must be all right. The hardware of the netbook must be the culprit.

Jefro, I didn't understand what is cold booting.

However, since Wheezy will be out this weekend and the non-live version of the stable on this usb creates no problem (I am already working with Squeeze on this netbook), all this must be academic.

But I am simply curios.

DaneM 05-02-2013 06:17 AM


Well, here's something you can try: have you used the "isoinfo" tool to see what's different about the images? Specifically, the boot-up methods employed by the different images could be part of the problem. (I think that they SHOULD work on any PC if they work on one, but...) For example, this is what I get with I look at the Linux Mint 14 64-bit MATE ISO:


dane@orchestrator /mnt/PERSONAL/Dane/ISO/Linux/Linux Mint/14 Nadia $ isoinfo -d -i linuxmint-14-mate-dvd-64bit.iso
CD-ROM is in ISO 9660 format
System id: LINUX
Volume id: Linux Mint 14 MATE 64-bit
Volume set id:
Publisher id:
Data preparer id:
Copyright File id:
Abstract File id:
Bibliographic File id:
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 495477
El Torito VD version 1 found, boot catalog is in sector 69
Joliet with UCS level 3 found
Rock Ridge signatures version 1 found
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID ''
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 4
        Bootoff 46 70

The "Eltorito," "Joliet," and "Rockridge" stuff are probably of specific importance in this, but you might also note anything that's different about the images, because "the clue" may lie therein. :-)

prudra 05-04-2013 11:28 AM


Originally Posted by jefro (Post 4942906)
Did you try what I suggested?

Good that you cleared that up for me on the iso. Thanks.

Now that I have learned what is cold booting I tell that I have all along been doing exactly that. In fact, I have learned in the hard way that restarting the computer with a live bootable usb does not work on my netbook.

jefro 05-04-2013 03:34 PM

So you did a full power down, pulled the plug and removed battery, pressed power button a few times, then attached usb flash, attached power and booted to bios? What did you see in bios in "hard drive" order??

prudra 05-07-2013 08:51 PM

Now that wheezy has become stable, I downloaded
and dd'ed it on the usb flashdrive and now the netbook is booting.
My previous attemt was for squeeze

Maybe, something was changed in the wheezy release and this is one case when
Murphy's law is not working.

jefro 05-08-2013 04:00 PM

Hummm, I'd think you may be correct or even some slight error in original data. Who knows.

Sounds like you fixed it.

All times are GMT -5. The time now is 11:22 PM.