-   Linux - Laptop and Netbook (
-   -   Black screen following grub (

memilanuk 04-03-2013 11:02 AM

Black screen following grub
So... last fall I picked up a Lenovo ThinkPad T530, w/ 4GB RAM, i5 processor, 500GB HDD and a DVD-RW. In general terms, Linux worked pretty well on this machine - Ubuntu 12.10, Mint 14, Scientific 6.3, openSuSE 12.2 all installed and worked fine. I eventually settled (more or less) on Ubuntu 12.10, as more things worked 'out of the box' (pretty much everything), and co-existed pretty well in a dual-boot setup with Win7 Pro.

About three weeks ago I 'upgraded' to 16GB RAM, a 256GB SSD, moved the 500GB HDD to a drive caddy and replaced the DVD drive with that. Getting all the data moved around and what not took some considerable shuffling, but it worked. Somewhere in there I'd loaded XFCE/Xubuntu packages, and behaviour had been a little erratic (when using XFCE, not under Unity). Still, everything basically 'just worked'.

I did a clean re-install of Xubuntu 12.10... and things started getting *really* flaky. Hardware switches for volume/mute that 'just worked' in other versions no longer did. After a few cycles going back and forth between Win7 (no problems) and Xubuntu due to various updates and other things, I started encountering more weirdness - after selecting the X/Ubuntu option from grub2, the screen would flicker, show a cursor (underscore) briefly, and then nothing. Just a black screen, totally unresponsive. Tried switching to alternate ttys via keyboard shortcuts... nothing.

Fine... I'd been getting fed up with XUbuntu anyway. I made a bootable LiveUSB image of openSuSE 12.3, and installed it - taking care of some partition issues I'd had left over from the original migration from the larger HDD to the smaller SSD. Everything seemed to be working fine... but I wasn't liking KDE that much... so I installed Fuduntu 2013.1 last night.

Again, everything seemed to install fine... until I went to reboot after applying some updates. Same thing... after selecting the default option from grub2, I got... nothing. Black screen, completely unresponsive until I manually power-cycled the machine.

So now I've had at least two different distros (Xubuntu and Fuduntu) that are displaying the same odd behavior, shortly after applying updates. Ubuntu and openSuSE don't seem to have an issue... but at this point (with Fuduntu installed) I'm not sure how to go about troubleshooting things when I can't even get a display to work with.

Any suggestions?

PTrenholme 04-03-2013 01:20 PM

How long did you wait after the "black screen" was displayed? Sometimes the grub2 gfxpayload settings are not correct, and you won't see anything until the X-server is started late in the boot process. (Usually a few minuets.)

memilanuk 04-03-2013 01:22 PM

10-15 minutes

PTrenholme 04-06-2013 12:18 AM

First, a disclaimer: My only Ubuntu is 12.10 in a virtual system, and it's booted directly.

However, if I recall correctly, the GRUB2 boot menu that Ubuntu creates has, in addition to the "default" boot option, a "rescue" option. If you select that option, you should be given several boot options. One (or more) of those options should let you specify the driver to use with your monitor.

Since the "black screen" is (I my opinion) the result of Ubuntu selecting display settings that are not supported by your hardware, try the VESA driver to see if that will work (almost all display drivers support the old VESA standard). If it does, see if you can tell what Ubuntu "thinks" your setting should be, and change them to what is working in your other (working) Linux distributions. (That might be as simple as copying /etc/X11/xorg.conf from a working distribution to your Funbutu one, but you might have to run the Xorg -configure command (after doing a sudo su - in a terminal window to get logged in as "root"). (See man Xorg for details.)

memilanuk 04-06-2013 12:34 AM

Well, since I wasn't going to sit there with a half-b0rked system... it's since been re-installed as straight Ubuntu 12.10, which worked fine from the start. It was Xubuntu and Fuduntu that didn't play nice. Guess I'll stick with regular Ubuntu for now...

memilanuk 04-10-2013 09:34 AM

Well, that didn't last long. :(

Yesterday I downloaded and applied the most recent security updates, which included kernel 3.5.0-27generic. When I went to reboot, guess what? Black screen after grub.

I fiddled around a bit, and I'm able to boot normally from the previous kernel (3.5.0-26generic), but the latest update (which I would imagine is what I got when updating Fedora 18 and Fuduntu 2013.1 previously) seems to cause the system to lock up somewhere during startup.

Any suggestions at this point as to how to hunt this down?

All times are GMT -5. The time now is 03:46 PM.