-   Linux - Laptop and Netbook (
-   -   BIOS thinks hard disk is unusable after installing Grub (

Pap 11-13-2012 05:15 AM

BIOS thinks hard disk is unusable after installing Grub
Hi all,
I tried to install Debian Linux (64-bit) on a new Fujitsu Lifebook AH531. The system should be more than efficient for this (Quad processor, 8Gb RAM), and I am not new on installing Debian. However, I came across a problem. Debian was installed flawlessly, and also installed Grub2 in MDR for dual boot (Windows 7 was already pre-installed). BIOS boot sequence was set to hard disk first before rebooting. However after system reboot, I see something like this:

Intel UNDI, PXE-2.1 (build 083)
Realtek PCIe GBE Family Controller Series v2.41 (06/08/11)

Apparently, the system thinks the hard disk is empty or something like that, so tries to book from the network. After some time, it fails of course, and I get a simple menu asking me what device should be used for booting.
All that happens before the Grub2 screen for selecting operating system, so it seems to be a BIOS issue. For some reason, BIOS thinks the hard disk unusable. However, the hard disk is perfectly ok: if I use the SuperGrub2Disk utility from a boot CD, I can have access to Grub2 and from there I can boot either Debian or Windows 7 without any problem on both operating systems. It is, however, a very inconvenient workaround.
I tried anything I could think of to solve the annoying issue, such as looking at the Internet and updating the BIOS, but the problem is still there: The system still can't boot, unless I boot a SuperGrub2Disk CD and have access to Grub2 from there. I assume someone else had the same problem, so any help would be appreciated.

Thanks in advance.

malekmustaq 11-13-2012 11:02 AM


All that happens before the Grub2 screen for selecting operating system, so it seems to be a BIOS issue. For some reason, BIOS thinks the hard disk unusable.
It is not that worse actually. Your laptop runs a dual core sandy bridge, all things are in order to run for Gnu/linux.

Boot the laptop, when the screen comes up press Del or F2 or F10 whichever leads you to the BIOS setup configuration. You must get into the BIOS. Being there, find the configuration something that offers you to choose which device to boot. Usually the choices to make is --
First: The Optical DVD Drive
Second: Hard Disk
Disable the PXE boot, you do not need it, yet most of the netbooks set this to priority as the first booting device. AFter disabling PXE be sure to Save and Exit the BIOS.

From there you should dual boot normally.

Hope that helps.

Good luck.

Pap 11-13-2012 03:16 PM

Unfortunately this won't help. Network boot was already the last one in the boot sequence list (can't be disabled), but the fact is computer fails to see that hard disk (which is first one in the boot sequence) has Grub installed and thus goes to the second device (which is the disk drive), then to the third (which is usb ports), then finally tries to boot via network.

In the meantime, trying several suggestions found on the Internet I somehow made Windows partiotion not bootable at all (SuperGrubDisk still helps me to get the Grub menu and start Linux from there, but I can't boot Windows anymore, although the partition was not affected, just the MBR.

I seem to have 2 options now: either try to fix the MBR, or to just forget about Windows and reinstall Linux using the whole disk. So far all tries to fix the MBR failed.

JaseP 11-13-2012 03:23 PM

There may be a second hot-key, like F12, to get to the boot menu, separate from the full BIOS,... Try to access that and change the boot order there. Plus, many BIOSes have the PXE boot options in two places,... Boot menu and Advanced chipset. You may have to go to the Advanced Chipset setting to change it to deactivated.

PS: Pretty sure that the Fujitsu Lifebook AH531 uses GPT not MBR,... So, maybe another option, like Grub-efi?!?! (I'd personally opt for wiping Windows, but that's just me)

jefro 11-14-2012 02:30 PM

I like the idea of trying hot key to directly select the drive as both above suggested to some degree or directly.

Look at bios just to check what it does say for hard drive, could be that some bootable usb device is above the real hard drive.

Also it might be that this boot loader has been placed too high in the drive.

Pap 11-14-2012 04:21 PM

I think I said it many times: The hard disk is the first option in the boot sequence. Anyway, I finally opted to just wipe out the disk -therefore, also wiped the (pre-installed) Windows 7 partition- and use the whole disk for installing Debian GNU/Linux 64 bit. I still don't know what the problem was, it was probably what JaseP suggested: somehow, Debian installed Grub instead of Grub-efi.

I can't mark this thread as "Solved" because it is not. Or maybe it *is* solved the best way: by deleting the Windows partition (which wouldn't be used much anyway) and forget about it once and for all. ;)

jefro 11-15-2012 03:14 PM

There is generally two place to look for boot order. One is a selection that lists cd, usb, hard drive, pxe. The other is a place where one can check the order of each device. So, you'd need to check that under the hard drive menu, the correct drive is listed.

Thanks for updating us.

thorkelljarl 11-16-2012 05:55 AM

I think that this is your problem...

If you changed the size or disposition of the Windows 7 partition table using a tool other than the Windows 7 partitioner, you may well not get Windows to boot. The Windows 7 boot loader refers to its partition information and the partitions it finds and expects them to concur in order to boot.

If that's all that's been done, Neosmart has come to help. Try following their guide. Note that you can download a Windows 7 Recovery Disk if you need one.

However, if your Windows 7 installation booted from its own boot partition and you have removed that partition, you may have to install or edit Grub2 or use something like PLOP to boot Windows. Otherwise, restore the Windows 7 partitions as they were and conduct a Windows 7 restoration or, as a last resort, re-install Windows 7.

Were it I, I would start looking at what I have at the moment by opening the Windows 7 Disk Manager and looking at the partition table. You might also take a look with a live -cd of PartedMagic.

thorkelljarl 11-16-2012 06:22 AM


You installed Debian without a problem. Does this machine have a EFI BIOS and did Debian install its bootloader correctly?

Pap 11-16-2012 11:53 AM

To be honest, I had no idea about EFI BIOS, as I didn't install Linux the last years (the benefits of running Debian: you install it once and you update it for years, no need to reinstall it ever).

Anyway, that laptop came with Windows 7 pre-installed and, for some reason, there was a very small partition containing Windows "loader" while the actual Windows partition was after that small one. Grub was installed in the MBR, but for some reason the computer could not boot from hard disk. I had to boot from a SuperGrubDisk CD and access hard disk's Grub from there, then I could boot on Windows or Linux without a problem. But since it was annoying, and being unable to find out how to fix it, I just wiped out the disk and installed Debian. Now it works as expected, and I got rid of pre-installed Windows, which I would never use anyway. :-D

However, if someone would want to keep the Windows partition, I guess he/she would have to cope with that strange "loader" partition.

thorkelljarl 11-16-2012 05:04 PM

That's right...

Windows 7 laptops I have encountered in the recent past have what is in effect a boot/bootloader partition at the beginning of the HDD, in addition to a partition for Windows itself, and often a recovery partition, plus a partition for any data files under Windows. There may be no free partition for linux, and unless you can combine the two Windows partitions as I could on a Samsung laptop, you loose the recovery partition.

What can be done if you have a Windows 7 installation DVD is to use it to format and install windows more as you like it. The Internet has many guides and howtos.

The point is, if you might want or need Windows 7 again at some point, you can use a Windows 7 installation DVD to install it at any time, and to reinstall it thereafter if need be. Your Windows 7 OEM license is valid for your system regardless of how it is installed. Just match the Windows 7 DVD version to the OEM license.

Pap 11-16-2012 06:01 PM

There was indeed a small boot partition, a partition for Windows, a recovery partition and a data partition, probably for the applications manufacturer added to Windows. However, my problem was not that; most of those partitions were "logical", not primary. So I could shrink the Windows partition and make space for another one for Debian (as I did). The problem was that system could not boot after that and I needed SuperGRUB2Disk to have access to Grub and boot any of the OSes installed from there. I suspect that was because Grub was installed in that small boot partition, which somehow made the system think the disk is not bootable, although I can't think why.

I even created a Windows "recovery" disk trying to "fix" the boot sector (which, according to the usual Microsoft's monopoly terminology means "make the system boot on Windows only"); even that didn't work. I also tried a special CD that is supposed to fix the boot sector; didn't work. Several other solutions I found on the internet, such as MBRFix and others didn't work as well. After all that, I just decided I was wasting my time, trying to save a Windows partition I doubt I would use once a year, so I just got rid of it and used the whole disk for Linux.

I repeat, however, that the problem is not solved, and if someone needs pre-installed Windows to be there, he/she will need to find out how to deal with that strange boot partition.

All times are GMT -5. The time now is 05:15 AM.