LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   BCM V.92 56K modem on RH9 (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/bcm-v-92-56k-modem-on-rh9-99655/)

pqb 10-02-2003 10:23 PM

BCM V.92 56K modem on RH9
 
Hi,

I am a newbie and have recently installed RH9 on an Inspiron 5150. I can't seem to get my modem to work.

It is a BCM V.92 56K modem and I have rpm-ed the driver, rebuilt the rpm for my kernel (my kernel version is 2.4.20-8) It creates BCMSM.o but insmod is giving errors and when I type "service BCMSM start" the init script in /etc/rc.d/init.d/BCMSM is showing mknod errors.

I am totally confused as to what to do. Please help !!!


pqb

:newbie:

al_chemyst 11-07-2003 02:12 PM

BCM v.92
 
I tried linman's method a couple days ago and go the same error.

He basically used an old RH driver to update MDK 9.1 kernel. I have MDK 9.2
kernel 2.4.22-10mdk, and think linman's method should work. It was worth
using his method to learn some Linux procedures.

Hopefully someone will know what to do with the mknod error. Looks like
mknod might be creating a buffer space for modem i/o. I posted my ouput
listing in linman's thread. (I also got a config error)

Regards,
Al :study:

frankieh 12-10-2003 08:50 AM

No luck but more detail.
 
Hi guys,

I have had the same problem as well, mandrake 9.2..

It appears from reading the BCMSM init script, that it looks in /proc/devices for the major number for mknod. On my mdk9.2 machine, I see no reference to the modem at all, (according to the script it looks for something like BCMSM_CONFIG ).

The result is that mknod doesn't know the major device number and it gives that error messasge.

Can someone with 9.1 or a RH that works with the driver post their results from:
cat /proc/devices ???

I even installed GCC 3.2.2 in the tmp dir, and compiled the driver from scratch, ended up in the same place.. so now I'm stuck for ideas.


rgds

Franki

JustMe5551212 12-30-2003 12:47 PM

I've got the same problem. Tried Linman's method as well as one listed in the same driver that I got from Dell's site. It seems to create the RPM fine, but when trying to start the modem, I get the 'mknod' error.

Just wanted to give the thread a bump and say I'm stuck too :(

lvgandhi 02-23-2004 12:59 AM

I also have mknod problem. But linman has written it is working in mandrake linux 9.1 but for v90 modem. I have two doubts. one whether he was using devfs or not. If devfs is used nodes are made, I think, on boot. No permanant device is made by mknod. May be this is source for conflict. If any body has already any workaround for mknod error of Mandrake 9.2, kindly mail me offlist to lvgandhi@yahoo.com. I have posted a while ago asking linman through the list as his email id is not available regarding mknod error. but it has not got his attention I think.

NguyenAnhHoang 04-24-2004 12:00 PM

Hi Everyone,

I went through the script file and noticed the problem: It was the major variable in the line mknod /dev/BCMSM c $major $minor. The variable major returns NULL, so mknod sees only 3 variable; it has to have 4. The major variable come from the result from egrep of /proc/devices file. I posted this message to another topic and requested anyone who has succeed install this modem from Mandrake 9.1 copy and paste the /proc/devices so I can analyze the problem. However, I have not gotten any response.


All times are GMT -5. The time now is 02:13 PM.