-   Linux - Laptop and Netbook (
-   -   Backtrack 5 wireless problem (

kempster 01-18-2013 08:56 PM

Backtrack 5 wireless problem
I have just installed backtrack 5 off my usb on to my netbook. I connected to my Ethernet cable and internet worked but when I tried to connect to wifi on wicd it came up with cannot connect to Wicd's dbus interface. I fixed that but it still cant find any wifi networks. Please help :D

frankbell 01-18-2013 10:16 PM

This post might help. It includes information on how to identify your wireless chipset, which is the first step to solving this problem. I'm linking to it because I'm too lazy to recreate the relevant bits.

It would help also to know the make/model of your netbook. There may persons here with experience with that particular device.

kempster 01-21-2013 12:23 AM

Thanks for the quick reply I really appreciate it. this has helped me alot. :cool:

I also found that my network card is a realtek semiconductor if that helps.

If I could please have a tutorial on how to install its drivers I would be extremely greatful. :)

TobiSGD 01-21-2013 07:22 AM


Originally Posted by kempster (Post 4874434)
I also found that my network card is a realtek semiconductor if that helps.

Actually, no, that doesn't help. This is basically the same as coming to a car forum and saying: My card is a Ford, how do I repair the transmission?
We need to know the specific model of the chip, otherwise we can't help.

LT83 01-24-2013 08:49 PM

wicd cant find any wireless networks
Hello all. Not trying to hijack this thread, but i too am having difficulty with WICD not finding any wireless networks. Ran sudo ifconfig -a ; sudo ifconfig wlan0 up; iwconfig wlan0 essid Eagle1; iwlist wlan0 scan essid Eagle1; and so on. All indications thru terminal window reflected a wireless signal being detected by my laptop, but WICD wasn't finding any wireless. My ssid is not broadcasted, but WICD allows you to 'find a hidden network'. Entering my ssid info, wicd still found nothing.

Reviewing other threads i saw that i could purge WICD thru the apt-get purge wicd* ; but when i attempted to do an apt-get install wicd, no luck. Looking at another post, i saw reference to synaptic package mgr. I found the wicd pkg, but of course i couldn't install because--I HAVE NO INTERNET CONNECTION. Yes, it was a bonehead moment.

I restarted my box and ethernet connection found. I used synaptic package mgr to install wicd. Still no wireless.

When i do an IWLIST SCAN i see my router with it's hidden beacon: ESSID: "\x00\x00\x00"
I then executed SUDO IWCONFIG WLAN0 SCAN ESSID EAGLE1, and i see my ssid and associated parameters: encryption key on, bit rates, freq, etc.
But when i go to the wicd n/w mgr, it tells me there no wireless networks found.

I ran DMESG |GREP WLAN0 and saw the following: ADDRCONF (NETDEV_UP), wlan0: link is not ready. Then DMESG |GREP IWL3945, and got this: detected intel wireless wifi link 3945abg. Just before submitting post, i saw the "Check if already posted" button. Reviewing some other threads, i ran LSHW -C NETWORK and saw my PRO/Wireless 3945G info, then i ran RFKILL LIST ALL and saw nothing is blocked.

Read similar posts in another forum and ran several commands:
cat /etc/network/interfaces (everything ok)
lspci -nn (saw n/w controller info related to Pro/Wireless 3945ABG)
sudo /etc/init.d/networking restart (still no change, wicd reflects "no wireless networks found."
cat /var/log/debug |grep wlan (showed previous dates of when wlan was up, attached, authenticated; however the last entries reflected "disabling the bridge, down, detached.")
cat /var/log/messages |grep wlan (showed multiple lines of "wlan0: link is not ready")

I'm at a loss and need help? I'm using Backtrack 5 (Ubunto 10.04).

frankbell 01-24-2013 09:31 PM

LT83, the link below is primarily about Broadcom, but it will identify your wireless chipset, which is the first step to shooting this trouble.

LT83 01-24-2013 09:42 PM

I read the info from that link prior to submitting post, and ran the lspci -nn command, which is why i identified the Pro/Wireless 3945ABG. I'm not sure what else i should be looking for with that command other than fastethernet info. Plz elaborate, i'm a relative newbie to this stuff.

frankbell 01-25-2013 08:32 PM

A search for "Pro/Wireless 3945ABG linux" turned up this:

Maybe it will help.

LT83 01-27-2013 02:10 PM


Originally Posted by frankbell (Post 4877698)
A search for "Pro/Wireless 3945ABG linux" turned up this:

Maybe it will help.

I looked at the info from the link, but I dont think I need it because when I run the following cmd, I get this:
root@bt:~# lsmod |grep iwl3945
iwl3945 72170 0
iwl_legacy 65230 1 iwl3945
mac80211 410313 2 iwl3945,iwl_legacy
cfg80211 160399 3 iwl3945,iwl_legacy,mac80211

So I dont see how the above link can help. Can someone provide some instruction on how to connect wirelessly thru cmd line?

All times are GMT -5. The time now is 02:56 PM.