-   Linux - Laptop and Netbook (
-   -   Backlight fails frequently on boot with custom kernel (

tm512 08-05-2011 03:12 PM

Backlight fails frequently on boot with custom kernel
Hi, first post here. :)

I have been having issues with my netbook's backlight on a 3.0 kernel I have compiled. Every few boots, the screen will turn fullbright, as the kernel prints out:


ACPI Error: Current brightness invalid (20110413/video-377)
Any attempts to change the brightness with the fn keys afterwards causes this to be printed out:


ACPI: Failed to switch the brightness
Rarely (I've only gotten this once) I can change the brightness afterwards, even though it still prints out the errors. When I look in /sys/class/backlight/ when the errors get thrown, it is completely empty, otherwise it has a folder named acpi_video0.

This happens both with a .config based on the (working) Arch Linux kernel I am running now, and with a "make defconfig" that I tweaked to include the drivers that I want. I'm a bit confused as to where to start looking for a solution since the majority of the time it does work properly. It's just the times when the screen gets forced to an eye-searing brightness that I have problems.

If anyone is able to help, I would be most appreciative. Thanks in advance. :)

H_TeXMeX_H 08-07-2011 04:18 AM

I think more info might be needed, for example post the .config or the parts in the graphics section, and what brand of netbook is this ?

tm512 08-07-2011 01:58 PM

Sure, here's the kernel .config file, not sure exactly which parts to post so I'm just doing the whole thing:

Here's a paste of dmesg when it fails to get the backlight working:

The netbook is an Acer Aspire One AO532h.

EDDY1 08-07-2011 06:29 PM

Maybe this will help

Ialso noticed you have settings for dual-head not sure if it's relevant

tm512 08-07-2011 08:12 PM


Originally Posted by EDDY1 (Post 4436289)

I'd prefer to avoid hacks like that since the backlight works perfectly on Arch Linux supplied kernels.


Originally Posted by EDDY1 (Post 4436289)
Ialso noticed you have settings for dual-head not sure if it's relevant

You mean "ACPI: Video Device [OVGA] (multi-head: yes rom: no post: no)"? It's the same on the working kernel.

Oh, and I believe that I forgot to mention that the previous kernel I had compiled myself (2.6.35) had very similar issues. I can't say exactly since it was a while ago and I didn't pay too much attention to it.

Thanks for your time thus far. :)

EDDY1 08-08-2011 01:27 AM

Are you just compiling for the fun of it or for a specific reason?
Also the suggested info was not a hack if you read it it gives you control of the adjustments up & down, I elieve that you looked at the first option 50% not at the full configuration file, have you checked your settings.

H_TeXMeX_H 08-08-2011 08:42 AM


Try adding "acpi_backlight=vendor" to the append line in '/etc/lilo.conf', then run 'lilo' as root.

tm512 08-08-2011 05:00 PM

I am doing this just for "fun". I also wanted to set my CPU type to Intel Atom and take advantage of any optimization that did.

The backlight fix you linked to was, in fact, a hack. It was a workaround fix for something that sometimes works on this kernel, and that always works on Arch Linux supplied kernels. It addresses the symptoms, not the cause. Sorry, but that is no solution for me.

"acpi_backlight=vendor" does not help, I had tried it prior to posting here. If I recall correctly, it just made the backlight go fullbright 100% of boots. Furthermore, the launchpad link is old, and it does not accurately portray my problem.

Arch Linux's newly released Linux 3.0 does not have this issue.

I am now going to try compiling with this currently working config to see if I still run into problems. If I do, then I will look and see what patches Arch Linux might have applied and see if any of them fix it.

Thanks so far. :)

tm512 08-08-2011 10:01 PM

I have just compiled Linux 3.0.1 from source using an unmodified Arch Linux config. It does not appear to have the backlight issue.

At this point, I am confused as to what I did that broke it. It's not like there's an option in the setup named "Make backlight work on only some boots". :( Common sense says that the backlight would either work 100% or 0% of the time, depending on whether the driver was installed, right?

Here's the good config.

EDDY1 08-08-2011 10:35 PM

You obviously used the old configuration file from original install.

I just did a apt upgrade on vbox & it worked well. I might try it on my wheezy hdd for my laptop, which was having network problems so I switched back to hdd with Squeeze on it.

H_TeXMeX_H 08-09-2011 09:17 AM

Originally it was a bug in the kernel. I think they may have fixed it in the most recent release.

tm512 08-10-2011 01:56 AM


Originally Posted by EDDY1 (Post 4437359)
You obviously used the old configuration file from original install.

Yes, that was the point. I had wanted to see if the problem persisted if I used the same config as the working kernel. I'm not sure what you're trying to say here.


Originally Posted by H_TeXMeX_H
Originally it was a bug in the kernel. I think they may have fixed it in the most recent release.

Not sure how that would be quite possible, since I've never had this issue on my netbook with Arch Linux kernels since I switched it to Linux (2.6.34).

When I get the time, I will try out a customized config again, and if the problem seems to be gone, I'll mark this as resolved.

tm512 08-10-2011 08:02 PM

I customized my 3.0.1 config, recompiled, and am no longer able to reproduce this issue.

Marking it as solved.

EDDY1 08-11-2011 12:42 AM

Nice to know that you have solved your issue, I recently upgraded from wheezy 2.6.38 to 3.0 on my laptop & am working thru my issues, laptop mode wasn't working also Gtk pixbuff, partially fixed, had to edit /usr/sbin/laptop_mode for unhandled kernel version errors. I have a few more issues but they'll soon be resolved. My virtual machine works fine though.

Congrats on your success!

All times are GMT -5. The time now is 03:21 AM.