LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   ATI fglrx driver problems on a Sony Vaio (but can be a common problem...) (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/ati-fglrx-driver-problems-on-a-sony-vaio-but-can-be-a-common-problem-214905/)

MachineH 08-08-2004 02:31 AM

ATI fglrx driver problems on a Sony Vaio (but can be a common problem...)
 
Hi everybody.

I have a Sony Vaio PCG-K115S, with a ATI Radeon Mobility 9200 inside.
I use slackware 10.0 with a 2.6.7 kernel (the original one).

That's the problem: if I use the fglrx driver (the official ATI driver), X.org doesn't. work. Simply, when i write startx, the screen goes black, and nothing happens. I've tried Ctrl+Alt+F1/F2/.../Del but nothing happens too, and I have to power off the laptop.

Radeon DRI drivers (icluded in Xorg) works fine, instead.

I've tried everything: switch options on or off (like UseInternalAGP, FastWrites...), adding vga=792 at boot, modifing the hex code of fglrx_drv.o (!!) as suggested in a website about an asus laptop...
I have no idea left...
:( :( :(
Please help!

Some details:
- sometimes (on some configuration) the Xorg.log doesn't report anything, sometimes only a laconic:
"Caught signal 11"
No errors regarding fglrx.
- Module loads fine, as the agpgart one do.
- /etc/log/messages doesn't report anything interesting.

Thanks in advance
Paolo


All times are GMT -5. The time now is 12:48 PM.