-   Linux - Laptop and Netbook (
-   -   Atheros card not working in opensuse 10.2 Acer Aspire 5570Z (

chief_officer 06-07-2007 10:39 AM

Atheros card not working in opensuse 10.2 Acer Aspire 5570Z

First, this is a cross-post. The original is in I could not solve my problem there, so I am just seeking LQ's wisdom.

Not to take you to the site above, I will post everything here:

I have an Acer Aspire 5570Z notebook running openSuSE 10.2. I have added to my installation sources and installed the 0.9.3-6.1 version.

Edit: The chipset used is AR5BXB63.


03:00.0 Ethernet controller: Atheros Communications, Inc. Unknown device 001c (rev 01)

03:00.0 Ethernet controller: Atheros Communications, Inc. Unknown device 001c
(rev 01)
Subsystem: AMBIT Microsystem Corp. Unknown Device 0428
Flags: fast devsel, IRQ 11
Memory at 52100000 (64-bit non-prefetchable) [disabled] [size=64K]
Capabilities: <access denied>

lsmod | grep ath

ath_pci                96544  0
wlan                  197956  1 ath_pci
ath_hal              195792  1 ath_pci

dmesg | grep ath

ath_hal: module license 'Proprietary' taints kernel.
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
ath_pci: (0.9.3)

dmesg | grep wifi

wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
wifi%d: unable to attach hardware: 'Hardware didn't respond as expected' (HAL status 3)


eth0      Link encap:Ethernet  HWaddr 00:16:36:F9:2F:F5 
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::216:36ff:fef9:2ff5/64 Scope:Link
          RX packets:684 errors:0 dropped:0 overruns:0 frame:0
          TX packets:766 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:454272 (443.6 Kb)  TX bytes:112995 (110.3 Kb)

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:30 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1956 (1.9 Kb)  TX bytes:1956 (1.9 Kb)


lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.


lo        no private ioctls.

eth0      no private ioctls.

sit0      no private ioctls.

I have also tried -despite it is told "unnecessary"


wlanconfig ath0 create wlandev wifi0 wlanmode sta
with an error that


wlanconfig: ioctl: No such device
Meantime, YaST sees this card in Network Cards as AMBIT Microsystem WLAN Controller and offers me configuration options. However, in KNetworkManager there is no clue about wireless driver.

I have ran into a solution in


The very next thing was to try to make the wireless chip work. This laptop came with a Atheros AR5005G wireless card inside. Using a Knoppix Live CD, I already knew it worked fine using the Madwifi drivers. Using my Ethernet port, I added the Livna repository to my system and installed the drivers from there, following these instructions. But they didn't work, at first. I read around, and eventually I saw somewhere that the modules have to be removed in a certain order (so as to free up the reference counts in the right order) and then probed in a specific order (no idea why). The order to remove: ath_pci, ath_hal, ath_rate_sample, ath_hal, wlan. Don't ask me why this order, or why one module is repeated, or anything. I just know this is what I did. Then I loaded ath_pci, and the rest just sort of snapped into place, and it worked, and I was able to configure the device. On subsequent boots, the device just worked without any extra effort required.
This did not work either.

It seems to me that Acer has put some lock on the hardware to make it proprietary. Whilst I was googling, I saw that people could not get their Atheros card to work using ndiswrapper using drivers from the manufacturer. In Acer's site, in Support & Downloads section, the drivers for the Atheros card is a zip file, which contains some "setup.exe".

The funny thing is that the notebook came with Linpus Linux installed (ok, they didn't even installed any Desktop Environment,you can just boot to our friendly black & white command prompt). However, it has some hardware which is not supported by Linux.

I have Acer service center in UK and received a reply that they do not ship Acer 5570 with Linux installed and thus they are not able to help. Germany refused to pass me to their service rep. In my country -Turkey-, the Acer guys are clueless about Linux. E-mail on Middle East support (UAE) bounces back -no such address-. I am afraid to call France, Belgium, Switzerland, Italy, Spain because I can not speak French, Italian nor Spanish. I could not reach USA's hotline (some kinda International telephone connection issue) and also Taiwan (time difference, I can not catch them while they are at the office).

It seems to me that I am really hopeless about this. If I can not get my wireless card working, I think I will go out to the Acer Service Center and replace my Atheros with Intel 3945 Pro or Intel 2200.

If you have any idea about getting this card to work, I am happy to try it.

Thanks to everyone for reading so far.


PS 1: Please do not tell me to install wpa_supplicant, acer_acpi packages, they are already installed.

PS 2: I did everything stated in

PS 3: There is not a single webpage that returned in my search results with keywords: atheros, acer, 5570, linux.

PS 4: I have read everything in

PS 5: I have joined and asked my questions in #madwifi on IRC.

t0bias 06-08-2007 03:02 AM

i neither have an acer, nor an atheros-wlan-card, but you could try to use ndiswrapper + the original windows drivers to get this card working.


lithul 06-25-2007 07:01 PM

hope this helps Im a Debian User
I read through your article on the wifi drivers, i have the same laptop and i have the wireless working. I had to install the headers for the kernel image i am running and then I had to install the madwifi, it installed to /usr/src/modules/madwifi. As root entered that directory then make, make install. it complained about some build directory missing, i used ln -s /usr/src/linux-headers-kernelversion/ /lib/modules/kernelversion/build, then i had to do make and make install again, After this ath_pci.ko module became available. I used modprobe to load that module. ifconfig showed wifi0 and ath0 added. You can then use ath_key to put in your wireless keys if needed etc.
I am using this laptop and wifi card right now :) I did try ndiswrapper before this but had no luck.

chief_officer 07-02-2007 12:00 PM


I tried what you said to no avail.

As you said, I did the following:

ln -s /usr/src/ /lib/modules/
But I suspected that ath_pci.ko is not located in /lib/modules/kernelversion/build, I searched for ath_pci and it was found in


But when I tried


ln -s /usr/src/ /lib/modules/
But the net directory is already there.

I checked what is inside the /lib/modules/ directory contains, I found:


ath_hal.ko            ath_rate_onoe.ko    wlan.ko          wlan_wep.ko
ath_pci.ko            ath_rate_sample.ko  wlan_scan_ap.ko  wlan_xauth.ko
ath_rate_amrr.ko      wlan_acl.ko        wlan_scan_sta.ko
ath_rate_minstrel.ko  wlan_ccmp.ko        wlan_tkip.ko

With my tiny knowledge, it seems that I have to make some link to this directory?!?

It looks to me that the drivers are in place, modprobe returns nothing, lsmod lists the modules as loaded but somehow the card is not recognized by the system.

What must I do?

lithul 07-03-2007 04:38 AM

The fact that you can find ath_pci.ko on the system makes it easier than when I did it cause i had to build that module, you have it.
K, so i am assuming if you do lsmod you get ath_hal blah blah ath_pci in that list somewhere which would mean the module is loaded. Which is good, next check ifconfig (as root login) it should show ath0 and wifi0 if not then type
ifconfig wifi0 up
ifconfig ath0 up
to see if they are up. let me know cause if we can get that far the rest is fairly easy :)
I used network-admin in X System tools to enable the ath0 interface and set it up after that with the key etc, that was with debian Etch though you will have to find equivalent in your distro

chief_officer 07-03-2007 12:03 PM

lithul, thank you very much for your kind assistance, but things are not working :(

ath_pci, ath_hal, ath_whatever are shown in the lsmod output.

ifconfig itself shows only eth0 and lo interfaces.


$ ifconfig wifi0 up
wifi: no such interface: device not found


$ ifconfig ath0 up
ath0: no such interface: device not found

I know I am somewhere close, but don't know how to fix this thing!

lithul 07-04-2007 07:38 AM

Ya, sounds like you are close, can't think of why the module is loaded but not coming up in ifconfig. If I think of anything else will let you know, sorry couldn't help more :(

chief_officer 07-05-2007 11:46 AM

Solution: Take your notebook to Acer and complain. Ask about replacing your wifi card with Intel 3945 because it is not supported by the preinstalled operating system.

Result: Free of charge replacement with "...changed for customer satisfaction..." remark.

Acer has done a very good job I believe.

chief_officer 07-05-2007 11:46 AM

And with another post, my THANK YOU's for lithul.

hypodermia 07-14-2007 07:24 PM

okay, so my blog was linked in the first post. (thanks for posting to that page, by the way, rather than just the relevant entry, so everybody can read that personal stuff AND the technical stuff. right.)

so anyways, in the time since then and now, i figured out that this particular acer laptop has a hardware switch on the front to control the wireless. in linux, the light doesn't seem to do its job (indicating on/off states, or searching, or disconnected), but the switch actually DOES work. the key to making this work when you modprobe is making sure the switch has the hardware turned ON. it's finicky, but it is the key to making this work, i think.

RHarelson 07-15-2007 10:42 AM

I have the same Atheros mini-PCI card (AR5BXB63) in an Acer Aspire 3680. This notebook also has a hard switch that toggles the card on and off. I've gone through same churn with identical results posted previously in this thread. I was attempting to use this card with Puppy 2.6.1. I have not been able to Google a single thread where the user could make this card/chipset work in any Linux distro through the usual methodology. Incidental reports of other versions of this card with other chipsets possibly do work. I wonder, has anyone attempted to drop this card into another notebook? Every reference that I have found regarding this problem centers around an Acer notebook. This might possibly give some indication as to whether it is the card itself or the associated hardware.

RHarelson 07-15-2007 11:04 AM

Argh, correction in order; it's is not a standard mini-pci card. Dropping it into another notebook is not going to be that easy. Sorry.

OK, it's a standard MINI card and not all that rare of a socket but most older wireless notebooks are more likely to be mini-pci. I see that both my older Fujitsu and Dell are mini-pci so I can't try a swap, but just a thought.

beatupbilly 07-15-2007 01:04 PM

This card works in 10.3
I have this same card and it works in:

OpenSuse 10.3
Ubuntu 7.04
Xandros 4.1 OCE
Linux Mint

and a handful of others I can't think of off of the top of my head. I'm sure the last thing you want to do is download another set of install discs and start over but I had no success with the Atheros wireless adapter in 10.2, Fedora Core or Red Hat. Allthough I did get it working in Scientific Linux (Red Hat based Distro). I think my favorite is Linux Mint. It has all the cool 3d Beryl stuff and themes and supports just about all the hardware I have thrown at it :)

RHarelson 07-15-2007 05:03 PM

Hmmmm, good to know; and you said it is an AR5BXB63? I tried it with Ubuntu 7.4 Friday night without success although I didn't spend a whole lot of time with it. Did you use the bundled ath_pci driver or did you tweak it? I got a Netgear WG511T that works great using the ath_pci driver in Ubuntu, Puppy and Freespire but no joy from the AR5BXB63, no matter how I jiggle it. Maybe it's like Hypodermia surmised and the hard switch is the problem and not necessarily due to it being switched off.

I never tried Mint, sounds interesting, I'll check it out. Thanks.

Andrenl 07-18-2007 09:01 PM

I have An Acer 5100-3019 it comes with the Atheros AR5BXB63, I`ve alredy tried everthing, this card is not compatible with linux yet. In madWifi it returns HAL error 13, or 3 (not suported/no respond has expected), with madwifi-openhal an ath0 interface shows up but don't work, there are very little information on google about this device, I still not discovered what chipset it uses, for expample.

In windows the Atheros driver show it like "AR5007EG" - (AR2425)

In a mail-list Sam Leffler - the HAL supplier, anwsered my question abouti this device saing
"The support it`s comming, Hopefully soon".

The only thing that we can do is, wait or use Ndiswrapper =/

All times are GMT -5. The time now is 05:55 PM.