-   Linux - Laptop and Netbook (
-   -   Asus K53E Debian Install: No ethernet card detected (

poopypenguin 01-05-2013 05:07 PM

Asus K53E Debian Install: No ethernet card detected
1 Attachment(s)

I'm kind of a newb but please help.

My PC uses Atheros AR8151 PCI-E Gigabit Ethernet Controller and Atheros AR9485 Wireless Network Adapter. While installing 32-bit Debian (on my 64-bit machine), it said that no ethernet card was detected. There was a list (of, I'm guessing, ethernet cards) and I tried selecting each one but naturally none of them worked. So finally I chose "no ethernet card" and continued with the installation.

Afterward, I wasn't able to connect to the internet wirelessly. So I tried plugging in my ethernet cable, but even then it didn't work.

So then I reinstalled, this time with a dual boot of Vista and Ubuntu (10.10, I think), both 32-bit. I downloaded a driver for wired internet access for Vista, so now my Vista internet works (not wirelessly though), but Ubuntu still can't connect, even with an ethernet cable. I've searched Atheros' official website, but there doesn't seem to be any Linux drivers for the hardware I have.

I tried installing Debian Squeeze (64-bit), but it still comes up with the "no ethernet card detected" message. I've also tried putting some firmware onto my USB, but the installer doesn't seem to detect it.

Sorry for the long explanation but hopefully it'll provide some clues? (>_<) Please help me get my internet working on Debian.

EDIT: I've attached a screenshot of the parts of Device Manager that I think might be relevant.

TobiSGD 01-07-2013 06:47 PM

Debian 6 and Ubuntu 10.10 (which is unsupported anyways) may simply be to old for that hardware, Try it with something newer, like Debian Testing or Ubuntu 12.10.

The hardware manager screenshot you provided also indicates that you lack drivers for your Windows, download them from the ASUS site.

poopypenguin 01-26-2013 01:46 PM

Thanks, it works with Debian Testing.

All times are GMT -5. The time now is 11:21 PM.