-   Linux - Laptop and Netbook (
-   -   asus g55vw dual booting linux 64 bit and windows 7 home premium 64 bit (

momok 05-16-2012 10:26 PM

asus g55vw dual booting linux 64 bit and windows 7 home premium 64 bit
Dear friends,
i've been tried several times to install linux (bt5 r2) 64 bit to make it dual booting with my windows 7 home premium 64 bit. And windows 7 have been pre-installed in my asus g55vw laptop (republic of gamers - i7 3rd gen gc nvidia geforce gtx 660m).
at first the installation seems to be successful but after i reboot it there is no grub menu and it boot directly into windows.
i have tried several techniques to repair my grub but still failed.

what i think might be the problem is maybe it come from "windows boot manager" that i saw in bios and it appeared as a first boot option

usually in older and other laptop what i saw it should be the harddisk.
what should i do?i really hope that windows doesnt control my boot manager such as using bcedit.. is there any solutions so grub can take control of the booting options?(sorry for my bad english)

i installed by using live usb pendrive not by using cd/dvd
this is my grub.cfg

# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
set default="0"
if [ ${prev_saved_entry} ]; then
set saved_entry=${prev_saved_entry}
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true

function savedefault {
if [ -z ${boot_once} ]; then
save_env saved_entry

function recordfail {
set recordfail=1
if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
insmod ext2
set root='(hd0,6)'
search --no-floppy --fs-uuid --set 421262e9-a020-4b66-9bc3-94404bd2ad6b
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=1024x768
set gfxpayload=keep
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
insmod ext2
set root='(hd0,6)'
search --no-floppy --fs-uuid --set 421262e9-a020-4b66-9bc3-94404bd2ad6b
set locale_dir=($root)/boot/grub/locale
set lang=en
insmod gettext
if [ ${recordfail} = 1 ]; then
set timeout=-1
set timeout=10
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 3.2.6' --class ubuntu --class gnu-linux --class gnu --class os {
insmod ext2
set root='(hd0,6)'
search --no-floppy --fs-uuid --set 421262e9-a020-4b66-9bc3-94404bd2ad6b
linux /boot/vmlinuz-3.2.6 root=UUID=421262e9-a020-4b66-9bc3-94404bd2ad6b ro text splash vga=791
initrd /boot/initrd.img-3.2.6
menuentry 'Ubuntu, with Linux 3.2.6 (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
insmod ext2
set root='(hd0,6)'
search --no-floppy --fs-uuid --set 421262e9-a020-4b66-9bc3-94404bd2ad6b
echo 'Loading Linux 3.2.6 ...'
linux /boot/vmlinuz-3.2.6 root=UUID=421262e9-a020-4b66-9bc3-94404bd2ad6b ro single
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-3.2.6
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod ext2
set root='(hd0,6)'
search --no-floppy --fs-uuid --set 421262e9-a020-4b66-9bc3-94404bd2ad6b
linux16 /boot/memtest86+.bin
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod ext2
set root='(hd0,6)'
search --no-floppy --fs-uuid --set 421262e9-a020-4b66-9bc3-94404bd2ad6b
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda3)" {
insmod ntfs
set root='(hd0,3)'
search --no-floppy --fs-uuid --set 62082D74082D47FD
chainloader +1
menuentry "Windows Vista (loader) (on /dev/sda5)" {
insmod ntfs
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 8E7233AF72339AC3
chainloader +1
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

and this is my fdisk -l
root@bt:~# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x2902cc6d

Device Boot Start End Blocks Id System
/dev/sda1 1 121602 976762583+ ee GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 16.0 GB, 16013852672 bytes
78 heads, 14 sectors/track, 28641 cylinders
Units = cylinders of 1092 * 512 = 559104 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdb1 * 8 28642 15634496 c W95 FAT32 (LBA)

/dev/sdb1 is because im using liveusb

ls -l /dev/sd*
root@bt:~# ls -l /dev/sd*
brw-rw---- 1 root disk 8, 0 2012-05-16 22:03 /dev/sda
brw-rw---- 1 root disk 8, 1 2012-05-18 06:04 /dev/sda1
brw-rw---- 1 root disk 8, 2 2012-05-18 06:04 /dev/sda2
brw-rw---- 1 root disk 8, 3 2012-05-18 06:04 /dev/sda3
brw-rw---- 1 root disk 8, 4 2012-05-18 06:04 /dev/sda4
brw-rw---- 1 root disk 8, 5 2012-05-18 06:04 /dev/sda5
brw-rw---- 1 root disk 8, 6 2012-05-18 06:04 /dev/sda6
brw-rw---- 1 root disk 8, 7 2012-05-18 06:04 /dev/sda7

my root directory is in /dev/sda5

and i've got this strange things that my linux partition appeared in mycomputer in windows as a drive "d" and being unrecognized.usually in older laptop it should not appeared unless i opened disk management

2nd update:

i guess this problem related to efi system partition? in my bios it has an option to delete this "windows boot manager".should i go for it? i think this person has a problem that is almost equal to mine
in my disk management in windows i saw this efi partition sitting in my hdd "healthly"... im almost "sick" about this efi.. if it didn't make me worries that it can harm my notebook i think i want to heavily kick it out :)

3rd update:

assumed solution is to reformat all my partition and just kick out the original windows 7 home premium and the "healthy baby" efi and the recovery partition. install windows back and linux bt lastly to make it dual boot.would this be ok?should i also delete the bios "windows boot manager p1"? i hope some guru will help to enlighten me and figure this out

4th update:

trying to figure it out on my own and of course by god help.
1.disable "windows boot manager in bios"
2.try to add hdd in bios but i just dont know how.its using "American megatrends utility - aptio utility"
3.try to repair grub by using live usb and doing some commands such as
mount /dev/sda5 /mnt
grub-install --root-directory=/mnt /dev/sda --force
4.try to boot using live usb back and use option booting my first hdd in the live usb
5.suddenly the grub appears (with the help of live usb boot into hdd option) and managed to login into the linux bt partition
6.try to figuring something - i think i must find the way to add boot from hdd in my bios instead of booting using "windows boot manager"

jefro 05-17-2012 03:51 PM

Did you see the part on the Backtrack web site where is said,

"BackTrack is a Linux-based penetration testing arsenal that aids security professionals in the ability to perform assessments in a purely native environment..."

Please consider a more newbie friendly disto.

momok 05-17-2012 09:15 PM

hi Jefro.. thanks for the answer.. although its half true, it won't stop me from learning trying to configuring this thing.
this one still have ubuntu in it, i have been with it since version 2 where it using lilo and i configured the lilo file manually (almost 3 days - i won't give up!) to make it dual boot, i know how to start x server at least :) the problem is not with backtrack but it is with this new laptop. please understand this

AxE_EfFeCt 06-06-2012 08:10 AM

It's been quite a while since I posted here (roughly 8 years I think). I also have one of these and I am trying to install Linux Mint 13. The problem is essentially exactly as the OP describes. I am looking at trying to chainload Grub from the Windows 7 boot manager (if that is possible at all). I'll keep this place updated if I manage to find a working solution using this method.

This post looks promising in this regerd (post #6)

momok 06-07-2012 01:06 AM

oh im really sorry.. i've have settled this problem 2nd day after my last post. i used liveusb of backtrack, then i installed gnuparted software in it.. then i reformat the partition using gnuparted but first you must tell gnuparted that you doesn't want to use gpt style of partition table, instead choose msdos and then format it as usual.. and wallaaaa.. i have settled it down.. my partition has 1 terabyte of size.. now im happy with my dual boot system :)

edited:did you have same laptop as mine?

AxE_EfFeCt 06-07-2012 12:23 PM

OK, good for you.

What I wanted was to install Linux Mint 13 without having to repartition the hard disk or having to make my Windows unusable. I also succeeded today by following the UEFI Boot Instructions for Ubuntu and then creating a EFI boot menu entry from the BIOS. (Having the utility of creating new EFI Boot entries directly from the ASUS G55V and G55VW BIOS is awesome).

And my laptop is slightly different from yours (Mine is a G55V). It came with a 1366x768 pixel display (with 3D but I didn't care much about 3D). So I opened it up first day (voiding my warranty but I am brave :P) and added 4gigs of RAM from a previous laptop to make it 16GB and replaced the LCD with a beautiful Full HD display from an old Dell Studio XPS 1645 I own.

All times are GMT -5. The time now is 06:16 PM.