-   Linux - Laptop and Netbook (
-   -   Asus Eee PC 1005ha Ubuntu Netbook Remix 9.10 Wifi issue (

mawkernewek 01-26-2010 12:20 PM

Asus Eee PC 1005ha Ubuntu Netbook Remix 9.10 Wifi issue
I have upgraded the kernel to 2.6.32 and installed the latest ath9k driver in an attempt to enable N support on the wireless (i.e. to enable the use of the 802.11n capability) to enable speeds above 54Mbps.

Now it only connects at 1Mbps, the output of iwconfig is as follows:

wlan0 IEEE 802.11bgn ESSID:
Mode:Managed Frequency:2.412 GHz Access Point:
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=51/70 Signal level=-59 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Any suggestions?

mawkernewek 01-26-2010 02:29 PM

I think I'm getting improved signal strength though, I am getting 36/70 in link quality in iwconfig whereas my desktop in the same room with a 805.11g card gets 13/100 and that's with an external antenna.

Why though does iwconfig report the speed at 1Mbps?

mawkernewek 01-26-2010 06:07 PM

I think the desktop is having problems with a weak signal.

In Windows, it successfully connects to the router at 54Mbps, however in OpenSUSE 11.2 it connects at 1Mbps

from lspci:

03:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)

I am using the rtl8180 kernel module

mawkernewek 01-26-2010 07:34 PM

I reconfigured the router to use WPA and WPA2 mixed, this seems to have been necessary to connect at the higher speeds.

Now the netbook gives Speed as "Unknown" I can't actually tell if it is achieving the N speeds because my desktop is only connecting at 1Mpbs at the moment.

mawkernewek 01-27-2010 02:41 AM

typing iwlist wlan0 scanning gives

the lines
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s

so it seems to me that for some reason the higher N speeds are not available.

mawkernewek 01-27-2010 06:04 PM

The desktop is still only getting around 1Mbps despite installing compat-wireless kernel modules and attempting to set the speed manuallly to 54Mbps with iwconfig wlan0 rate 54M

It duly reported the speed as 54Mbps but when an scp was tried from the netbook to desktop it acheived about 1Mbps

It is possible it is just a weak signal but Windows 7 reports it as "Fair" with 3 bars out of 5 whereas in Linux it is 13/100

mawkernewek 01-27-2010 06:33 PM

Having tried some experiments with aluminium foil here are the results:

Placing aluminium foil behind router results in increased signal strength on netbook. (reported as 50-60% instead of 40-50%)

In Windows on desktop no change was observed. However obscuring the signal path with aluminium foil results in signal dropping from 2-3 bars to one. (and speed dropping down to 1Mbps)

However in OpenSuSE 11.2 there was no change when this was done, it continued to report strength of 13% aluminium foil or no.

All times are GMT -5. The time now is 07:46 PM.