-   Linux - Laptop and Netbook (
-   -   Asus Eee: can't always resume from suspend (

Kropotkin 04-14-2012 11:43 AM

Asus Eee: can't always resume from suspend
Hi all,

I've installed Mint 12 on a new Asus Eee 1215B-SIV128M (AMD Fusion 64-bit) notebook computer, and I am having problems with suspend.

Suspend works two or three times, and then it fails. The laptop LEDs light up (the system starts running), but nothing happens; the screen stays dark. I have to power off, and usually have to unplug the power supply and remove the battery for a moment before the computer will boot normally. I don't see anything useful in the pm-suspend.log.

I have found a couple of threads on suspend/hibernate issues on the Mint forums, and Google has turned up some leads elsewhere, but I haven't found a solution. Any ideas on what might be going wrong with suspend on this netbook?

Current kernel is v3.0.0-17


rokytnji 04-15-2012 05:03 AM

I don't run Mint or own a Asus Eee 1215B. My EEEPC's are a 900 and 701SD. I run AntiX on mine with a 3.3.1 Kernel and

Not sure if this will help or not since I don't own you're unit.

Kropotkin 04-17-2012 03:42 PM

Thanks for the very helpful links. I am going to investigate the possibilities as soon as I can.

Today I installed the latest RC version of Linux Mint Debian Edition on this Asus. It is running a v3.2.0 kernel. I don't think this has solved the suspend problems; but I need to test things a bit more to be sure. I do think Cinnamon is going in a better direction than Gnome 3, so it is certainly an interesting adventure in terms of desktop environments.

Kropotkin 04-18-2012 06:28 AM

I didn't find a "C9" setting in the BIOS that was mentioned in the first link, but there was a "C6". A Google search indicates this is one of a series of CPU sleep states. I disabled it. I also installed the proprietary graphics driver, fglrx, for the Radeon HD 6320 graphics chipset with the hope that might fix things.

Alas, these changes haven't completely solved the problem. Suspend works fine three or four times -- and then it doesn't resume. I have to unplug the power supply and briefly remove the battery before the Eee will boot again.

At this point, I assume it is a hardware issue; some obscure bug in the BIOS. I will try writing to Asus support, but if I tell them I am running Linux I expect no help.

The disappointing thing for me is that suspend working flawlessly on my previous Eee, a 1001 HA.

Kropotkin 04-20-2012 04:45 AM

An utterly predicatable response from Asus support in response to my inquiry about this problem:

First off we would like to ask you to set the notebook back to factory settings.
This because we do not provide support for an own installati on of Linux on our notebooks.
We only provide support for the original setup of the notebook.

So in this case we cannot help you with problems under Linux.
At the moment, I am not convinced it is per definition a Linux problem, since having to unplug the power supply and remove the battery suggests a hardware issue, but I can't be sure, as I made the mistake of deleting the Windows partitions before installing Mint.

At this point, I have absolutely no idea what to do. Wipe Linux and return it to the store where I bought it with some lame excuse? Having a laptop without reliable suspend is a real nuisance.

All times are GMT -5. The time now is 01:10 AM.