-   Linux - Laptop and Netbook (
-   -   AMD Fusion E450 Graphics (

kauaianspunger 12-01-2011 11:03 PM

AMD Fusion E450 Graphics
I've got a Lenovo G575 laptop that I installed Debian Squeeze (stable) on, and I've been having trouble getting the video drivers working. I've got a AMD Fusion E-450 processor with an integrated Radeon HD6320. The fglrx drivers in the repositories are from Catalyst 10.9, I couldn't find any info on whether they support the HD6320 but I think they're too old. The included aticonfig give an error saying no supported cards were detected. I tried installing the newest fglrx from AMD, based on Catalyst 11.11, but I got an error with that, too. I was following this guide and got to the point where you generate .debs but it gave me an error. Here's the full command and error I got:

I also couldn't find my card in the supported hardware list at that wiki (, and when I downloaded the drivers from the ATI Catalyst page I selected E-350 because E-450 wasn't on the list, only E-250 and E-350. It's not just linux E-450 drivers that are missing, because I selected the chipset before the OS. This must be a mistake on their part, right? They wouldn't have released hardware without any drivers, would they?

Here's the output from lspci -vvx:

edit: I found some stuff on google after making this thread, I don't know why I didn't see it before. It sounds like they really did release the E-450 before releasing drivers for it, the hardware came out in August 2011 so hopefully we'll get something soon. People installed the Catalyst 11.8 drivers on Ubuntu, and it worked, but with worse performance than the opensource drivers. They did get it installed, though, and I'm hoping the 11.11 drivers are better.

jefro 12-02-2011 03:53 PM

Wonder if the drivers for HD 6320 would be suitable if available?

I had read another post about a clean install working but auto update messed up video. The solution was to install os then apply amd video drivers then let it update if you want.

kauaianspunger 12-04-2011 11:06 PM

I did a clean netinst install when I got this, so there was nothing to update, and the only thing I did before trying to get video drivers working was install bcm80211-firmware or something. I made a very minimal xorg.conf like someone suggested in my other thread here and tried using radeon and radeonhd drivers but both just gave me a black screen with a underscore cursor (as apposed to block cursor). I could type and have the text appear with the radeon driver, but with the radeonhd driver the cursor blinked a lot faster and alt+ctrl+F1 did nothing. Some people in the ubuntu thread I linked to in the 1st post had it working fairly well with the opensource radeon driver, and it didn't sound like they had to do anything but change the driver line in xorg.conf.

All times are GMT -5. The time now is 05:37 PM.