-   Linux - Laptop and Netbook (
-   -   AMD A6-3400M and Radeon HD 6520G issues (

dragonfire82 12-11-2011 04:38 PM

AMD A6-3400M and Radeon HD 6520G issues
I'm having issues with this hardware. Some people say the hardware is too new, but I have had it work on Ubuntu 11.04 and the installer of Fedora 15. Any other distro I have tried based off new version have booted into a black screen unless I use Radeon.modeset=0 then it hangs. I have tried Fedora 16 and waited a while for it to boot and it kicked to the terminal (no GUI) with the video card not having KMS enabled due to the modeset change. Otherwise, its a black screen like the display never turned on.

Another strange issue is on the ubuntu distros is the keyboard and mouse does not work. Many of the FN keys work, but that's it. If I plug an external mouse to it then I get the mouse only. No keyboard or touchpad works. BUT... Random time when I boot into ubuntu it will work. Never had a problem with kb/tp with Fedora. Oh, and KDE, regardless of distro, black screens or, if I use modeset, hangs.

For more specs if have the Toshiba Satellite L775-S7206. It is the AMD A4-3400M with Radeon HD 6520G video, 6GB DDR3 RAM, bluray player, webcam and Bluetooth. The WiFi is an Atheros brand which has no issues as well as a RealTek Ethernet port. HDMI output with 3 USB ports and a standard monitor port.

I have search through many forums trying to find an answer to this. Oh, and using a basic driver boots into Ubuntu 11.04 where (if the kb/mouse works at the time) I can update the fglrx and it works fine graphics wise.

Trying Fedora 15 with a basic driver and see of it works with GNOME 3.

Thanks for any leads and help!

EDIT: Installed Fedora 15 using the basic video driver option and installed the Radeon driver from AMD's website and got video up. Now if only F16 would work that way.

Well any help on getting the newer ubuntu/fedora distros working would be cool.

All times are GMT -5. The time now is 04:10 AM.