-   Linux - Laptop and Netbook (
-   -   Alps touchpad unrecognized (

rcrules 06-11-2004 01:50 AM

Alps touchpad unrecognized
Okay, I know that this issue has been covered it about a thousand different forums, but my problem seems to be a little different than those that I've read about so far. First, to cover the basics, I have a Compaq Presario R3140US laptop, running Gentoo 2004.1, in 64-bit mode (i.e.: x86_64) b/c it has an AMD Athlon 64 3000+ proc. I have read before that for an Alps or Synaptics touchpad, you need to set the device location to "/dev/input/event1". Well, on my system, for some reason, /dev/input/event1 doesn't exist! The only devices in /dev/input are "mice" and "event0". Now, when you do
cat /dev/input/mice
you simply get nothing, wether an usb mouse is plugged in or not. Also, when you do
cat /dev/input/event0
you get the output from the keyboard, in ultra-cryptic fashon. I have also tried /dev/psaux and /dev/mouse as alternates, both to no avail. Also, as mentioned above, a USB mouse connected also doesn't show up as /dev/input/mice for some reason as well. I know that there needs to be a driver installed for the touchpad, but I think I should still be able to see it in /dev/ and be able to cat it for some output, so I'm kind of at a loss with this.
Thanx for any help!

movery 06-14-2004 03:56 PM

i have exactly the same problem on fc2 on a 3400 athlon 64... did you find a solution?

dtor 06-22-2004 11:09 AM

OK, do you have psmouse and mousedev loaded? What about hiddev for USB mice?

rcrules 06-29-2004 03:31 PM

Well, I went back through the kernel configuration, and it turns out that I did not have support for PS/2 mice, nor did I have support for USB HID devices built in yet (do'h!), so I recompiled the kernel with those options build in. Now the USB mouse works when plugged in, so I get some functionality, but /dev/input/event1 still doesn't exist for the touchpad. I figure that I need to enable some other type of kernel option or load some other driver, in order to get it to recognize the touchpad... Any ideas?

dtor 06-29-2004 03:40 PM

You also need evdev module ("Event Interface" it's also in the "Input Devices" section).

Ok, nevermind, I see that you have /dev/input/event0 for keyboard...

Can I see the lsmod, .config, dmesg and "cat /proc/bus/input/devices" please? You can send it directly to

k-dub 07-06-2004 10:26 AM

Is there a solution? I have the same problem.

Sager 4080 laptop, Alps Glidepoint
kernel (2.6.7) has usb hid, ps2, and events interface compiled in
OS: Gentoo with
neither 'cat /proc/bus/input/devices' or 'lspci -v' show any reference to the touchpad
/dev/input/event0 is keyboard, /dev/input/{mouse0|event1} is PS2 Logitech wheel mouse

Oddly, the PS2 mouse is not detected at boot, because the laptop uses the same port for PS2 mouse _or_ keyboard. I have to unplug the mouse and plug it back in before it will work.

All times are GMT -5. The time now is 08:44 PM.