-   Linux - Laptop and Netbook (
-   -   adjusting screen brightness does not work in slackware 13.0 on asus laptop M70 series (

nezdravanul 09-11-2009 07:35 AM

adjusting screen brightness does not work in slackware 13.0 on asus laptop M70 series
hello, i just installed slackware 13.0 on this asus m70 series laptop(intel duo t8300, 4gb ram, ati radeon hd 3650 graphics. the problem is that i can not change/adjust the brightness level of the monitor. i tried to do that by pressing Fn+F5/Fn+F6 - not working. Tried from powermanager in the task bar - not working. is something i should manually install or configure?

thank you.

brianL 09-12-2009 08:19 AM

It's working OK on my Asus F5RL laptop. Could you run lsmod, and post the results then I can compare it with mine?

nezdravanul 09-15-2009 03:51 AM

Thank you Brian for your reply. In the mean time I solved the problem. It was about the light-sensor that activates automatically at every boot and did not allowed me to manually change the brightness. So after some googling,I found that it should be turned off in order to get the Fn+F5/Fn+F6, powermanager and/or Kpowersave to work.That laptop is actually not mine and when I wrote the thread I did't knew that it has a light sensor. Anyway,I solved this in Ubuntu/Kubuntu (because slackware seems to be a little complicate for the laptop's owner) by installing sysfsutils and adding in /etc/sysfs.conf this line "devices/platform/asus-laptop/ls_switch = 0" and then I set /usr/bin/gnome-power-manager as not executable because of the conflict with kpowersave. Now Fn+F5/Fn+F6 and kpowersave work ok. I don't Know if this is the solution for slackware, but if someone get the same problem should try to turn off the light sensor. There is "echo 0 > /sys/devices/platform/asus-laptop/ls_switch" that works only for session but it should be made permanent somehow.

p.s. I am sorry for my bad english

brianL 09-15-2009 06:39 AM

OK. Glad you sorted something out.

All times are GMT -5. The time now is 01:03 AM.