-   Linux - Laptop and Netbook (
-   -   ACPID scripts only work when restart acpid from terminal (

jasonkhonlaw 07-22-2004 03:27 PM

ACPID scripts only work when restart acpid from terminal
I have an ACPI script to turn off my screen when I close the lid on my laptop. This however doesn't work unless I open a terminal window and restart ACPID. If I then leave the terminal window open and hit the close lid button, the screen turns off great, however after I close the terminal, it no longer works. If I restart ACPID from the services applet in the menu, it says it restarts, but the script doesn't run.

Any help would be greatly appreciated..



weijie90 02-04-2008 10:24 PM

I have the same problem. Can anyone please help? Thanks!

th0gz19 07-31-2012 12:37 PM

this thread should not be left unanswered, it may help others..

anyway. i have the same problem with xcompmgr through acpid..
i want to turn off xcompmgr when i plug-out my ac-adapter.

when acpid starts from startup scripts or rc's on BOOT. that process would be running in root or in a virtual terminal. after logging in then "startx", i would open a terminal then restart acpid

$ sudo /etc/rc.d/rc.acpid restart

then the rc.acpid must be running inside X now not in the virtual terminal where it started in bootup.
the xcompmgr now works as what i wanted.. but i have to restart the acpid after opening a terminal "inside x".
i already tried restarting acpid through a virtual terminal, then the xcompmgr won't work again if i plug-out my ac-adapter. i can't think of any work around for this so i posted, anyone?

slacky90 10-23-2017 12:43 AM

This post is quite old now, but I recently was having this issue with acpid. I was trying to make my laptop go to hibernation when I closed the lid. My problem seemed that I was using /proc/acpid/button/lid/LID0/state for checking the state of the lid. When I changed that and started using acpid parameters in the script (those you pass with %e and you fetch with $1 $2 $3 $4) my issue was solved. Hope it helps someone.

All times are GMT -5. The time now is 10:37 AM.