-   Linux - Laptop and Netbook (
-   -   ACPI patch and kernel compile error (

crisponions 10-29-2003 01:45 PM

ACPI patch and kernel compile error
I have a dell inspiron 5100 and have been trying in vain to get the power management to work. I have downloaded the 2.4.22 sources applied the dsdt patch and created a hex file with the Dell-custom.......asl patch etc.

My problem is when I try to compile the kernel I get the following error.

make[3]: Entering directory `/usr/src/linux-2.4.22/drivers/acpi'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.22/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i686 -Os -nostdinc -iwithprefix include -DKBUILD_BASENAME=osl -c -o osl.o osl.c
osl.c: In function `acpi_os_table_override':
osl.c:236: `acpi_table_header' undeclared (first use in this function)
osl.c:236: (Each undeclared identifier is reported only once
osl.c:236: for each function it appears in.)
osl.c:236: parse error before ')' token
osl.c:236: warning: statement with no effect
make[3]: *** [osl.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.22/drivers/acpi'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.22/drivers/acpi'
make[1]: *** [_subdir_acpi] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.22/drivers'
make: *** [_dir_drivers] Error 2

I have tried everything I can think of, including deleting the sources and starting from scratch several times. Any help would be appriciated

lupin_the_3rd 10-29-2003 02:50 PM

try it using your current kernel configuration

crisponions 10-29-2003 05:08 PM

that is what I have been doing, I have also tried using the "safe" config that redhat 9 generated during install.

crisponions 10-29-2003 07:52 PM

Well, I got the battery monitor working which is mainly what I was concerned about, I will move on to suspend and sleep later.

Just a note I never got the patching of the kernel with the dsdt patch to work successfully, I ended up finding another post here that had a link to a different sert of patches and that worked.

All times are GMT -5. The time now is 11:20 PM.