LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Laptop and Netbook (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/)
-   -   [Ubuntu GUI] Changing GUI from Gnome to wmaker (https://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/%5Bubuntu-gui%5D-changing-gui-from-gnome-to-wmaker-320980/)

MangaManiac 05-07-2005 07:16 AM

[Ubuntu GUI] Changing GUI from Gnome to wmaker
 
First of all, hi to the people here! I do not often post here but I do look up a lot of of issues regarding Linux systems here and I often find answers but not this time. Maybe I'm looking incorrectly or I'm just using the wrong search terms but I cannot find an answer to the following question:

How does one change the GUI in a Linux system from Gnome to Windowmaker?

I'm running Ubuntu 4.0 (Warthog) on a Compaq M700 laptop. When I boot up it boots into Gnome and I'd like to change that into Windowmaker. I already apt-get installed wmaker but where do I change the setting that It'll boot into Windowmaker or at least give me te choice wether to boot into Gnome or Windowmaker? I'm pretty familiar with Linux with the commandline (running Debian web/file/mail server etc. for 2 years now) but I have no experience running GUI's etc at all!

If anyone could point me in to the right direction I should be able to change my GUI.

Owh yeah, I choose Windowmaker 'cause I use Windowmaker at work and I like the look/feel and way it works a whole lot better then Gnome (which I do not like a whole bunch).

Thanks in advance!

ultimatenoob 05-07-2005 07:18 AM

try:

Code:

switchdesk Windowmaker
and that should set that as your default GUI for when you reboot. No promises though, im pretty new to this whole cup of tea! Good luck to ya

MangaManiac 05-07-2005 11:35 AM

The switchdesk command is not recognized, both as user and as root. I also cannot apt-get install it. any other ideas? Perhaps some editing in xinit files or gdm? I do find a lot on this forum and on other sites but nothing which answers the question of how I might change my GUI.

masonm 05-07-2005 03:57 PM

Doesn't your gdm login screen have the option to selection the session type?

Just click the button and select windowmaker from the session type list before entering your user name and password to log in.

MangaManiac 05-07-2005 04:35 PM

Nope, it does not have that option. That's the first thing I tried, too bad it didn't work out that way :(

MangaManiac 05-07-2005 05:55 PM

Okay I found out how to start Windowmaker. I first kill off everything mentioning GDM, Gnome or X, then I start up "X" after which i run "./wmaker -display localhost:0" which of course is quite sluggish. Where does Ubuntu start X from after which it starts gdm(greeter) and so on? Which are the configuration files Ubuntu/X uses? Again, I know my way around in CLI but I find a whole bunch of configuration files, but mostly they are for Gnome (GDM etc.)

mccannmarc 05-08-2005 02:22 PM

Have you tried putting a new session script in /etc/X11/gdm/Sessions?

Duplicate one of the existing scripts in the folder and rename it to WindowMaker, then edit its script so it says:-
Code:

exec /etc/X11/xdm/Xsession wmaker
WindowMaker should now appear on your login screen as a selectable session

If this alone doesnt work then create two new files in /home called .xsession and .xinitrc

in both files type
Code:

exec wmaker
This should make WindowMaker selectable by using the "Default" session

Good luck to you and let me know how it goes.

Marc

MangaManiac 05-08-2005 02:57 PM

That did the trick. I can start up in Windowmaker now using default as Session. I could not use the /etc/X11/xdm directory seeing as it does not exist on my system, but I just used exec wmaker all the time. Now I will change the scripts and .xsession thingies untill I get it right. Next problem now is that Windowmaker gives me a huge headache because it gives me errors upon errors and also my keyboard settings changed from English to Dutch lol... ah well, I'll get that working soon enough.

Thanks mccannmarc, masonm and ultimatenoob for your help :)

mccannmarc 05-08-2005 03:17 PM

no problemo :D good luck with ur new problems!! lol


All times are GMT -5. The time now is 11:34 PM.