-   Linux - Kernel (
-   -   USB modem can be detected but device cannot be opened (

eryn 12-16-2009 10:01 PM

USB modem can be detected but device cannot be opened
Hi everyone,

I have encountered a problem here with my ready USB port on my computer.

I used an USB modem to test the USB port. After I plugged in the USB modem, and do the following action:

dmesg | grep tty

It shows me result as in reply #2. I think this should mean that my host controller is successfully detect the USB modem and convey the modem's information to the operating system.

By the way, my OS is Linux Debian 2.6.28-versalogic-intelm #1 PREEMPT i686. The USB modem I used to test is Huawei E160G.

The OS should assign a driver to the device. I think it might be the problem of the driver but I am not sure.

I have learned from the internet that we have to try to modprobe usbserial. However, my version of Linux did not allow this. It returns error as follows:

FATAL: Module usbserial not found.
Here is the result of lsmod.

Module                  Size  Used by
snd_pcm_oss            32128  0
snd_mixer_oss          12288  1 snd_pcm_oss
lm90                  13612  0
loop                  12556  0
pcspkr                  2304  0
snd_intel8x0          25884  0
snd_ac97_codec        91428  1 snd_intel8x0
ac97_bus                1664  1 snd_ac97_codec
serio_raw              4740  0
snd_pcm                62344  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              17668  1 snd_pcm
snd                    46388  6 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
snd_page_alloc          8072  2 snd_intel8x0,snd_pcm
i2c_i801                7952  0
e100                  29196  0
mii                    4864  1 e100
evdev                  8196  0

Thank you.

Eryn Ng

eryn 12-18-2009 03:34 AM

No one get the same problem as me and got the solution?

I have search for information and tried several methods to get this done. But I still cannot get the problem solved.

Here is my outcome when I run lsusb

Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The device is correctly been detected. But when I run dmesg | grep tty, I get this.

[    0.404757] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    0.404927] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

There is no ttyUSB exists. These two ttyS device is not belong to USB modem. Before I update my BIOS to a later version that claimed to 'Fixed Legacy USB keyboard/mouse support when plugged into USB ports 2 and 3' (*USB ports 2 and 3 is the USB expansion port on my motherboard.), the USB modem works just fine, it is auto detected and connected.

I tried to modprobe usbserial, however, from the net resources, my version of Debian do not allowed me to do this. It should be auto detected.

What should I do to fix this?

eryn 12-18-2009 03:50 AM

I also tried to run a sample code from gammu.

Here is my result.

[Gammu            - 1.25.92 built 01:19:03 Dec 16 2009 using GCC 4.3]
[Connection      - "at19200"]
[Connection index - 0]
[Model type      - ""]
[Device          - "/dev/ttyUSB0"]
[Runing on        - Linux, kernel 2.6.28-versalogic-intelm (#1 PREEMPT Thu Feb 5 00:46:52 UTC 2009)]
[System error    - open in serial_open, 2, "No such file or directory"]
Init:GSM_TryGetModel failed with error DEVICENOTEXIST[4]: Error opening device, it doesn't exist.
ERROR: Error opening device, it doesn't exist.
user@debian:~$ gammu --identify
Error opening device, it doesn't exist.

eryn 12-29-2009 03:04 AM

Hi there,

Anyone have an idea on how to get the modem working?
I just need it to sms.

It have been half a month that I deal with the problem and still not yet solved.

Thank you in advance.

eryn 12-29-2009 09:33 PM

I have look through a lot of website.
Many suggesting the 'modprobe' method.
But my version of Debian do not allow me to do that.

What can I do?

I am really running out of idea and resources now.

All times are GMT -5. The time now is 11:10 PM.