LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices



Reply
 
Search this Thread
Old 04-08-2009, 06:08 AM   #1
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 661

Rep: Reputation: 66
Unhappy usb in mount/unmount loop


Dear all

I am using fedora 9 kernel version 2.6.27.7 on lenovo N100 notebook.

I am facing a strange problem from long time. When i insert usb stick in my laptop, i automatically mount that, but after few seconds it unmount my usb stick. Loop of mount umount continues unless in remove usb stick from usb port. Physical port of my notebook in work properly in windows with same usb stick, so i am sure that there is no hardware problem.
I am unable to find out reason of thsi problem. Plz guide me for same.

dmesg show following detail for problem

usb 1-1: new high speed USB device using ehci_hcd and address 2
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: New USB device found, idVendor=0951, idProduct=1603
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: DataTraveler 2.00000023160
usb 1-1: Manufacturer: Kingston
usb 1-1: SerialNumber: 0000023160
Initializing USB Mass Storage driver...
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb 1-1: USB disconnect, address 2
usb 1-1: new high speed USB device using ehci_hcd and address 3
usb 1-1: configuration #1 chosen from 1 choice
scsi3 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usb 1-1: New USB device found, idVendor=0951, idProduct=1603
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: DataTraveler 2.00000023160
usb 1-1: Manufacturer: Kingston
usb 1-1: SerialNumber: 0000023160
usb 1-1: USB disconnect, address 3
usb 1-1: new high speed USB device using ehci_hcd and address 4
hub 1-0:1.0: unable to enumerate USB device on port 1


Thanks

Last edited by vishesh; 04-09-2009 at 02:39 AM.
 
Old 04-09-2009, 07:28 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
In my experience automounting is not reliable accross all motherboards and device types. What I'd advise is turning it off completely, then mounting the memory stick manually... the first thing I always do when I install a new distro is to immediately disable all "auto" mounting processes and / or functions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
usb mount and unmount vishesh Linux - Newbie 5 12-05-2008 04:57 AM
Mount and unmount Hargibi Linux - Software 9 09-26-2005 08:11 AM
mount and unmount d1l2w3 Linux - Hardware 4 05-15-2005 08:32 AM
mount / unmount Lostman Linux - Newbie 3 11-09-2003 01:15 AM
mount - unmount? randon Red Hat 3 10-10-2003 01:31 PM


All times are GMT -5. The time now is 09:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration