LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel
User Name
Password
Linux - Kernel This forum is for all discussion relating to the Linux kernel.

Notices


Closed Thread
  Search this Thread
Old 10-27-2020, 09:34 AM   #1
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,494

Rep: Reputation: 242Reputation: 242Reputation: 242
Turning numlock off at boot


The BIOS enables NumLock on boot, not settable in its setup. I want the kernel to turn numlock off at boot time. How do I do this? kernel 5.9.1
 
Old 10-27-2020, 09:45 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 15,643

Rep: Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127Reputation: 5127
do you mean something like this: https://jvsg.github.io/blog/2018/disable-numlock/ ?
 
Old 10-27-2020, 09:47 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,768

Rep: Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843
Quote:
Originally Posted by RandomTroll View Post
The BIOS enables NumLock on boot, not settable in its setup. I want the kernel to turn numlock off at boot time. How do I do this? kernel 5.9.1
I don't know about the kernel, but you can use setleds to turn off numlock
 
Old 10-27-2020, 11:32 AM   #4
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,494

Original Poster
Rep: Reputation: 242Reputation: 242Reputation: 242
Quote:
Originally Posted by pan64 View Post
do you mean something like this: https://jvsg.github.io/blog/2018/disable-numlock/ ?
Doesn't work. Not only does it not-work, it disables the NumLock key: pressing it changes the state of the LED but not the lock state.

Quote:
Originally Posted by bathory View Post
I don't know about the kernel, but you can use setleds to turn off numlock
That's too late.

The computer enables NumLock at boot, the kernel turns it off almost immediately, but it turns on again for each virtual terminal. I also tried clearing VC_NUMLOCK in kbd_kern.h, to no avail.

Last edited by RandomTroll; 10-27-2020 at 11:57 AM.
 
Old 10-27-2020, 12:27 PM   #5
rinaldij
Member
 
Registered: May 2011
Location: Oklahoma
Distribution: Slackware64 current
Posts: 37

Rep: Reputation: 6
Put this in your rc.local

for n in 1 2 3 4 5 6 7 8 ; do setleds -num < /dev/tty$n ; done

season to taste.
 
1 members found this post helpful.
Old 10-27-2020, 01:08 PM   #6
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 13,264

Rep: Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921Reputation: 3921
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Display not turning off when using xrandr --output <display> --off. Instead it just turns black. bluesk Linux - Newbie 5 07-18-2020 11:24 AM
numlock comes on turning on when booting up and when login screen appears hamster Mandriva 2 02-21-2006 10:09 AM
Keyboard NumLock is always off at startup jborges Linux - Hardware 0 11-16-2004 05:04 PM
Set Numlock Off By Default On A Suse 9.1 Laptop? FluffyPanda Linux - Laptop and Netbook 1 07-28-2004 04:49 AM
left numeric keyboard is typing numbers (problem with NumLock on/off) zstingx Linux - General 0 11-10-2003 10:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Kernel

All times are GMT -5. The time now is 10:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration