-   Linux - Kernel (
-   -   True Image boot problem: cmov feature not present on CPU (

deadkenny 12-06-2008 08:11 AM

True Image boot problem: cmov feature not present on CPU

I'm not really sure what's the right forum for this, but seemed to make sense here as it's a kernel boot issue.

I've got True Image Home 2009, which although I bought to backup my Windows boxes, it also comes with a boot CD that turns out (I believe) to be a linux variant of some sort. The specs also say it supports linux filesystems.

So I thought I'd have a go on my mail server (which runs Fedora), and see if it will boot and try and do a backup image. Would be great for when I make major changes on the server.

However on booting it comes up with this:

"This kernel requires the following features not present on the CPU: cmov
Unable to boot - please use a kernel appropriate for your CPU."

and that's as far as it will go.

Now, the machine is somewhat antique, but then I never believe in throwing out old machines if it can do the job (it's just a mail and low use web server and performs fine). It's an old AMD K6-2 400Mhz.

It's been running versions of Red Hat through to Fedora 8 (currently) with no problem at all. It's currently running kernel.

I understand there may be some options I can give to the True Image boot, either through a key press on boot, or I can provide options when I burn the image to CD using their utility to do so. Would there be any such option to make it work? I don't specify anything for Fedora though.

fordeck 12-06-2008 09:43 AM

I'm not sure this is relevant, but here is a link that talks about a similar issue:

you might try there suggestion as follows:

{QUOTE-> Please try the following workaround:
Please boot your computer from the Acronis True Image rescue disc (the full version) and press F11 key when the "Starting Acronis Loader..." message appears. After you get the "Linux kernel command line" prompt, please modify it in the following way:

quiet acpi=off noapic <-QUOTE}



deadkenny 12-06-2008 03:12 PM

Cheers. Gave that a go, but sadly I just get the same error. Looking around it seems I may need the kernel recompiled without cmov to get it to work perhaps? Job for Acronis really, so time to contact them.

Their minimum spec is a Pentium, and wouldn't a K6-2 come above a Pentium? So in which case they should support it.

crxssi 09-05-2009 09:31 AM

The cmov issue is a known problem not only with Acronis but even general distros like Centos, Mandriva, etc.

The problem is that certain CPU's, even though they are "pentium class", lack the cmov instruction. At some point a few years ago, the default 586/686 build of the booter (isolinux?) started requiring cmov.

This totally hosed VIA C3 processors and AMD K6/2. When I upgraded to TrueImage 10, Acronis support eventually sent me an updated iso to boot that would work on CPU's without cmov.

Unfortunately, version 10 doesn't support the default block sizes of newer ext3 filesystems. So I upgraded to TrueImage 2009. Ug, it has the exact same cmov issue as before, and I am still working with support, trying to get them to "relearn" how they fixed it last time.

All times are GMT -5. The time now is 06:26 AM.